Jump to content

Error: SecureChannelFailure When Checking for Application Updates


DarWun
 Share

Recommended Posts

DarWun

For about the past week, checking for Emby updates fails with the following error:  "SecureChannelFailure (The authentication or decryption has failed.)".  A log file has been attached.

 

 

server-63655081335.txt

Link to comment
Share on other sites

github has updated to require tls 1.2, which mono 5.2 should support but apparently not out of the box for some reason. I think some adjustment might be needed for the synology release.

Link to comment
Share on other sites

mikeraburn

Thanks for the link to this Luke.

 

Can't believe I missed this while searching prior to MY post.

Link to comment
Share on other sites

We are looking into it. On most Synology systems there is no problem, which leads us to believe there might be some sort of system configuration that is affecting it.

Link to comment
Share on other sites

DarWun

We are looking into it. On most Synology systems there is no problem, which leads us to believe there might be some sort of system configuration that is affecting it.

Thanks @@Luke.

Link to comment
Share on other sites

adrianwi

This has also started to appear on the FreeBSD version.  Given I'm not updating from github it's not a problem, although nobody likes to see red error messages :)

Link to comment
Share on other sites

This has also started to appear on the FreeBSD version.  Given I'm not updating from github it's not a problem, although nobody likes to see red error messages :)

I can confirm this as well, using 3.3.0.0

Link to comment
Share on other sites

DarWun

You could try this procedure to set the environment variable so that mono will use google's boringssl, which may resolve it:

 

http://www.mono-project.com/docs/about-mono/releases/4.8.0/

 

REquires mono 4.8.1+.

I did try this a few days ago on my synology NAS.  I received an error of some kind.  I googled a bit to try and better understand the issue, and ended up getting confused on account of my limited knowledge of all things linux.  Normally I'll stubbornly hammer away at stuff like this until I get things to work.  But in this case I decided to wait as I was worried I would bork my entire setup.  Now that you have "officially" pointed towards this as being a potential solution I'll take another look at it when I get home tonight.

Edited by DarWun
Link to comment
Share on other sites

pr3dict

Not to be like anti solution but couldn't there be a different way the server gets updates instead of relying on this function that no longer seems to work as designed?

Link to comment
Share on other sites

Not to be like anti solution but couldn't there be a different way the server gets updates instead of relying on this function that no longer seems to work as designed?

 

The Synology server doesn't auto-update. The only thing affected here is the display of whether or not an update is available. Display only. And no that's not really a solution. 

Link to comment
Share on other sites

pr3dict

My debian system doesnt auto update either. When I get an email t hat a new release has come in, I shutdown the server, update, then turn it back on and all is good...

 

All I'm saying is that, this used to work as designed and now it doesnt and instead of changing some variables around that isnt really recommended why dont we come up with a new way to tell the individual servers there is an update. 

 

I'm not a programmer so I dont want to pretend I have the answer but I do know of a plethora of different applications that get told when there is an update so there must be other options out there.

Link to comment
Share on other sites

This is only affecting a limited set of users. Specifically, a subset of users using mono-based installations, which the Synology package is still using. None of the Windows users will see this, or any of the Linux, Docker, MacOS, etc.

 

We're not going to change the entire way we report about updates when it would be better to just resolve the problem. What happens when every web server requires TLS 1.2, what then? Since it is not affecting everyone, that's the reason I asked if you might be willing to try something.

Link to comment
Share on other sites

pr3dict

wait im confused... I'm on debian aka linux and im having the issue. Does that mean its not mono related?

Link to comment
Share on other sites

wait im confused... I'm on debian aka linux and im having the issue. Does that mean its not mono related?

 

You might be running our legacy install package, which is based on mono. If you're not sure please see how to report a problem. Thanks.

Link to comment
Share on other sites

Wait im confused even more... Im totally willing to help you fix this but now im super duper confused....

 

What is a legacy installation???? When did we switch that or what not. 

 

Ok so you are running our OBS based packages, and that is indeed our legacy installation package. You can continue to use this for as long as you like. This edition does not auto-update either so your update process is just the typical apt-get update linux command. We are no longer doing any new development on these packages (but we will post new server versions) so you would just have to ignore the error, which really shouldn't bother you because as I previously mentioned, it is only used to display if an update is available. it's not actually used for updating.

 

If you would like to switch to our newer installation package, there are numerous benefits: this error goes away, faster performance, more stable, self-contained dependencies, which means no more mono, etc.

 

However, this would require you uninstall your current package, and then install the new package fresh: https://emby.media/download

Link to comment
Share on other sites

pr3dict

Ok so you are running our OBS based packages, and that is indeed our legacy installation package. You can continue to use this for as long as you like. This edition does not auto-update either so your update process is just the typical apt-get update linux command. We are no longer doing any new development on these packages (but we will post new server versions) so you would just have to ignore the error, which really shouldn't bother you because as I previously mentioned, it is only used to display if an update is available. it's not actually used for updating.

 

If you would like to switch to our newer installation package, there are numerous benefits: this error goes away, faster performance, more stable, self-contained dependencies, which means no more mono, etc.

 

However, this would require you uninstall your current package, and then install the new package fresh: https://emby.media/download

 

When did this new install package come out? Also, is there a way I can keep my config the same?

Link to comment
Share on other sites

A few months ago, however, we do not want to force anybody to have to switch so that's why there wasn't a whole lot of fanfare about it. You could use the backup plugin for your config.

Link to comment
Share on other sites

pr3dict

A few months ago, however, we do not want to force anybody to have to switch so that's why there wasn't a whole lot of fanfare about it. You could use the backup plugin for your config.

 

 

oh man oh man this is super scary but I'm going to do it. Break my whole system but im ready lol

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...