Jump to content

New Thecus Package


Luke

Recommended Posts

Unfortunately, the latest emby program in emroid can't be used with version 3.2.70.0. I can't install newer ones. When will it be resolved to install the latest server file on the x86 platform?

Link to post
Share on other sites
  • 2 months later...
throgmorton

Tried this again with the latest mod ( 3.5.2.0 ) on my Thecus N5550.

So current status, the server software WORKS! Great news and is a lot faster than the older pre .Net Core versions.

 

But, the Thecus OS still does not like the current mod version very much... after installation of the mod, you need to 'start' the module in the thecus manual application installation area.

This gives no feedback after trying for a while... a good working mod will tell you that it has been started. Trying to start it again results in nothing.

But this does actually trigger the software to run! So even though you get no feedback in the thecus admin area, the mod is actually running and working.

 

Secondly if you reboot the NAS, you need to trigger the start manually again, because after reboot thecus OS will tell you the emby server mod restarting is not working.

 

So overall, it works, but it needs to be trigger manually to start ( even after NAS reboot ) and you won't see visual confirmation in the thecus admin panel.

 

So @@Luke thought I would try again and give some feedback and I'm having a very similar experience as @Glenn:

 

Thecus N7770-10G w/ firmware version: V2.06.03.1 (2018-11-16)

Emby Server Package: emby-server-thecus_4.1.0.1_x86_64.mod

 

Basically as Glenn states the software installs properly and once you click to start the module it seems to respond correctly with the caveat that it never gets a response that the module has started (in the admin panel).

 

The one difference between Glenn's version is that if I reboot the machine it seems to stall the machine during bootup.  What I assume is happening is that it tries to start the Emby module but never receives a response back that it started and so just hangs there.  A successive reboot seems to boot the machine normally, but I would need to restart the Emby Server module manually as Glenn stated.

 

I think its very close to functional, there is just something missing telling the Thecus unit that the module successfully started.

Link to post
Share on other sites
  • 4 weeks later...

for guys running on OS5 and having the module installed, just edit the file /raid/data/module/cfg/module.rc/EmbyServer.rc

Find this line

 

$APP_DIR/bin/emby-server &

and change it to

 

$APP_DIR/bin/emby-server > /dev/null 2>&1 &

For Emby developers, add this change in the module.rc script, to fix the hanging issue on OS5

  • Like 1
Link to post
Share on other sites

Just a heads up, I've removed the link from the first post and going forward you can find this package from the download page of our website:

 

https://emby.media/download

 

It's under the NAS section, then select Thecus.

 

Thanks guys.

 

The links for the 64bit software are valid, but the Emby app does not appear in the integrated appstore under Thecus OS7 nor does it appear in the Thecus online webstore. Additionally the instructions mention that manual download by PC is required for OS5 & 6, but no download links are supplied - I am searching for the most recent ARM version of Emby for my N2350 - any chance the new release will support me? many thanks!!

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...
blakestone

Thecus N7510 (v2.06.02.10) OS5 64bit

Hello,
I am trying to install Emby for the first time and need some help.
I have downloaded the file and it say that OS5 requires dependencies which I have found on the Thecus App page but only older versions of these files:

- Required: Mono v4.4.0.0 || Thecus App: Mono v3.4.0.0
- Required: ffmpeg v3.1.1.0 || Thecus App: ffmpeg v2.2.1

Does anyone know where I can obtain the required versions of these dependencies?

 

Edit: found it here: https://emby.media/community/index.php?/topic/48824-327000-download/?p=464000 :)

Edited by blakestone
Link to post
Share on other sites

Thecus N7510 (v2.06.02.10) OS5 64bit

 

Hello,

I am trying to install Emby for the first time and need some help.

I have downloaded the file and it say that OS5 requires dependencies which I have found on the Thecus App page but only older versions of these files:

 

- Required: Mono v4.4.0.0 || Thecus App: Mono v3.4.0.0

- Required: ffmpeg v3.1.1.0 || Thecus App: ffmpeg v2.2.1

 

Does anyone know where I can obtain the required versions of these dependencies?

 

Edit: found it here: https://emby.media/community/index.php?/topic/48824-327000-download/?p=464000 :)

 

Since you have a 64-bit model, it sounds like you can just use the install process listed on our website rather than going through all that:

https://emby.media/nas-server.html

Link to post
Share on other sites
blakestone

This link says you need OS7 in order to do that, OS5 and OS6 require those dependencies?

 

Also I ran into the same bug where clicking START in the Thecus Apps page does not show the application running - however it is running.

Also the first film I tried the Video and Audio was out of sync by 2-3 seconds.

Also out of about 800+ films I have it only downloaded 8 covers - I click refresh metadata and it says refreshing but nothing ever happens?

Edit: I am using this with a  Emby app on a "ROKU Streaming Stick Plus" - https://www.roku.com/products/streaming-stick-plus

Edited by blakestone
Link to post
Share on other sites
  • 1 year later...
On 7/15/2020 at 1:21 PM, Kanishka said:

Is there an ARM7 build available for Thecus N2350 NAS? 

No but we'll investigate. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...