Jump to content

Playback error with docker container


alc86

Recommended Posts

Hi,

Today i tried to use Emby on my Qnap NAS but I am struggling with the transcoding. The idea is to use the emby docker container (official) with the container station. The server runs without problems but transcoding does not work.
NAS: TS-431XeU with latest versions of QTS and container station.
Emby Docker container from docker hub.

I have also attached the screenshot of the Log file and the error message.

post-283145-0-90546300-1517853584_thumb.png

post-283145-0-42394200-1517853591_thumb.png

Link to post
Share on other sites

I know that there is a different docker image for arm32v7. This is the one which I have already installed. Ther server i running well only the playback does not work.

Link to post
Share on other sites

ok sorry. I use the container station on my QNAP and have selected the emby/embyserver image with the arm32v7 architecture. So which one from docker hub should I use ?

post-283145-0-41578200-1517901370_thumb.png

Link to post
Share on other sites



[s6-init] making user provided files available at /var/run/s6/etc...exited 0.                                                                                                                                                                                                                                              

[s6-init] ensuring user provided files have correct perms...exited 0.                                                                                                                                                                                                                                                      

[fix-attrs.d] applying ownership & permissions fixes...                                                                                                                                                                                                                                                                    

[fix-attrs.d] done.                                                                                                                                                                                                                                                                                                        

[cont-init.d] executing container initialization scripts...                                                                                                                                                                                                                                                                

[cont-init.d] done.                                                                                                                                                                                                                                                                                                        

[services.d] starting services                                                                                                                                                                                                                                                                                             

[services.d] done.                                                                                                                                                                                                                                                                                                         

Failed to initialize CoreCLR, HRESULT: 0x80004005                                                                                                                                                                                                                                                                          

[cont-finish.d] executing container finish scripts...                                                                                                                                                                                                                                                                      

[cont-finish.d] done.                                                                                                                                                                                                                                                                                                      

[s6-finish] syncing disks.                                                                                                                                                                                                                                                                                                 

[s6-finish] sending all processes the TERM signal.                                                                                                                                                                                                                                                                         

[s6-finish] sending all processes the KILL signal and exiting.



Edited by alc86
Link to post
Share on other sites

Both arm32v7 docker containers use hardware floating point (armhf). You qnap device is most likely arm soft float like almost every NAS out there, unfortunately the dotnet runtime doesn't support soft-float arm yet so we can't provide a container for this architecture.

Link to post
Share on other sites

Hi,

 

Now I have installed Qmono + ffmpeg + emby on my NAS from the offical Qnap Forum and I still get the "System.Exception: Error starting ffmpeg".

 

Qmono : Qmono TS-X41 (this is the only one which was posible to install) Version 5.4.1.6.0

ffmeg: ffmpeg_3.4.0_armx41 (this is the only one which was posible to install) Version 3.4.0

Emby: Emby TS-NASARM Version 3.2.70.0

 

I have set the FFmpeg path to /mnt/ext/opt/medialibrary/bin/ffmpeg.  

emby_server.txt

FFmpeg_log_1.txt

FFmpeg_transcode_2.txt

FFmpeg_transcode_3.txt

Link to post
Share on other sites

the ffmpeg build appears to be extremely old:

ffmpeg version 2.8.5 Copyright (c) 2000-2016 the FFmpeg developers

and is potentially missing libraries:

No decoder for stream #0:1, filtering impossible
Error opening filters!
Link to post
Share on other sites

Based on the fact that ffmpeg is not printing anything to the log, from past experience this looks to be permissions related. In other words, the emby server process does not have permission to read that file.

Link to post
Share on other sites

@@alucryd

 

Any idea why the first docker image was running well beside the playback ? This image I have downloaded from docker hub emby/embyserver and I have selected arm version. Last week this was availible but now only 3.2.70, beta and latest options are there.

post-283145-0-19256100-1518119509_thumb.png

Link to post
Share on other sites

@@alc86 We now have separate repositories per architecture. You can use emby/embyserver_arm32v7 or emby/embyserver_arm32v7_neon if your cpu supports neon optimizations, but they probably won't work as I'm pretty sure all qnap devices are soft float. Was the previous image you're referring to mono-based? In that case it was probably soft float, but unfortunately it's not possible with dotnet core yet.

Edited by alucryd
Link to post
Share on other sites

@@alc86 We now have separate repositories per architecture. You can use emby/embyserver_arm32v7 or emby/embyserver_arm32v7_neon if your cpu supports neon optimizations, but they probably won't work as I'm pretty sure all qnap devices are soft float. Was the previous image you're referring to mono-based? In that case it was probably soft float, but unfortunately it's not possible with dotnet core yet.

 

Yes it was mono based, so he will have to stick with the QNAP community package for now.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...