Jump to content

PolyMorphTV Plugin


BeppoMonkeyBoy

Recommended Posts

So I know this was discussed earlier in the builds but is it still in plans for it to move the original file to like a temp trash that way we as the user can delete them after the queue has completed?

Link to comment
Share on other sites

  • 2 weeks later...
BeppoMonkeyBoy

So I know this was discussed earlier in the builds but is it still in plans for it to move the original file to like a temp trash that way we as the user can delete them after the queue has completed?

 

Yes, I've just been superbusy doing the day job and with the family.

 

I've have just pushed out a compatibility update, as I've only just become aware of polymorph not working at all, so that should now be fixed.

Link to comment
Share on other sites

  • 3 weeks later...

Getting back into looking @ polymorph, there are some issues I am concerned about.

 

1. I initially didn't realize that I had to clear the attributes of all the files. Polymorph will hang forever if the attributes are not cleared on a file it is trying to process. Got that resolved.

 

2. Do not like the fact that it leaves the mkv files after the conversion. This one is a biggie for me. I will look for a solution to this.

 

3. I do not like Polymorph adding the resolution size to the name. I prefer it leave all file names intact.

 

4. Polymorph does not convert all MKV files. It leaves many unconverted. Testing this, I noticed there were some errors in the files it did not do, although the errors were very minimal and I could convert them manually. Polymorph needs a better method of conversion for files with minimal errors. Many IPTV source material sometimes have a few minor issues.

 

5. Seems to only do videos in the Movies and TV Shows categories. I also have a Music Video folder and it didn't do those. I also have a TV Archive folder and it selectively picked some and not others to do.

 

6. There needs to be a log created of videos that Polymorph did not convert for whatever reason.

 

7. Need to add settings to the plugin to address some of these issues.

 

8. There are no FAQ's or guides for this plugin.

 

9. The only way to turn this plugin off is to uninstall it.

 

This plugin is not worth paying for with these issues.

Link to comment
Share on other sites

BeppoMonkeyBoy

1. First I’ve heard of that, what attributes are you referring to?

 

2. That’s going to be a config option at some point, bottom line at the moment is that if your file gets deleted I don’t want to get the blame.. so I was planning to have the option to move file to a common folder, to be fair.. I myself use Plex to show me duplicates and delete the old ones.

 

3. I can stop it doing that.. but I was going to make it a config setting.

 

4. It uses ffmpeg, and it will log what it’s doing in your Emby log, be intesting to see what’s its doing though, do the files have multiple streams or something else in common.

 

5. That’s in the plan.

 

6. Like I said it’s in the Emby main log.

 

7. In the plan.

 

8. Most of it is covered in the description to be honest.. I’m not sure what else needs explaining until I add more user settings.

 

9. Not true, you can simply remove the scheduled time from the task so it never runs, you can do that will all the plugins.. for example my movies are left alone..

Link to comment
Share on other sites

1. First I’ve heard of that, what attributes are you referring to?

 

 - Read Only needs to be cleared.

 

2. That’s going to be a config option at some point, bottom line at the moment is that if your file gets deleted I don’t want to get the blame.. so I was planning to have the option to move file to a common folder, to be fair.. I myself use Plex to show me duplicates and delete the old ones.

 

 - Should be an option. Having two files makes the library a mess.

 

3. I can stop it doing that.. but I was going to make it a config setting.

 

 - A setting would be great.

4. It uses ffmpeg, and it will log what it’s doing in your Emby log, be intesting to see what’s its doing though, do the files have multiple streams or something else in common.

 

 - I saw simple PVR timestamp errors. Easily correctible by re encoding. Seems if Polymorph see errors it abandons the convert

 

5. That’s in the plan.

 

 - Much needed. Polymorph needs to run on a per library basis. Maybe an option in the library settings?

 

6. Like I said it’s in the Emby main log.

 

 - didn't see any errors in the Emby log for non converted videos. Better if Polymorph had its own log.

 

7. In the plan.

 

 - good. Sooner the better.

 

8. Most of it is covered in the description to be honest.. I’m not sure what else needs explaining until I add more user settings.

 

 - Maybe just explain what gets converted and any other things that may affect conversions

 

9. Not true, you can simply remove the scheduled time from the task so it never runs, you can do that will all the plugins.. for example my movies are left alone..

 

 - Ok, a great item to add to the guide. Found out about the schedule by accident.

 

here's another one.

10. Subtitle extraction fails when run. Maybe because it can't find any?

5d61b8602cee6_emby17.jpg

 

Edited by dcol
Link to comment
Share on other sites

  • 4 weeks later...

I am still unable to convert any MKV's. Just sits at 0% for 2 days now.

I even tried manually converting all my MKV's and then just put one in the folder and it still won't do it.

There are no errors in the log. Sorry I paid for this. Never worked. Also subtitle extraction always fails (see above)

 

This plugin is useless until it works and replaces the original file.

Edited by dcol
Link to comment
Share on other sites

BeppoMonkeyBoy

Please post your emby log, I can't replicate your issue with the read only flag, the full emby log will tell me the exact ffmpeg commands the plugin uses, so I can try and replicate on my testing rig, it may be wiser to pm a link to full logs. Polymorph logs events to the main log as well as creating its own logs per action. It may seem a daft question but do you have write access to the folders that contain your media? If the emby service cant create the new file it will just return an error 

Link to comment
Share on other sites

I know about the write issue. I do have full access to those folders.

 

I think what is going on is Polymorph doesn't keep track of what it completed. When it is run, it sees the already converted MKV's and tries to process them again, but this time it gets stuck because the MP4 already exists. You really need to delete the original file or skip the MKV if it sees a matching MP4.

 

If I place a new MKV in the folder, it is converted ok. When Polymorph runs again, as in the schedule. It gets stuck on the MKV it did in the previous conversion.

Polymorph will be stuck until I remove the old MKV's then restart Emby. The ONLY way to unstick Polymorph is to restart Emby

Edited by dcol
Link to comment
Share on other sites

BeppoMonkeyBoy

I know about the write issue. I do have full access to those folders.

 

I think what is going on is Polymorph doesn't keep track of what it completed. When it is run, it sees the already converted MKV's and tries to process them again, but this time it gets stuck because the MP4 already exists. You really need to delete the original file or skip the MKV if it sees a matching MP4.

 

If I place a new MKV in the folder, it is converted ok. When Polymorph runs again, as in the schedule. It gets stuck on the MKV it did in the previous conversion.

Polymorph will be stuck until I remove the old MKV's then restart Emby. The ONLY way to unstick Polymorph is to restart Emby

It should be skipping 

Link to comment
Share on other sites

It should be skipping 

 

It doesn't. What could cause this? I can repeat with same results every time.

Edited by dcol
Link to comment
Share on other sites

@Bepp0MonkeyBoy , Any answer to this issue, other than 'doesn't happen to me' or 'Gee, shouldn't do that'?

I cannot use Polymorph at all. Why did I pay for this? Where's the support?

Does this work for any users? And yes, I am really frustrated with this plug-in.

Edited by dcol
Link to comment
Share on other sites

@Bepp0MonkeyBoy , Any answer to this issue, other than 'doesn't happen to me' or 'Gee, shouldn't do that'?

I cannot use Polymorph at all. Why did I pay for this? Where's the support?

Does this work for any users? And yes, I am really frustrated with this plug-in.

 

This is just a guess, but i would think that attaching the server log to your issue reports will allow him to provide more detailed responses.

Link to comment
Share on other sites

BeppoMonkeyBoy

@Bepp0MonkeyBoy , Any answer to this issue, other than 'doesn't happen to me' or 'Gee, shouldn't do that'?

I cannot use Polymorph at all. Why did I pay for this? Where's the support?

Does this work for any users? And yes, I am really frustrated with this plug-in.

 

I posted a new version last night, that should deal with the skipping issue that you reported, i have asked for logs from you but you havn't provided any, so i'm kinda going blind. the plugin does provide loging, in both the main log and its own ffmpg specific logging. 

Link to comment
Share on other sites

Thanks for the update, but....

 

I Installed the update and it seems to be now getting through the list, but logging a lot of ffmpeg errors. But maybe I need to wait and see what it did when it has completed.

I have attached the log and it shows, as an example, errors on every conversion of the show iZombie. The source MKV is fine.

 

Once again. There is nothing wrong with any of my MKV files. And I would still like to see an option to delete the original MKV file

embyserver.txt

Edited by dcol
Link to comment
Share on other sites

Also noticed that when I manually run Polymorph from the Scheduled Tasks it instantly showed finished, even though it is running in the background. The percentage bar no longer shows completion percentage.

 

Restarted the server and tried running the convert again. get lots of ffmpeg errors showing 'streams and format are both null'. Maybe it is checking the MP4 before it has converted it, idk. Here's the latest log

embyserver.txt

Edited by dcol
Link to comment
Share on other sites

  • 3 weeks later...

Are we ever going to get the much needed update? I HIGHLY recommend no one waste their money on this until it is a usable plug-in. Right now I feel scammed.

Required at the bare minimum, have per library conversions and option to delete the original file. I can't use this until these features are implemented.

Edited by dcol
Link to comment
Share on other sites

  • 1 month later...
FredMuppeteer

This may be a silly question - how do I see which files it has converted after it has run?

 

Also is there a way to configure any of the settings?

Link to comment
Share on other sites

There are no settings at all. This plug-in is very basic with no options. I cannot even use it until it is updated which I suspect, being this long, will never be. Emby should remove it from their list. This plug-in is useless. Especially with the new convert features.

Link to comment
Share on other sites

  • 1 year later...

Hello, I'm having a problem with the "PolyMorph" Plugin, which when I start to extract subtitles it claims error in seconds (below I leave the Logs), in other cases it shows that it is executing the action, however it doesn't walk the process bar and stays hours stuck there. I thought it might be because of the size of my library, so I reduced it to test it and it didn't matter.

 

 I'll also attach the Emby Log, if that fits.

embyserver.txt polymorphTV-encode-Sub-585bf458-fa31-48ce-af3b-fbaaa6dddd41.txt polymorphTV-encode-Sub-558feb1a-efd6-4829-9326-ffd645540d7e.txt polymorphTV-encode-422cc621-69b8-4d29-adef-a9ac809ca734.txt

Link to comment
Share on other sites

  • 3 weeks later...

I am new to Emby, but want to say i love your plugin. I do have one suggestion, and reading through these posts i saw a few people wanting H265 from H264, but chromecast does not like that. Chromecast only likes H264 unfortunately. maybe someone mentioned it but my ADD skipped it lol. 

 

I run Emby off a QNAP and the transcoding is crap. The conversion to mp4 H265 at least makes it watchable where the MKV H265 won't play at all. If it could convert to H264 it would be perfect for Chromecast as it would be direct play and not need real-time transcoding at all.  Not sure why more people are not asking for that? I guess not many on here use Chromecast.

 

But maybe even could even be its own plugin? Pollymorph Chromecast version? All my TVs but 1 use Chromecast so would be nice to have auto conversion to direct playable files over time. I have been slowly doing them manually as most all my files are MKV H265 so would just be a time saver. 

 

Just my 2 cents. And love the plugin, for me is good. 

Link to comment
Share on other sites

On 10/28/2021 at 10:17 AM, LJDCDC said:

Hello, I'm having a problem with the "PolyMorph" Plugin, which when I start to extract subtitles it claims error in seconds (below I leave the Logs), in other cases it shows that it is executing the action, however it doesn't walk the process bar and stays hours stuck there. I thought it might be because of the size of my library, so I reduced it to test it and it didn't matter.

 

 I'll also attach the Emby Log, if that fits.

embyserver.txt 6.61 MB · 0 downloads polymorphTV-encode-Sub-585bf458-fa31-48ce-af3b-fbaaa6dddd41.txt 2.82 kB · 0 downloads polymorphTV-encode-Sub-558feb1a-efd6-4829-9326-ffd645540d7e.txt 2.72 kB · 0 downloads polymorphTV-encode-422cc621-69b8-4d29-adef-a9ac809ca734.txt 26.79 kB · 0 downloads

probably failing because it only works with the stable version. Does not work with beta versions of Emby.

Link to comment
Share on other sites

18 hours ago, dcol said:

probably failing because it only works with the stable version. Does not work with beta versions of Emby.

I use the stable version of Emby as far as I know

Link to comment
Share on other sites

4 hours ago, LJDCDC said:

I use the stable version of Emby as far as I know

4.6.4 would be stable. 4.7.x will not work with Polymorph

Link to comment
Share on other sites

1 hour ago, dcol said:

4.6.4 would be stable. 4.7.x will not work with Polymorph

I saw it on my server and I'm on version 4.6.4, apparently it wouldn't be that then

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...