Jump to content


Photo

BluRay MKV file freezing occasionally during browser playback

BluRay MKV Freeze Skip Browser

Best Answer mev , 21 January 2018 - 05:59 PM

Hi Luke,

 

Just to update. I think my problem is solved :)

 

The problem was 2 part

 

1. I sorted out the RAID config which reduced the amount of freezes (that was my bad)

 

and the more interesting find

 

2. If you are transcoding on a partition of the same drive (a HDD that is) where the BD MKV is stored, it really doesn't like it - Large sequential reads and then writes on another sector (this is what was doing it) - It is improved on the SSD but I don't see any SSD lasting too long in that setting.

 

The solution to 2 was to pop in a spare SSD (128GB) for transcoding which fixed everything.

 

I just said I would pass on the above in case someone else finds themselves in the same boat.

Thanks again for your assistance

 

 

(One sidenote question - I plan to format my Emby server soon to change the OS to Server 2016 - With regard to my license, is there any special procedure to follow or will it just work if I pop in the same key?)

Go to the full post


  • Please log in to reply
9 replies to this topic

#1 mev OFFLINE  

mev

    Newbie

  • Members
  • 6 posts
  • Local time: 06:43 PM

Posted 13 January 2018 - 08:48 PM

Hi Folks,

 

I am using Emby for a while now and I really enjoy it for DVD playback - I have digitised all of my DVD library which works great.

 

I have recently moved on to my BluRay library and I am noticing a playback issue using the browser as a player, I also have an emby app on an android TV box and notice the same issue.

 

The server Emby is on is purpose built

 

CPU: AMD FX 6300 Hexa Core Processor 3.50GHz

RAM: 32 GB

OS: Currently Windows 10, Planning to switch to Server 2016

Storage: OS Disk 500GB SSD 500meg Read 500meg Write (where Emby is installed)

               Video Storage Disk 1+2 8 TB HDD 7200 RPM 128meg cache

 

The MKV's from the BluRays are usually circa 30GB in size

 

I will say that I am extremely new to emby and video stuff in general so I am not sure what info is useful and what's not. The settings on emby are defaults as per the installation.

 

One thing I noticed when playing the Blu Ray files from Emby is the Network usage shoots up on the emby server - Not sure if its expected/normal or if I need to consider NIC teaming

 

The other thing I noticed is if I sit and suffer the freezes (and there are lots) usually mid way through the movie it will stop freezing and/or happen less frequently unless you rewind or fast forward.

 

Does anyone have any setting recommendations I could try just to rule out simple stuff??

 

I have done all the usual host stuff such as ensure power management is not switching off stuff, all drivers are up to date, disk read/write is fine and tonnes of space for the temp/cache directory.

 

Any/All suggestions greatly welcome :)

 

Also if there are some logs I can provide to help, or do a debug during playback, just tell me what and Ill get it done.

 

Cheers

M



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156918 posts
  • Local time: 01:43 PM

Posted 13 January 2018 - 08:49 PM

Hi there, can we look at an example? please attach the information requested in how to report a media playback issue. thanks !



#3 mev OFFLINE  

mev

    Newbie

  • Members
  • 6 posts
  • Local time: 06:43 PM

Posted 13 January 2018 - 09:05 PM

Hi Luke,

 

Thanks for the reply (Log attached)

 

Played a movie there and the issue happened at 00:52:00 and 00:52:40 local server time (GMT)

 

M

Attached Files



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156918 posts
  • Local time: 01:43 PM

Posted 14 January 2018 - 03:30 AM

Hi there, can you attach the ffmpeg log as well? thanks.



#5 mev OFFLINE  

mev

    Newbie

  • Members
  • 6 posts
  • Local time: 06:43 PM

Posted 14 January 2018 - 04:01 AM

Hi,

 

I hopefully have attached the right ones now :)

 

M

Attached Files



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156918 posts
  • Local time: 01:43 PM

Posted 14 January 2018 - 01:47 PM

I notice you customized the crf setting. you could try putting that back at default.



#7 mev OFFLINE  

mev

    Newbie

  • Members
  • 6 posts
  • Local time: 06:43 PM

Posted 15 January 2018 - 08:48 AM

Hi Luke,

 

My sincerest apologies, I was not aware I changed anything. I have set it to Auto for now.

 

Something interesting I found, I copied a BluRay MKV to the SSD and added it to the Library in its own category for test purposes. for the whole movie I experienced two very short freezes which is certainly an improvement. This made me take a look at the storage config a bit closer and I THINK i might have some bottlenecking going on in the RAID setup. I have ordered a different card and an additional HDD to re-configure the storage, so if its OK rather than wasting any more of your time, I will wait until those supplies arrive (hopefully the weekend) and I will give you another update.

 

Thanks for all efforts so far, hopefully it is the storage config

 

M



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156918 posts
  • Local time: 01:43 PM

Posted 15 January 2018 - 11:42 AM

Thanks for the feedback.

#9 mev OFFLINE  

mev

    Newbie

  • Members
  • 6 posts
  • Local time: 06:43 PM

Posted 21 January 2018 - 05:59 PM   Best Answer

Hi Luke,

 

Just to update. I think my problem is solved :)

 

The problem was 2 part

 

1. I sorted out the RAID config which reduced the amount of freezes (that was my bad)

 

and the more interesting find

 

2. If you are transcoding on a partition of the same drive (a HDD that is) where the BD MKV is stored, it really doesn't like it - Large sequential reads and then writes on another sector (this is what was doing it) - It is improved on the SSD but I don't see any SSD lasting too long in that setting.

 

The solution to 2 was to pop in a spare SSD (128GB) for transcoding which fixed everything.

 

I just said I would pass on the above in case someone else finds themselves in the same boat.

Thanks again for your assistance

 

 

(One sidenote question - I plan to format my Emby server soon to change the OS to Server 2016 - With regard to my license, is there any special procedure to follow or will it just work if I pop in the same key?)


  • Luke likes this

#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156918 posts
  • Local time: 01:43 PM

Posted 21 January 2018 - 11:43 PM

Thanks for the feedback. You can just pop in the same key.







Also tagged with one or more of these keywords: BluRay, MKV, Freeze, Skip, Browser

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users