Jump to content

Start watching an ongoing recording


Recommended Posts

Hi

 

I'm new to emby.  My main emby client is a nvidia shield.  On the Shield, I can start watching an ongoing recording and skip through commercials perfectly.  But that doesn't seem the case with emby theater on Windows.  I can start watching an ongoing recording, but the player has a lot of difficulties tracking time.  It's really difficult to skip through commercials.  i tried the webapp player with the same results.  On the android app (not tv), the player shows a length of 0 min and It's not possible to skip through commercials at all.

 

Is it the expected behavior?  Or there is something that I'm missing?

 

Thank you

Edited by rouq
Link to post
Share on other sites

@@Luke

Just to add more information to this.

 

On the Nvidia Shield TV, when I start watching an ongoing recording, I can see on the player overlay the duration of the recording, where the recording is at (dark green line) and where the playback is (light green line).  However, in emby theater, this is not the behavior I see.  When I start watching, in the player overlay, I see the little dot on the line moving around.  The total duration also moving around.  I don't see where the recording is at unlike on the Shield.  When I try to skip through, the player has a hard time skipping.

 

Other info, emby server 3.2.60 running on Synology DS418play with hardware acceleration activated.

 

Emby theater desktop version running on Windows 10 home.  Core i7 second gen, 16GB ram  with GTX-1050ti.

 

Should emby theater behave like the Nvidia Shield client?

Link to post
Share on other sites

​Yep. I have the exact same issue. I agree that the shield works great for this, but there appears to be an issue with keeping track of the time in the emby theater app.

Link to post
Share on other sites

One of the things I loved about WMC was the ability to start recording a show and then have the ability to start watching it while it's still recording and catch back up to the end.  It seems like I can watch it but when I try to skip ahead on a show that's still recording the skip takes 90 seconds to execute every time.  It gets really frustrating.  Any workarounds or things I can try to resolve that?

 

Enclosed is a log from last night.  Did it multiple times around 8:00pm.

 

Thanks

 

 

Log.txt

Link to post
Share on other sites

@@bshaf

 

Thank you for your reply.  With all @@Luke questions, I started to wondering if it was a setup issue.  I was kind of surprised to see this behavior because so far, everything that I've testing on emby works really well.

Link to post
Share on other sites

hi @@torrys, yes you can seek active recordings, but only the amount that has been buffered by the video player. This is something we'll look to improve in a future release. Thanks !

Link to post
Share on other sites

Hi Luke,

 

Yes it works it's just painfully slow as skipping 30 seconds takes 90 seconds to execute.  I'm running Emby Theatre for windows and using the default player for live TV.  Is there a better option or anything else I should try?

 

Thanks

Link to post
Share on other sites

hi @@torrys, yes you can seek active recordings, but only the amount that has been buffered by the video player. This is something we'll look to improve in a future release. Thanks !

Luke, this does not work on the current build while a recording is in progress, it just restarts at the beginning if you try to skip, does it on Roku, firetv, Xbox one etc.

 

Sent from my Nexus 6P using Tapatalk

Link to post
Share on other sites

Luke, this does not work on the current build while a recording is in progress, it just restarts at the beginning if you try to skip, does it on Roku, firetv, Xbox one etc.

 

Sent from my Nexus 6P using Tapatalk

 

@@snorkel, in my testing it works fine. best thing to do is attach the information requested in how to report a media playback issue. thanks !

Link to post
Share on other sites

@@snorkel, in my testing it works fine. best thing to do is attach the information requested in how to report a media playback issue. thanks !

 

Luke, it's that setting "transcode on the fly to a friendly format" that is causing the issue.  I turned that off and now the seek works fine with a ongoing recording.

Is that something you know about or should I do a official bug report for it?  

 

I turned that on because it sounded like a good idea otherwise the recordings are mpeg2 and a bit bigger.

Link to post
Share on other sites

Hi Luke,

 

Don't know if this helps you but I was using the Windows Theatre client when I was having the problem.  I just switched to the Nvidia Shield TV and now there's no delay when skipping in a show that's currently recording.

Link to post
Share on other sites

The theater app on Xbox one has really bad issues with seek if the recording needs to be transcoded. If you enable the transcode on the fly option you can't seek at all, however once the recording has finished and it's in a h264 mkv format the seek is fine.

 

The emby theater app on the Xbox one shows nothing when you seek, just skips forward with no position indicator. Works a lot better on Android/fire TV.

Link to post
Share on other sites

Part of the issue is none of the clients support mpeg2, so if you are streaming mpeg2 it needs to be transcoded while you watch and the seek is super choppy and then the stream stutters/pauses a bit right after the seek.

I see this on a fast home network with gigabyte connections. It's not network related.

Link to post
Share on other sites

Currently you can only seek what the player has buffered. In a future update we'll improve this to allow you to seek everything that has been recorded immediately . Thanks.

  • Like 2
Link to post
Share on other sites
  • 1 year later...
Michael.D.Pine

Luke, it's that setting "transcode on the fly to a friendly format" that is causing the issue.

 

Where do I find this setting, is this an Emby Theatre or server setting, I assume it is a server setting ?

 

Sorry for distracting the thread slightly but does being able to watch a recording while it is happening get affected by the device, i.e Silicon HDHomeRun or this should not matter ?

Link to post
Share on other sites
ryanfinger

I also need to get this fixed.  I am replacing Emby with my WMC which could do this without an issue.  It does looks like it might be trying to transcode the video as opposed to direct playing it.  Someone noted that perhaps because the fire is in use?  I did a test and tried to launch the video using VLC while it was being recorded and it opened up immediately and played fine.  Seems like the code needs to be adjusted to support this.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...