Jump to content


Photo

Actors Metadata not Refreshing

actors metadata xml refreshing scheduled tasks

  • Please log in to reply
42 replies to this topic

#21 Aussiedroid OFFLINE  

Aussiedroid

    Advanced Member

  • Members
  • 174 posts
  • Local time: 08:17 PM
  • LocationAustralia

Posted 08 January 2018 - 06:23 PM

I'm sorry to be a pain Luke. Where should I be reporting this, under what category other than General? (I assume this post is in the wrong area?)

 

I've got the logs attached above & covered other points covered in the report a problem post.

 

Thank you,

AD



#22 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153204 posts
  • Local time: 05:47 AM

Posted 08 January 2018 - 06:43 PM

Sorry, i meant the log of what you tried to do just now.

 

 

For the example I added previously, I added Original Title and Sort Title and saved. No difference  :(

 

Tried refreshing metadata and saving. No difference  :(

 

 

How do I find the hosts file to change the IP for the DNS as listed in the solution?



#23 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 18439 posts
  • Local time: 02:47 AM
  • LocationWashington State

Posted 08 January 2018 - 06:48 PM

I'm sorry to be a pain Luke. Where should I be reporting this, under what category other than General? (I assume this post is in the wrong area?)

 

I've got the logs attached above & covered other points covered in the report a problem post.

 

Thank you,

AD

 

This is the correct area.

 

I will have to do some more testing as I see the issue of third party metadata provider (MCM) providing actors (from movies.xml) and people images, and Emby not pulling actor metadata without a manual actor refresh.  And when doing that the metadata is only written to the database. 

 

Since Emby is in a read only mode for existing stuff it sort of makes since.  The hard part is not having a way to refresh people easily (bulk).


Edited by Happy2Play, 08 January 2018 - 06:50 PM.


#24 Aussiedroid OFFLINE  

Aussiedroid

    Advanced Member

  • Members
  • 174 posts
  • Local time: 08:17 PM
  • LocationAustralia

Posted 08 January 2018 - 06:49 PM

Ok, latest logs attached.

 

This morning, I went into Metadata Manager, and added the Original & Sort titles to American Horror Story. Saved and then loaded Emby Theater.

 

I navigated to the show via TV & then selected several actors to see if the metadata would appear. Nothing showing.

 

 

Edit - sorry now with logs!

Attached Files

  • Attached File  Log.txt   2.38MB   1 downloads

Edited by Aussiedroid, 08 January 2018 - 06:53 PM.


#25 Aussiedroid OFFLINE  

Aussiedroid

    Advanced Member

  • Members
  • 174 posts
  • Local time: 08:17 PM
  • LocationAustralia

Posted 08 January 2018 - 06:52 PM

This is the correct area.

 

I will have to do some more testing as I see the issue of third party metadata provider (MCM) providing actors (from movies.xml) and people images, and Emby not pulling actor metadata without a manual actor refresh.  And when doing that the metadata is only written to the database. 

 

Since Emby is in a read only mode for existing stuff it sort of makes since.  The hard part is not having a way to refresh people easily (bulk).

 

Thanks!

 

Just to clarify, if I had people.xml files in the People folder of the metadata folder, then they appear no issues.

 

I deleted all of the xmls (and also nfo files that were created by Metabrowser) last night with only images remaining now, but I cannot get any actors data to appear without a manual refresh via the sub menu on the actors page (one actor at a time).


Edited by Aussiedroid, 08 January 2018 - 06:52 PM.


#26 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 18439 posts
  • Local time: 02:47 AM
  • LocationWashington State

Posted 08 January 2018 - 06:53 PM

Ok, latest logs attached.
 
This morning, I went into Metadata Manager, and added the Original & Sort titles to American Horror Story. Saved and then loaded Emby Theater.
 
I navigated to the show via TV & then selected several actors to see if the metadata would appear. Nothing showing.

 
Well that is a bad show to test with as all the seasonnumbers added to the actor there will be no metadata.
 
Issue with this series each actor has different role in every season.
5a53f77d12873_act.jpg

5a53f7887bb36_act2.jpg

Edited by Happy2Play, 08 January 2018 - 06:58 PM.


#27 Aussiedroid OFFLINE  

Aussiedroid

    Advanced Member

  • Members
  • 174 posts
  • Local time: 08:17 PM
  • LocationAustralia

Posted 08 January 2018 - 06:59 PM

Ah just my luck starting at 'A' :)

 

Ok tried another show Seinfeld. Updated all the Titles to ensure they are populated, refreshed and saved. Same behaviour being seen.

 

Updated log attached. I tried to go into the 4 main actors to see if the metadata would show. Same result as AHS.

 

Attached Files

  • Attached File  Log.txt   2.61MB   4 downloads


#28 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153204 posts
  • Local time: 05:47 AM

Posted 08 January 2018 - 07:24 PM

Ok for starters, since you're on 3.2.50 I would suggest updating to the latest version of emby server, then try again. Thanks.



#29 Aussiedroid OFFLINE  

Aussiedroid

    Advanced Member

  • Members
  • 174 posts
  • Local time: 08:17 PM
  • LocationAustralia

Posted 08 January 2018 - 07:29 PM

Thanks for the reminder Luke.

 

Have just updated & reattempted on Seinfeld but still the same.

 

Cleaner log attached.

 

 

From what I can see it is attempting to fetch the data:

 

2018-01-09 09:57:45.504 Debug App: Running PersonXmlProvider for /volume1/Backups/Emby Server Data/metadata/People/J/Jerry Seinfeld
2018-01-09 09:57:45.507 Debug App: PersonXmlProvider returned no metadata for /volume1/Backups/Emby Server Data/metadata/People/J/Jerry Seinfeld
2018-01-09 09:57:45.515 Debug App: Running MovieDbPersonProvider for /volume1/Backups/Emby Server Data/metadata/People/J/Jerry Seinfeld

...

2018-01-09 09:57:46.534 Debug App: MovieDbPersonProvider returned no metadata for /volume1/Backups/Emby Server Data/metadata/People/J/Jerry Seinfeld

 

Although there seems to be data present via website:

https://www.themovie...-jerry-seinfeld

Attached Files

  • Attached File  Log.txt   175.66KB   2 downloads

Edited by Aussiedroid, 08 January 2018 - 07:49 PM.


#30 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153204 posts
  • Local time: 05:47 AM

Posted 09 January 2018 - 12:37 AM

I already mentioned earlier, if we don't have the MovieDb Id for the person, then we don't search by name. The moviedb id is obtained when we download the metadata from a movie or series that the actor appears in.



#31 Aussiedroid OFFLINE  

Aussiedroid

    Advanced Member

  • Members
  • 174 posts
  • Local time: 08:17 PM
  • LocationAustralia

Posted 09 January 2018 - 12:49 AM

Thanks for explaining this.

 

Will doing a refresh metadata for 'search for missing metadata' resolve the missing MovieDB person IDs? or are these only created when a new show metadata being downloaded from scratch?



#32 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153204 posts
  • Local time: 05:47 AM

Posted 09 January 2018 - 12:57 AM

that should be fine.



#33 Aussiedroid OFFLINE  

Aussiedroid

    Advanced Member

  • Members
  • 174 posts
  • Local time: 08:17 PM
  • LocationAustralia

Posted 09 January 2018 - 02:31 AM

Righto, made it home and given the above suggestion a try. No change :(

 

It does not appear to be updating the nfo file at all (date/time remains from this morning). I have tried searching for missing metadata in both the metadata manager and via Emby Theater. Next I renamed the tvshow.nfo to remove the existing metadata and rescan anew. Completed a library scan, but the data remains in the metadata manager when I check (even with the file removed). I try replace all metadata & no nfo file is being created. I tried to view actors again at this point but nothing has changed, still no data showing. Not sure where it is sourcing or storing the data. I don't know if this may even relate to the main issue at this point or there is something else prevent the refresh.



#34 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153204 posts
  • Local time: 05:47 AM

Posted 09 January 2018 - 02:39 AM

unfortunately the settings we offer create a lot of scenarios that are difficult to test. i would try putting all metadata settings back to default. thanks.



#35 Aussiedroid OFFLINE  

Aussiedroid

    Advanced Member

  • Members
  • 174 posts
  • Local time: 08:17 PM
  • LocationAustralia

Posted 09 January 2018 - 04:12 AM

I understand :) I'll troubleshoot it further my end and try some different settings and see if I can get it to work.

 

Really appreciate your help trying to solve this. Been working through a few minor issues over past few weeks that have been left unchecked for far too long, and the great knowledge around these forums has pretty much got them all solved! This bugbear seems to be the troublesome one.

 

there's no support for any kind of people.nfo file. fatal (the metabrowser developer) asked me to do this a while back but i never got to it.

 

at this point i would just rely on emby for metadata and you'll be fine.

 

Regarding the above, I just tried a quick test, & simply renaming the people.nfo to people.xml and the data for the actors displays fine. A possible workaround could be to do a bulk rename of all the people.nfo files (if I can find a reliable way to do it for the entire folder/sub-folders) after they are created to xml for the Emby XML plugin to read it.

 

Got me thinking if a simple solution here could be to add the .nfo file extension to be supported by the XML plugin for the actors? Search for xml file first but if not found read the nfo file if present?

 

Cheers,

AD



#36 maximilianh75 ONLINE  

maximilianh75

    Advanced Member

  • Members
  • 149 posts
  • Local time: 06:47 AM

Posted 10 August 2018 - 03:01 AM

Only for be clear, in the past emby added person.xml for any actor added in people folder in metadata.

These feature never added again, because i can modify actor metadata but only saved in library.db file and i don't have any backup of it


Edited by maximilianh75, 10 August 2018 - 03:05 AM.


#37 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153204 posts
  • Local time: 05:47 AM

Posted 10 August 2018 - 09:15 AM

You can install the legacy XML metadata plugin if you really need that.

#38 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 18439 posts
  • Local time: 02:47 AM
  • LocationWashington State

Posted 10 August 2018 - 02:47 PM

You can install the legacy XML metadata plugin if you really need that.

 

Sorry the plugin doesn't do metadata..



#39 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153204 posts
  • Local time: 05:47 AM

Posted 10 August 2018 - 03:54 PM

Maybe I'm forgetting again but i thought it had person.xml support.



#40 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 18439 posts
  • Local time: 02:47 AM
  • LocationWashington State

Posted 10 August 2018 - 03:59 PM

Maybe I'm forgetting again but i thought it had person.xml support.

 

Wasn't able to find the topic with a quick search, but I believe everything is commented out.







Also tagged with one or more of these keywords: actors, metadata, xml, refreshing, scheduled tasks

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users