Jump to content
BEis

Trakt sync authorization error?

Recommended Posts

BEis

As of this afternoon, when I run a "Sync library to trakt.tv" operation, I get the following error:

 

Sync library to trakt.tv failed. Unauthorized.

 

This just started happening today. Nothing has changed on my server. I've double checked to make sure my login information is correct. I've rebooted the machine, uninstalled and reinstalled the Trakt plugin, and it's still happening.

 

Anyone have any ideas? Not sure what else to try here.

 

Incidentally, the "Import playstates from trakt.tv" operation works fine. It's just the sync library that fails.

 

Help please! Thank you..

  • Like 2

Share this post


Link to post
Share on other sites
hstamas

I’m getting the same error.

Share this post


Link to post
Share on other sites
dranderson402

Here also

 

Sent from my SM-G955U using Tapatalk

Share this post


Link to post
Share on other sites
Luke

Thanks for the report. The plugin needs to be updated to support newer trakt api requirements. While we are here I would just like to point out that the trakt plugin is a community addition and contributions are welcome. The source code for it can be found here:

 
 
Thanks !

Share this post


Link to post
Share on other sites
paulsalter

Noticed the same on mine

 

Nothing i watched last night got sent to Trakt, though yesterday morning was ok

Share this post


Link to post
Share on other sites
alext41

Noticed it today, yesterday in the morning it was working :(

Share this post


Link to post
Share on other sites
BEis

Thanks for the info about the plugin @@Luke. Unfortunately this is above my level of expertise... does anyone know who was originally involved in creating the Trakt plugin? It sounds like we need to get someone involved that is capable of updating the code to support the new requirements.

Share this post


Link to post
Share on other sites
BEis

I'm tagging @@J2ghz because he's listed on the GitHub as a contributor to the plugin. Maybe he can help?

Share this post


Link to post
Share on other sites
hstamas

Im noticing that the straight up Trakt plugin for Kodi was not scrobbling last night either - just and FYI if it matters.

Share this post


Link to post
Share on other sites
Luke

Thanks for the info.

Share this post


Link to post
Share on other sites
heula

Having also problems with trakt. Not synchronising.

Share this post


Link to post
Share on other sites
paulsalter

Just guessing but wondering if Trakt has disabled the ability to scrobble/sync when using username/password

 

Been a while since i used the plugin for Kodi, anyone know if that is using username/password, as above that stopped yesterday

 

I am still subscribed to get emails about Trakt for Plex, just had the following update, looks like it's requesting oAuth instead of user/pswd

 

I'm using a very old version of the plug-in thats been working forever without issue, until yesterday.

 Now i'm getting the 401 oAuth must be provided error.

 I'm able to login to trakt.tv just fine. Anyone else having this issue?

 

Share this post


Link to post
Share on other sites
hstamas

Just guessing but wondering if Trakt has disabled the ability to scrobble/sync when using username/password

 

Been a while since i used the plugin for Kodi, anyone know if that is using username/password, as above that stopped yesterday

 

I am still subscribed to get emails about Trakt for Plex, just had the following update, looks like it's requesting oAuth instead of user/pswd

When I tried the Trakt Kodi add-on the other day I authorized via the web link it gives you. I never inputted a user name/password. I only watched 2 shows with the plugin installed (and the Emby server plugin uninstalled) and it did not scrobble.

Share this post


Link to post
Share on other sites
Zodler

Me too. Since yesterday when I watch videos, they do not sync to Trakt.

 

I have

Emby Server Version 3.2.36.0 and

Trakt plugin 3.1.1.0
 
It uses username and password and since yesterday things I watch with my Emby Server, do not sync.

Share this post


Link to post
Share on other sites
jbuyense

For what ever it's worth, same problem here!

Share this post


Link to post
Share on other sites
overdox

noticed this is happening the last couple of days allso.

Share this post


Link to post
Share on other sites
BEis

So the question now is, what do we do to fix this? Apparently since the Trakt plugin is not officially part of Emby, it is up to the community to update it to be in compliance with the new requirements of Trakt. Does anyone have programming experience to be able to fix this?

  • Like 1

Share this post


Link to post
Share on other sites
xDeepS

Trakt requires OAuth now, so instead of supplying logins in plugin config the plugin has to connect to trakt to authorize and then trakr provides a token. DuckieTV does it. Sadly I dont code. 

Share this post


Link to post
Share on other sites
BEis

Yes, that is exactly the problem. Apparently the Trakt plugin for Plex already had this new method in place, because it seems to be unaffected. Who among us is able to code? I would imagine this would be a relatively easy fix, although I don't code either so it might be really difficult... I have no idea.

 

Unfortunately this makes Emby a very unattractive option for now, since everything I watch becomes out of sync with my Trakt watchlist. I'm sure lots of other people are in the same boat. Would be great if someone could step forward and update the Trakt plugin for us...

  • Like 1

Share this post


Link to post
Share on other sites
xDeepS

 

Thanks for the report. The plugin needs to be updated to support newer trakt api requirements. While we are here I would just like to point out that the trakt plugin is a community addition and contributions are welcome. The source code for it can be found here:

 
 
Thanks !

 

 

Why don't you guys take it on as an internal addition and make it a Premiere only feature if needed? I just moved from Plex a few days ago and it seems like you guys compete with it head to head features and pricing wise, this would be a good core addition.

 

 

Unfortunately this makes Emby a very unattractive option for now, since everything I watch becomes out of sync with my Trakt watchlist. I'm sure lots of other people are in the same boat. Would be great if someone could step forward and update the Trakt plugin for us...

 

I hear Sickrage can do trakt well, I am giving it a spin right now to see if it can handle the shows for now instead of Emby.

  • Like 1

Share this post


Link to post
Share on other sites
Zodler

Trakt plugin is linked by the official Trakt site to the official Emby server plugins store and it's available in the official Emby plugin page. So it's not what I call a community plugin where it's on a third party web page and forgotten. I suppose it will be updated.

Share this post


Link to post
Share on other sites
BEis

According to @@Luke, it is a community plugin. See comment #5.

 

But you're right, it is linked on the official Trakt site, I noticed that last night while doing some research. So it seems like if there is an official link there, then there should be official support. As mentioned above, it seems like it would be a great addition for a Premiere only feature.

 

This is just my humble opinion, but without Trakt support (official or otherwise), any media center feels almost crippled.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...