Jump to content

Initial sync error on FireTV stick


cw-kid
 Share

Recommended Posts

Hi

 

Currently setting up a new Amazon FireTV stick for my mum's Christmas present.

 

I've manually connected the Emby addon in Kodi v17.6 to my Emby server using my domain name and SSL port. Seemed to had issues with using Emby connect it kept prompting for the user to login and would not accept login details which were correct.

 

Anyway when now trying to do the initial sync twice so far its come up with this error.

 

Please see attached image.

 

Thank you.

post-2165-0-31904900-1511539056_thumb.jpg

Edited by cw-kid
Link to comment
Share on other sites

If it's going to be remote and your mom only wants to have access to your video content, then Embycon would be better for this. Anyway, the error is saying the database was locked. Could be caused by clean on update (hence why I asked if there's advanced settings setup). Otherwise, you can enable the database locked fix in the add-on settings > sync options (should be the first option).

Edited by Angelblue05
Link to comment
Share on other sites

Hi @@Angelblue05

 

I've never used a FireTV stick before so will have figure out how to connect to its file system to get to the kodi files / directories.

 

Also Kodi is quite unstable and was hanging solid alot during the Emby sync.

 

After battling with all this the sync finally finished I think.

 

All the TV shows and albums appear to be present but there is like a 1000 movies missing for some reason.

 

I have tried repairing the db and doing a manual update in the Emby addon settings but the missing movies are still missing.

 

Thanks.

Link to comment
Share on other sites

One weird thing in Kodi in System Information. Its saying the IP address is 192.168.49.1 that's not even my subnet it should be 192.168.0.x

 

Looking in the FireTV network settings it doesnt seem to tell you its IP address only if its connected or not.

 

So looking on my router that says its IP is 192.168.0.77

 

So will try and connect to that and look for an advancedsettings.xml

Link to comment
Share on other sites

Just turned on Show hidden files in Kodi settings. Then using the Kodi file manager and going into Profile Directory aka the Userdata folder. I cant see an advancedsettings.xml file.

 

I can see some of the other regular files though like sources.xml, guisettings.xml etc.

Edited by cw-kid
Link to comment
Share on other sites

So thinking I should enable the DB locked fix option and reset the local DB and try again I guess.

 

I also have a second FireTV stick to setup for my brother so could try that one a fresh also.

Link to comment
Share on other sites

I'm experiencing a similar issue with a Kodi Leia build.

 

5a194e562c22b_4sOwNIr6x401y7Ih_Xu3OUNHts

 

I've already activated the "DB lock" with no avail. Is it required to reset the Kodi DB?

 

Cheers,

anthonws.

Edited by anthonws
Link to comment
Share on other sites

Hi

 

Did your initial sync finish at all? Is all your content present?

 

If not then we probably need to do a DB reset

Edited by cw-kid
  • Like 1
Link to comment
Share on other sites

Hi

 

Did your initial sync finish at all? Is all your content present?

 

If not then we probably need to do a DB reset

 

Reset Local DB and settings and the error is there, although it changed a bit.

 

From "no such table: movies" to "no such table: tags". I've also installed the latest version of the add-on, 2.3.57a, from this threat: https://emby.media/community/index.php?/topic/53104-emby-kodi-sync-bug/.

 

Cheers,

anthonws.

Link to comment
Share on other sites

I have just setup my second new FireTV stick. Using stable release of Kodi v17.6 and the stable release of the Emby repo / addon for Kodi.

 

I have enabled the DB locked fix option and its just started the initial sync now which will take several hours.

Link to comment
Share on other sites

@@Angelblue05 On this second TV stick I logged into the Emby addon in Kodi using the Emby connect option.

 

I entered my brothers Emby account username and password and it logged me in.

 

It then asked about Addon default or Direct paths. I selected Addon defaults and then selected I did NOT want to disable the music library and selected Direct Stream for music so he can play my music library remotely from his house etc.

 

However when I looked in the Emby addon settings the connection is set to Manual and is using my local Emby servers IP LAN address and HTTP port.

 

Because I logged into it using Emby connect I was expecting it to be set as my Emby servers WAN domain name address and the HTTPS port.

 

So after the initial sync has finished can I just change the servers address in the settings from the local IP to the WAN domain address etc?

 

Thank you.

Link to comment
Share on other sites

Regarding this initial sync on the second FireTV stick.

 

Its processed all the Kids Movies 506 titles which sounds about right.

 

Its now gathering the movies, actually that just finished, it now says processing Movies / 2294. So that looks better this time!

 

On the first TV stick I only ended up with about 800 film titles total. So think I need to reset the DB on that one again.

 

In fact I think I messed the first TV stick right up, as I configured it all logged in as me on my Amazon account.

 

I phoned Amazon support about switching the account used on it to my mums account and they said I have to deregister the stick and this loses all the apps you have installed / configured, apparently?

 

So think I will have to start again from scratch on that first TV stick Grrr..

 

EDIT:

 

Ok so I deregistered my Amazon account and registered mums on the stick.

 

Kodi and Emby apps are still there however. Kodi opens and has all the same settings.

 

However when I now open the Emby app it says Not Owned.

 

I am a Emby premiere member so I shouldn't have to buy the app for my remote users?

 

EDIT2:

 

When it says Not Owned it says click here for more details that then takes you to the area to download Emby app again.

 

Did that now I have two Emby app icons on the home page, only one works and is logged in a mum.

 

Looking in the FireTV settings under apps I can only see one actual Emby app listed.

 

So on the home page on the none working icon brought up the context menu and selcted remove from recent list and now its gone.

Edited by cw-kid
Link to comment
Share on other sites

Also Voice control does not work in the Emby app for FireTV.

 

If I am in the Emby app and press the mic button on the remote and say "Jaws" when I then click on Jaws it takes you out of the Emby app and to the Amazon Movie & TV area.

 

Same deal with Kodi.

Link to comment
Share on other sites

Back to the first TV stick with all the missing movie titles. I have enabled the DB locked fix option and reset the local DB.

 

When I relaunch Kodi it does not seem to do the gathering movies or gathering kids movies bit.

 

It just went straight to processing movies which it did far too quickly and now its moved on to processing kids movies.

 

Will see when its finished the initial sync but I expect it will be missing content titles again.

 

EDIT:

 

Now its gone back to processing movies and this time says 2294 items. So think I might alright.

 

Both sticks are currently syncing looks like they will take all day to finish.

Edited by cw-kid
Link to comment
Share on other sites

On the second stick the initial sync must have quit out. Its done all the movies and all titles are present but there is noTV shows and music, even after relaunching Kodi.

 

The first stick is still going and processing movies at 80%.

Link to comment
Share on other sites

Did you ever figure out if there was advanced settings setup?

 

Sent from my iPhone using Tapatalk

There are no advancedsettings.xml files present.

Link to comment
Share on other sites

Strange. And it locked every time? Check settings > video I believe. Is there any settings that refer to clean on update enabled?

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

On the second stick just clicked on Repair local database and it brings up a dialog box saying Proceed with the following server? But no server name is shown. Just an OK button to click onto.

 

If I RDP onto the WHS 2011 server, Emby server has quit out and it no longer in the system tray.

 

Seems the sync on the FireTV stick has taken down the Emby server.

 

I saw the same thing happen once yesterday as well.

 

If I look at the first stick again that is still showing it as syncing which is weird. Its still processing various movie title names.

 

If I look in the task manager processes on the Windows server I cant see Emby is running any longer.

Link to comment
Share on other sites

Strange. And it locked every time? Check settings > video I believe. Is there any settings that refer to clean on update enabled?

 

 

Sent from my iPhone using Tapatalk

I am no longer seeing that error I initially posted a photo of.

 

Both sticks have that DB locked fix option turned on.

 

Let me check the other setting you mention please hang on.

Link to comment
Share on other sites

Not sure I can see a setting for Clean on update. I have Expert settings turned on etc.

 

Looking in Media Settings - Library there are buttons to "Clean Library" but these have to be manually initiated.

 

"Update Library on startup" is not turned on.

Link to comment
Share on other sites

I've relaunched Emby server. On the stick that is now showing all the movies OK but missing Tv shows and music. I am using the repair database option and select the media content types I want to repair.

 

This worked for music videos they are now all present.

 

Seems I can't do a full initial sync on these sticks something always bombing out, if the sync process itself, or kodi hanging or now the Emby server itself bombing out.

Link to comment
Share on other sites

Well another way would be to build the database on a fast device, then just backup/restore. I'm not sure what the issue could be without a log, but when the database locks, it is because kodi or an addon is causing the database to be modified at the same time as the emby for kodi addon. Things missing sounds like the database clean up is wiping entries away.

 

 

Sent from my iPhone using Tapatalk

Edited by Angelblue05
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...