Jump to content

Random TV Episodes Showing up In Movie Database


ChipWhisperer
 Share

Go to solution Solved by Angelblue05,

Recommended Posts

ChipWhisperer

As the title implies, Emby is occasionally is showing episodes of TV shows in the Movies library section of Kodi. 

Specifically, the problem has occurred with various episodes of Rick and Morty as well as Family Guy.

The Metatdata editor properly lists the episodes as TV, and they are located in the correct storage locations with their counterparts. 

What's weirder is that the problem isn't limited to specific episodes, the only constant unhappy child is "Family Guy 16x01 - The Emmy Winning Episode".

You see, if I Scan the library, or even completely rebuild it, I get a nice shuffle of which episodes will randomly appear in the Movies Directory. 

 

I'm at a loss. 

 

PS: I know the FAQ says not to zip log files, but I was warned repeatedly about not being allowed to upload .docx files. Sorry!

 

Thanks!

100817-128pm.zip

Link to comment
Share on other sites

Angelblue05

Yea, because the damage is already done... it'll look fine in the web app, the issue if I recall is when the added event is triggered, the content type/etc is not correctly set. By the time the update event hits, it's fine...

 

I guess the only solution is for the addon to completely ignore "added" events.

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

Angelblue05

Running a manual sync should remove those entries in your movie library. Let me know if it's not the case. (Launch the addon > manual sync)

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

ChipWhisperer

Running a manual sync should remove those entries in your movie library. Let me know if it's not the case. (Launch the addon > manual sync)

 

 

Sent from my iPhone using Tapatalk

 

 

Hey again. After the manual sync, these TV Episodes remain in the movie section. 

Link to comment
Share on other sites

ChipWhisperer

For the sake of being thorough, it seems they're not links to the actual episode. If i try to play one of these improperly categorized episodes from the movies section, emby generates an error. 

Link to comment
Share on other sites

  • Solution
Angelblue05

Ok, then just delete them via the Kodi menu.  Open the menu on an episode in the movie section > manage > remove from library (Do not select emby options). Run a manual sync again, let me know if the items reappear.

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites

ChipWhisperer

Ok, then just delete them via the Kodi menu.  Open the menu on an episode in the movie section > manage > remove from library (Do not select emby options). Run a manual sync again, let me know if the items reappear.

 

It appears the items aren't coming back. Thank You!

  • Like 1
Link to comment
Share on other sites

Angelblue05

Thanks for reporting back. I will look into making sure we add new content after they are correctly detected by the server. This should resolve your issue. Until then, you know what to do :)

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...