Jump to content


Photo

Short jumps backward issue


  • Please log in to reply
91 replies to this topic

#61 Rohanaj OFFLINE  

Rohanaj

    Advanced Member

  • Members
  • 52 posts
  • Local time: 01:55 PM

Posted 19 February 2018 - 03:23 PM

If my experience is similar to others, I didn't have the problem but then in the last couple of weeks it started.  Oddly, it isn't all the time, for instance never during live tv, but does happen when streaming movies.

 

I posted earlier in this thread about the issue, and I'm still finding the same type of scenario I described previously applying for me.  I don't do live TV, so it's just streaming movies, episodes, and home videos for me.  I continue to find that if I'm in a situation that requires transcoding while streaming, the skips continue to pop up - which is the case if I'm connecting on an external network with limited speeds or the file is a format that doesn't natively play.  However, streaming on my home network with no transcoding has consistently worked smoothly.

 

This is just my hypothesis, but because it appears tied to situations where the data may have to break into pieces more often, I'm guessing the skips are tied to either points where those breaks occur, or perhaps even a buildup of where those breaks are (more on that in a couple sentences).  If that's the case, then what should be a seamless stream of lots of connected data pieces is glitching because iOS is potentially reading the data of each piece incorrectly.  So if it reads the length or position off by a second for a data piece, then that could explain why it skips back a second during the transition from piece to piece.  I doubt it's a full second on a single piece of course, that's just an easy illustration.  In reality, it would likely be more like tiny fractions of a second for each data piece that then add up into those breaks every so-many pieces.  You all are more than welcome to rip this idea apart though, as I'm definitely not a developer myself.

 

It would be nice if @ebr and @Luke were able to compensate for this issue, but I'm more than willing to give them the benefit of the doubt when it comes to the balance of whether they can logistically and feasibly do something about it.  That's especially true since it still appears to be a widespread issue for all kinds of developers and apps that stream video of any type on iOS 11.



#62 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146627 posts
  • Local time: 02:55 PM

Posted 19 February 2018 - 05:01 PM

I have tried various workarounds with limited success. We are exploring an embedded video player that wouldn't have to rely on apple libraries.


  • SikSlayer likes this

#63 jscoys OFFLINE  

jscoys

    Advanced Member

  • Members
  • 1228 posts
  • Local time: 02:55 PM

Posted 21 February 2018 - 10:49 PM

I have tried various workarounds with limited success. We are exploring an embedded video player that wouldn't have to rely on apple libraries.


At least you said you tried different things. I’m pretty sure you will find a solution to embed an other video player than using the one included, as YouTube, MrMC or Plex already did before! We rely on you! Let’s make Emby iOS app great again!


Sent from my iPad using Tapatalk

#64 grandboricua OFFLINE  

grandboricua

    Newbie

  • Members
  • 1 posts
  • Local time: 01:55 PM

Posted 22 February 2018 - 02:42 PM

I've been following this thread for quite some time in the hopes that this issue will be fixed. I only have iOS devices, and the frustration has finally gotten to me. I tried a competitor, and voila, no more stress when trying to watch something. While I love all the options Emby has (enough to have been a paid supporter the last 3 or so years), and it's by the far the best looking solution I've tried, it does me no good to have all the presentation in the world, and not be able to actually enjoy my media.

 

I will still keep an eye on this thread, in the hopes that I can return some day, but for now... a competitor it is. Also, Luke, while you may not have meant it, some of your responses have really come off as rude and dismissive, at least in this thread. Not a good way to represent your company/org to actual or potential customers.



#65 jscoys OFFLINE  

jscoys

    Advanced Member

  • Members
  • 1228 posts
  • Local time: 02:55 PM

Posted 09 March 2018 - 02:16 PM

@Luke can you keep us posted on your recent researches to have your internal video player instead of using the default one on IOS app?


Sent from my iPhone using Tapatalk

#66 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146627 posts
  • Local time: 02:55 PM

Posted 09 March 2018 - 02:24 PM

We are exploring a new video player for the app, thanks.


  • dcrdev likes this

#67 mbnwa OFFLINE  

mbnwa

    Advanced Member

  • Alpha Testers
  • 478 posts
  • Local time: 12:55 PM

Posted 16 March 2018 - 06:37 PM

So I had this issue for the first time today on iOS 11.3 Beta 5, however I am no longer having this issue with IOS 11.3 Beta 6 (released today) 

 

Right now it's too soon to say if it's been addressed or not however this issue happened almost every playback on 11.3 Beta 5.



#68 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146627 posts
  • Local time: 02:55 PM

Posted 16 March 2018 - 06:40 PM

It would figure that apple would resolve it just as we're about to give you guys a new video player to play with.



#69 jscoys OFFLINE  

jscoys

    Advanced Member

  • Members
  • 1228 posts
  • Local time: 02:55 PM

Posted 16 March 2018 - 06:53 PM

It would figure that apple would resolve it just as we're about to give you guys a new video player to play with.


That’s the thing Luke, you should go ahead with your internal video player because if you don’t, in 6/7 months your app will break again with iOS 12...


Sent from my iPhone using Tapatalk

#70 mbnwa OFFLINE  

mbnwa

    Advanced Member

  • Alpha Testers
  • 478 posts
  • Local time: 12:55 PM

Posted 16 March 2018 - 06:56 PM

Please note that this beta just came out today, I do not have a lot of playback time with it yet. I just happened to notice (seeing I was debugging this today) that I no longer had the issue on the few tests after the update. It could still totally be broken, just not enough testing yet

 

In addition while it may work in Beta 6 who's to say they don't break it again on the release version :)



#71 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146627 posts
  • Local time: 02:55 PM

Posted 16 March 2018 - 09:53 PM

@jscoys are you enjoying the new lion emoji they've given you in the beta?

#72 jscoys OFFLINE  

jscoys

    Advanced Member

  • Members
  • 1228 posts
  • Local time: 02:55 PM

Posted 16 March 2018 - 10:39 PM

@jscoys are you enjoying the new lion emoji they've given you in the beta?


LOL I think you’re a little bit sarcastic, but I don’t take it personal ;-) yeah it’s not a big improvement, and honestly i already don’t use that much emojis. But Faceid is great, and do you remember I told you that could be cool to unlock Emby iOS app with it? I already know your opinion, but I can already use it to unlock my banking account so...


Sent from my iPad using Tapatalk

#73 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146627 posts
  • Local time: 02:55 PM

Posted 16 March 2018 - 10:48 PM

actually i have nothing against using face id.


  • jscoys likes this

#74 jscoys OFFLINE  

jscoys

    Advanced Member

  • Members
  • 1228 posts
  • Local time: 02:55 PM

Posted 17 March 2018 - 07:34 PM

Hum just installed the beta 6 today, will need several days to test if it resolves the iOS Emby app playback or not.

Will keep you posted. After that we’ll have work together @Luke to make iOS app great again on iPhone X especially!


Sent from my iPhone using Tapatalk

#75 jscoys OFFLINE  

jscoys

    Advanced Member

  • Members
  • 1228 posts
  • Local time: 02:55 PM

Posted 20 March 2018 - 12:40 PM

Hum it’s wayyyyyy better! I noticed with my tests some jump backwards again, like one sometimes, but they’re really smallest (like 100-200ms) that before.

Will do more tests, we’re on the good way.


Sent from my iPhone using Tapatalk

#76 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146627 posts
  • Local time: 02:55 PM

Posted 20 March 2018 - 12:42 PM

Thanks for the feedback.

#77 jscoys OFFLINE  

jscoys

    Advanced Member

  • Members
  • 1228 posts
  • Local time: 02:55 PM

Posted 20 March 2018 - 04:56 PM

Thanks for the feedback.


For playback picture position issues on IPhone X depending of different movie resolution/type I guess you prefer me to open an other ticket?


Sent from my iPhone using Tapatalk

#78 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146627 posts
  • Local time: 02:55 PM

Posted 20 March 2018 - 05:07 PM

It's already reported. Thanks.


  • jscoys likes this

#79 Diedrich OFFLINE  

Diedrich

    Advanced Member

  • Members
  • 695 posts
  • Local time: 02:55 PM

Posted 20 March 2018 - 06:48 PM

I came here to report this problem but it seems to be a festering issue. I made a video to demonstrate what's happening.

 

Emby Server: 3.3.1.0

iPad app: 1.4.9 / iOS v11.2.6

Ryzen 5 1600, nVidia GTX 1500Ti, hardware transcoding not enabled

 

Video was showing as Direct Play from the dashboard in both scenarios. Here is what I'm seeing:

 


Edited by Diedrich, 20 March 2018 - 07:35 PM.


#80 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146627 posts
  • Local time: 02:55 PM

Posted 20 March 2018 - 06:51 PM

It will be resolved as soon as iOS 11.3 is released.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users