Jump to content

FR: MBC - Automatically\\Silently retry connecting to server


mranim8or

Recommended Posts

My HTPC goes to sleep until I use it, and when it wakes it often requries me to click the 'Couldn't connect to Server. Retry?' button. Would it be possible to add a setting to allow MBC to automatically retry connecting to the server (maybe for 15 seconds or something) before prompting the user?

Link to post
Share on other sites

The timeout is currently defaulted to 40 seconds.  Does it take that long for you to get the first notification that the server isn't responding?

Link to post
Share on other sites
mranim8or

The problem seems to be intermittent.   I just timed it and from the time my HTPC starts to wake from sleep to when it finishes automatically launches MBC. It took 20 seconds and the message popped up the first time I tested it.  But then I repeated it 4 more times....the HTPC launched in 20 seconds again, and these times I didn't have a problem.  Maybe something else is causing this?

 

BTW I use a program called Hibernate Trigger to automaticallly launch a batch file everytime the HTPC goes to sleep...it closes MBC and any instance of MPC-HC it finds running. On awaken it automatically relaunches MBC.  I found this was effective in reducing sleep related errors, especially with MPC-HC,  since sometimes my kids would turn off the HTPC in the middle of a movie. Plus its a clean way to start up...back at the main menu every time it awakens.  This setup may be related to the problem but I don't think its the whole story...I've been using it for a couple months and the problem with the message only started occuring a few weeks ago IIRC.

Link to post
Share on other sites

I should mention, too, that both the server and the client are on this HTPC.

 

That is the main issue probably as the server is trying to get going again at the same time you are trying to start MBC.  If you can put some sort of delay in your wake batch file that would give the server a few seconds to come alive, it may alleviate the problem.

Link to post
Share on other sites
mranim8or

Thanks, I'll try adding a delay via the timeout command.  What bugs me is the randomness of the problem...most times it works but sometimes it doesn't.

 

Could it be related to something on the server side....like if an automatic process (such as media library scan or chapter extraction) happens to be occuring when the comptuer is forced into sleep?

 

Hopefully the delay will be a cure for it.  In case others are having this issue I'll post the results here after testing for awhile.

Link to post
Share on other sites
mranim8or

After adding a 5 second delay via the batch file I mentioned, the problem has not re-occurred in the last few days.   Strange that the timeout default is 40 seconds if my HTPC starts up in ~20 seconds and still had this problem before the delay....I would've thought that meant the timeout delay defaults to 20 seconds.  All is well now, though. :)   Thanks for your help, ebr.

Link to post
Share on other sites

You can adjust the time-out yourself in the Advanced config panel in MBC.  It used to be 20 a while back and was increased to 40.  However, the system just not being ready may not wait for the time-out.  It may return faster than that.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...