Jump to content

Emby Theater 2.8.4 not using or remember default audio track?


ShoutingMan

Recommended Posts

ShoutingMan

Emby Theater 2.8.4 does not seem to use default audio track for at least one TV series. And it is not remembering the audio track selection if I change it, quit the app, and return.

 

 

I haven't explored further to see if it's just this one show on my server or throughout ET at the moment. In past version (2.8.3 and earlier) the default audio track played as expected.

 

The show is "Dirk Gentlys Holistic Detective Agency". The MKV files have a "Stereo" and a "Dolby Digital 5.1" track. The 5.1 is flagged as Default, using MKVToolNix. But ET plays the stereo track, the first track, everytime. If I manually switch the 5.1 track that plays fine. But quitting and returning, ET reverts back to the stereo track as default.

 

I've attached a log file from when I was playing some shows and experiencing this.

 

Log

Link to post
Share on other sites

Tested, no problem found. it is probably remembering from a previous playback session and that is leading you to think that playing the default track is not working.

Link to post
Share on other sites
Guest asrequested

I was running some tests on audio track playing, yesterday (a different but similar issue). When the audio stream is transcoded, no matter how I configured the settings in Theater, when resuming or playing from the beginning, the first audio track would always play. Not the default, but the first track, regardless of what it was.

Link to post
Share on other sites

it is probably remembering from a previous playback session and that is leading you to think that playing the default track is not working.

Link to post
Share on other sites
Guest asrequested

it is probably remembering from a previous playback session and that is leading you to think that playing the default track is not working.

 

But if I play something, choose the track, stop playback and then resume, should it not remember that choice? Regardless, if you're correct, then it's remembering that choice in perpetuity. No matter how many times I restarted, it played the first track. Again, this was only when the audio is being transcoded, not when it's direct playing.

Link to post
Share on other sites
ShoutingMan

Thamks. It might be related to previous settings.

 

I'd watched some of the episodes streaming to an AppleTV. The audio wasn't in surround, and I found the MKV audio metadata wasn't right. I edited the MKV data to label Stereo and Surround and set the Surround to the default.

 

So it might have be remembering previous settings and/or not updating to revised defaults immediately.

 

Thanks again for checking and the feedkback.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...