Jump to content


Photo

Kodi: Playback hangs after 60 Minutes

Samba hang

  • Please log in to reply
14 replies to this topic

#1 max06 OFFLINE  

max06

    Newbie

  • Members
  • 8 posts
  • Local time: 11:17 PM

Posted 11 September 2017 - 01:25 PM

Good evening everybody!

 

I just switched to emby from several years of Plex usage - and so far, I'm loving it.

 

Old setup: Synology Storage with Plex running on it, clients connecting via regular Plex Players or Kodi with PlexBMC-Plugin. Worked until the load on the synologies cpu got too high.

New setup: Synology hosts movies and tv shows on samba shares, emby is running on a windows 10 machine (in my own user account), accessing these samba shares. First client is Kodi with emby plugin, accessing via local network (= running on the same machine).

 

First problem: While setting the libs up, I had to enable the guest account on the synology just to make the samba shares visible to emby. (They were mounted in windows with my credentials). Adding the unc-Paths didn't help. But ok, guest access to these 2 shares is fine.

Important problem: While playing tv shows, the playback hangs after ~60 Minutes. No matter if I started a new episode in between. It just hangs and after some seconds the playback completely stops (or starts the next episode, depending on the playlist). 

 

I already found out that my samba connection seems to drop in that moment. At least windows reports the shares as disconnected and it has some trouble reconnecting to them. That lasts for 1-2 Minutes, then everything is back to normal - until the next 60 Minutes pass. Also the synology doesn't show my cifs-shares as in use (and corrects that info after windows managed to connect back).

 

I haven't tried to reproduce it with playback in my browser or with active transcoding. 

 

Did I miss anything? Can someone help me?

 



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 149353 posts
  • Local time: 04:17 PM

Posted 11 September 2017 - 01:46 PM

Hi, welcome. Best thing to do is start by attaching the information requested in how to report a problem. thanks !



#3 max06 OFFLINE  

max06

    Newbie

  • Members
  • 8 posts
  • Local time: 11:17 PM

Posted 11 September 2017 - 02:01 PM

Sure.

 

See the attached log please. I redacted my public hostname, please remove the file from this post once it's no longer needed.

 

I started watching at 18:27:53, it stopped around 18:58. What I can see that timestamp is obvious in the logfile. The next episode started automatically because I was using a playlist. If you need a more detailed log I need to change the loglevel and watch 2 more episodes.

 

 

Thank you for looking into this.

 


Edited by max06, 12 September 2017 - 11:44 AM.


#4 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 12738 posts
  • Local time: 03:17 PM

Posted 11 September 2017 - 03:27 PM

I think Luke meant your server log.


Sent from my iPhone using Tapatalk

#5 max06 OFFLINE  

max06

    Newbie

  • Members
  • 8 posts
  • Local time: 11:17 PM

Posted 11 September 2017 - 04:00 PM

Well, he linked to a thread where I was told to collect the kodi logs :D

 

Doesn't matter, here's the server log...

 

Btw: I just tested the playback in my browser (not sure if that includes transcoding. Debug info said DirectStream/HLS) - worked without problems...


Edited by max06, 12 September 2017 - 11:44 AM.


#6 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 12738 posts
  • Local time: 03:17 PM

Posted 11 September 2017 - 05:48 PM

Sorry I am away for the moment, but what version of kodi are you running? I suggest looking up "keep samba alive kodi {version}". I know you can adjust the timeout of smb via advancedsettings. This is not an issue with Emby for kodi but with Kodi terminating the smb connection.


Sent from my iPhone using Tapatalk

#7 max06 OFFLINE  

max06

    Newbie

  • Members
  • 8 posts
  • Local time: 11:17 PM

Posted 11 September 2017 - 06:13 PM

I didn't chose direct playback in the emby addon - so why should kodi play the file with samba? 

 

Also when the problem showed up I switched to direct playback, but the problem is still there. 

 

Using Kodi 17.4 (stable)



#8 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 12738 posts
  • Local time: 03:17 PM

Posted 11 September 2017 - 06:23 PM

Do you mean native playback mode?

Because both method offer direct playback via samba. With addon playback mode, you can also enable direct stream which gets the stream from the server rather than via smb. Is this what you are saying and still timing out?


Sent from my iPhone using Tapatalk

#9 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 12738 posts
  • Local time: 03:17 PM

Posted 11 September 2017 - 06:26 PM

I've just checked your logs and it's playing from smb in Kodi (in addon mode). Check my previous post for possible solutions.

Edit: the addon is not involved in playback. It just tells Kodi where to find the file. The rest is handled by Kodi.

If you use direct stream, then the server pretty much dictate what happens to the stream. If it times out, it'd show in your server log.

Sent from my iPhone using Tapatalk

Edited by Angelblue05, 11 September 2017 - 07:03 PM.


#10 max06 OFFLINE  

max06

    Newbie

  • Members
  • 8 posts
  • Local time: 11:17 PM

Posted 12 September 2017 - 02:58 AM

Good morning.

 

Sorry for the confusion here - that stuff is pretty new to me. 

 

So, Kodi is right now just taking the samba paths from Emby and opens the files directly?

I can disable this by turning on direct streming?

 

Yesterday I opened a ticket with Synology and asked for help on that 60 Minutes timeout. They replied that this is much likely a security limit for the guest account and I should try to disable it and use a regular user account/mount. So - here we're back at problem 1 described in my opening post - any ideas for that? :)

 

Have a nice day!



#11 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 149353 posts
  • Local time: 04:17 PM

Posted 12 September 2017 - 03:09 AM

Well we don't have a 1 hour time limit.



#12 max06 OFFLINE  

max06

    Newbie

  • Members
  • 8 posts
  • Local time: 11:17 PM

Posted 12 September 2017 - 03:14 AM

No, I mean how to make emby use of a regular user account for the samba shares? 



#13 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 149353 posts
  • Local time: 04:17 PM

Posted 12 September 2017 - 03:16 AM

the smb path is the same no matter what kind of emby account you use, and the emby account will not affect access to the smb path.

 

is it possible the machine is going to sleep?



#14 max06 OFFLINE  

max06

    Newbie

  • Members
  • 8 posts
  • Local time: 11:17 PM

Posted 12 September 2017 - 03:22 AM

Definitely not. 

 

The NAS is working all day (right now with a big backup) and my client is running Emby and Kodi at the same time, all screensavers/standby/hibernate-timers disabled.

 

Just to ensure that here's no misunderstanding going on: In my opening post I asked about two problems. I accept that the second problem (the 60 minutes limit in Kodi) is not a problem of emby. Now I was just wondering about the first issue, which is about the requirement to have the guest account enabled on my nas because emby doesn't offer a way to provide credentials for protected shares.



#15 max06 OFFLINE  

max06

    Newbie

  • Members
  • 8 posts
  • Local time: 11:17 PM

Posted 12 September 2017 - 04:59 AM

Nevermind... 

 

After reading some more topics in here I found the description about how to setup emby as a service in windows. This and a marked checkbox in the windows samba login dialogue allowed me to disable the guest account on the synology. So far it looks good.

 

Today evening I have time to test it with Kodi, hopefully the problem is now completely gone away.

 

Thank you all :)







Also tagged with one or more of these keywords: Samba, hang

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users