Jump to content


Photo

Slow channel changing

slow channel changing

  • Please log in to reply
43 replies to this topic

#21 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142200 posts
  • Local time: 12:03 AM

Posted 01 September 2017 - 10:22 PM

Everytime you tune/change a channel emby runs ffprobe for a few sec to figure out which video and audio stream are available.

I could be wrong but at least for hdhomerun atsc tuner. I think this information remain static. Which means that the scan process (or a daily scan) might be able to figure out the available stream once. And then rely on that stored information next time it starts to play.

In my mind that would make live tv without transcoding super fast.

 

Emby Theater desktop does not probe anymore.



#22 afullmark OFFLINE  

afullmark

    Advanced Member

  • Members
  • 91 posts
  • Local time: 05:03 AM

Posted 02 September 2017 - 03:12 AM

Everytime you tune/change a channel emby runs ffprobe for a few sec to figure out which video and audio stream are available.

I could be wrong but at least for hdhomerun atsc tuner. I think this information remain static. Which means that the scan process (or a daily scan) might be able to figure out the available stream once. And then rely on that stored information next time it starts to play.

In my mind that would make live tv without transcoding super fast.


Ah, uk broadcasting isn't static though; different programmes on same channel can have varying framerates and audio: 2.0 to 5.1.
  • pĆ¼nktchen likes this

#23 nyplayer OFFLINE  

nyplayer

    Advanced Member

  • Members
  • 509 posts
  • Local time: 10:03 PM

Posted 03 September 2017 - 03:03 PM

Everytime you tune/change a channel emby runs ffprobe for a few sec to figure out which video and audio stream are available.

I could be wrong but at least for hdhomerun atsc tuner. I think this information remain static. Which means that the scan process (or a daily scan) might be able to figure out the available stream once. And then rely on that stored information next time it starts to play.

In my mind that would make live tv without transcoding super fast.

 

+1 It has gotten to the point where I really do not want to use EMBY for live TV .... does everything have to be probed all the time ?


  • afullmark likes this

#24 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142200 posts
  • Local time: 12:03 AM

Posted 03 September 2017 - 03:07 PM

+1 It has gotten to the point where I really do not want to use EMBY for live TV .... does everything have to be probed all the time ?

 

Please see my response to you in your topic. Thanks.



#25 meep OFFLINE  

meep

    Member

  • Members
  • 28 posts
  • Local time: 05:03 AM

Posted 16 December 2017 - 05:57 PM

Every 12 months or so, I take out an Emby subscription in the hope that it will now fit my needs.

 

Once again, I'm disappointed. There's a lot to like, and I use Emby Server as the foundation of my whole house media system. However, LiveTV/PVR is a critical part of my setup and, though there have been great strides, the channel tuning times are so long on almost all of the clients as to make it unusable.

 

There's a ;lot to like about Emby and the Emby way but it's still not fulfilling my needs.

 

See you next year, Emby!



#26 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142200 posts
  • Local time: 12:03 AM

Posted 16 December 2017 - 09:27 PM

@meep what apps did you try because Emby Theater for Windows and Emby for Android mobile should start up pretty quickly as they can just direct play it.



#27 meep OFFLINE  

meep

    Member

  • Members
  • 28 posts
  • Local time: 05:03 AM

Posted 19 December 2017 - 06:38 AM

@meep what apps did you try because Emby Theater for Windows and Emby for Android mobile should start up pretty quickly as they can just direct play it.

 

Hi @Luke

 

Thanks for the response.

 

I tried web client on OSX (there no OSX equivalent of Theater?), the iOS app and the Emby app on my Amazon FireTV. All exhibited painfully slow live TV tuning.

 

I'll try installing the Android App on my phone to see how that performs.

 

Do you think direct play will eventually make it's way to the other apps & platforms? It's really the only thing left preventing me making the move from Kodi to Emby for all my clients.



#28 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142200 posts
  • Local time: 12:03 AM

Posted 19 December 2017 - 12:57 PM

there is no web browser that supports mpeg2video or the mpegts container, so as long as your live tv contains any of those then they won't direct play. The others are things that we can improve, yes.



#29 zombiefly OFFLINE  

zombiefly

    Newbie

  • Members
  • 6 posts
  • Local time: 06:03 AM

Posted 09 March 2018 - 04:42 PM

hi,

i have this problem too.

 

i use iptv in emby server. if i browse the server in a web browser, go to guide, select a channel then it takes a few seconds to start playing. 

If i use emby theatre on any machine, then changing channels from the tv guide takes up to a minute. after that it either stops completely (still image) returns to the guide or plays. 

 

if i connect to the same service via the raspberry pi, the guide works perfectly.

 

if i play content from my server (stored in the movie libraries) in emby theatre, everything is fine (using direct stream)....

 

after reading for a while in the forums i don't hold out much hope for a fix, unless i'm missing something....


Edited by zombiefly, 09 March 2018 - 04:51 PM.


#30 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142200 posts
  • Local time: 12:03 AM

Posted 09 March 2018 - 05:00 PM

hi,

i have this problem too.

 

i use iptv in emby server. if i browse the server in a web browser, go to guide, select a channel then it takes a few seconds to start playing. 

If i use emby theatre on any machine, then changing channels from the tv guide takes up to a minute. after that it either stops completely (still image) returns to the guide or plays. 

 

if i connect to the same service via the raspberry pi, the guide works perfectly.

 

if i play content from my server (stored in the movie libraries) in emby theatre, everything is fine (using direct stream)....

 

after reading for a while in the forums i don't hold out much hope for a fix, unless i'm missing something....

 

hi there @zombiefly, can we please look at an example? please attach the information requested in how to report a media playback issue. thanks !



#31 zombiefly OFFLINE  

zombiefly

    Newbie

  • Members
  • 6 posts
  • Local time: 06:03 AM

Posted 09 March 2018 - 05:38 PM

sure no problem

 

i made a video of the web browser live tv guide/select channel vs. the same in emby theatre.

you can see the browser is fast, theatre takes over a minute (i stopped recording but it did eventually start playing)

https://photos.app.g...OXk4ctO2jwQkLp2

 

logs attached

Attached Files


Edited by zombiefly, 09 March 2018 - 05:39 PM.


#32 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142200 posts
  • Local time: 12:03 AM

Posted 10 March 2018 - 02:47 AM

sure no problem

 

i made a video of the web browser live tv guide/select channel vs. the same in emby theatre.

you can see the browser is fast, theatre takes over a minute (i stopped recording but it did eventually start playing)

https://photos.app.g...OXk4ctO2jwQkLp2

 

logs attached

 

In this case it tries to direct play, then has an error and has to switch to transcoding. can you send me a sample m3u over PM? Thanks.



#33 zombiefly OFFLINE  

zombiefly

    Newbie

  • Members
  • 6 posts
  • Local time: 06:03 AM

Posted 10 March 2018 - 04:01 AM

In this case it tries to direct play, then has an error and has to switch to transcoding. can you send me a sample m3u over PM? Thanks.

 

 

aha! i've sent you a PM with an example

 

thanks



#34 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142200 posts
  • Local time: 12:03 AM

Posted 10 March 2018 - 03:00 PM

Thanks.

#35 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142200 posts
  • Local time: 12:03 AM

Posted 10 March 2018 - 11:55 PM

It seemed to play OK for me and started up within five seconds. In my case I did not see any transcoding.



#36 zombiefly OFFLINE  

zombiefly

    Newbie

  • Members
  • 6 posts
  • Local time: 06:03 AM

Posted 11 March 2018 - 06:56 AM

this is interesting. i've installed server on my main windows 10 pc and connected theatre to it from the same pc, it's working.

i'll continue testing... will try it from a client machine now



#37 zombiefly OFFLINE  

zombiefly

    Newbie

  • Members
  • 6 posts
  • Local time: 06:03 AM

Posted 11 March 2018 - 12:21 PM

ok. I have a working solution now, here's my findings

 

1. install emby server and theatre (desktop) on win10 pc. theatre plays live tv fine from server on same machine

2. install emby theatre (desktop) on another pc, connect to emby server on win10 pc, live tv won't stream. same as before.

3. install emby theatre (windows store version) on another pc, connect to emby server on win10 pc, live tv streams with no issue

4. connect emby theatre (windows store version) to original server, live tv streams with no issue.

 

there is something different with the desktop version, but this isn't a problem as I can use the Win10 store version. 

 

I've PM'd the logs for the failed point 2 above, the log should contain evidence of the desktop version failure, followed by the win10 app success if that helps at all.

 

 

 



#38 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142200 posts
  • Local time: 12:03 AM

Posted 11 March 2018 - 01:19 PM

Thanks for the info.

#39 kikinjo OFFLINE  

kikinjo

    Advanced Member

  • Members
  • 268 posts
  • Local time: 06:03 AM

Posted 19 March 2018 - 03:32 PM

 I have very similar issue, setup iptv provider, try with web app works fine, try with emby theater store version works fine.

 

 Emby desktop version (which i use the most) no stream at all, loading for ages, ET hangs, or stream loads after 5+ minutes. Mainly ET desktop crashing and spinning unresponsively. looked at logs and sometime it starts direct sometimes starts a transcode, ut no stream only spining circle.

 

 The biggest mystery is why is working in web normal. Same server, same iptv provider,

 

 Will gather logs and post.


Edited by kikinjo, 19 March 2018 - 03:34 PM.


#40 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142200 posts
  • Local time: 12:03 AM

Posted 19 March 2018 - 03:42 PM

 I have very similar issue, setup iptv provider, try with web app works fine, try with emby theater store version works fine.

 

 Emby desktop version (which i use the most) no stream at all, loading for ages, ET hangs, or stream loads after 5+ minutes. Mainly ET desktop crashing and spinning unresponsively. looked at logs and sometime it starts direct sometimes starts a transcode, ut no stream only spining circle.

 

 The biggest mystery is why is working in web normal. Same server, same iptv provider,

 

 Will gather logs and post.

 

Yes please do that, thanks.







Also tagged with one or more of these keywords: slow, channel, changing

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users