Jump to content

Show Intro Skip Option (Plugin)


Liquidfire88

Recommended Posts

Amanade3
15 hours ago, ebr said:

Auto skip is in the latest beta in the core.

Oh thanks I see it now in playback settings.

Link to comment
Share on other sites

crusher11

End credits detection on Prison Break has been an abysmal failure. It's picking up something, because it's almost always ~20 seconds late, but I don't know what it's picking up on.

Link to comment
Share on other sites

crusher11

Also on one of my specials it seems to have found an intro between 00:18:58 and 00:19:19 in a file that is only 00:13:05. Makes no sense...

Link to comment
Share on other sites

Banquero

Buenos dias, cuando el plugin no detecta adecuadamente el principio o fin de la intro y quiero editarla manualmente, cuando modifico los tiempos, debo salvar los datos o directamente establece los nuevos valores? Muchas gracias....

Link to comment
Share on other sites

Cheesegeezer
2 minutes ago, Banquero said:

Good morning , when the plugin does not properly detect the beginning or end of the intro and I want to edit it manually, when I modify the times, should I save the data or directly set the new values? Thank you very much....

You need to save the data

  • Thanks 1
Link to comment
Share on other sites

Banquero
54 minutes ago, Cheesegeezer said:

Tienes que guardar los datos

Una vez hechas las modificaciones he de actualizar los metadatos de nuevo? Muchas gracias...

Link to comment
Share on other sites

Cheesegeezer
3 minutes ago, Banquero said:

Once the modifications have been made, do I have to update the metadata again? Thank you very much...

Yes but just do it for the seasons or series you edited. Also you need to run chapter task after the refresh is completed 

Link to comment
Share on other sites

Banquero

He modoficado los tiempos de la primera temporada de Juego de Tronos y los he salvado. En la pantalla del plugin se ve que los ha guardado correctamente, pero una vez actualizados los metadatos e incluso escaneado de nuevo la temporada y ejecutar la tarea de Intro Skip, no finaliza correctamente..Mantiene los tiempos anteriores..Que estoy haciendo mal? Muchas gracias...

image.thumb.png.2dc6908550a2c221e8ec176a70f0f82c.png

Link to comment
Share on other sites

koopa8840

I just wanted to add that the show All American does not have the traditional intro, but instead starts with an episode recap. so the scanning is incorrect. Just wanted to make others aware.

Link to comment
Share on other sites

y3knik

Hello, I am on server version 4.7.1 and Android app version 2.0.70g with the plugin enabled. Should I expect to see a Skip button on the UI? The button shows up on the webapp, but not the android app. 

Link to comment
Share on other sites

crusher11
1 minute ago, y3knik said:

Hello, I am on server version 4.7.1 and Android app version 2.0.70g with the plugin enabled. Should I expect to see a Skip button on the UI? The button shows up on the webapp, but not the android app. 

The button wasn't in place for the ATV app as of the last stable release, but it's in the current beta.

  • Like 2
Link to comment
Share on other sites

Cheesegeezer
Posted (edited)
3 minutes ago, y3knik said:

Hello, I am on server version 4.7.1 and Android app version 2.0.70g with the plugin enabled. Should I expect to see a Skip button on the UI? The button shows up on the webapp, but not the android app. 

You need to speak to core devs. This is a feature they have allowed. But in general it’s working on ATV

What Crusher said above ⬆️ 

Edited by Cheesegeezer
Link to comment
Share on other sites

y3knik
11 minutes ago, crusher11 said:

The button wasn't in place for the ATV app as of the last stable release, but it's in the current beta.

Aha! That is what it was! Installed the latest beta and now its there. Thank you!!

The plugin works great, thank you for your hard work on this!

  • Thanks 1
Link to comment
Share on other sites

crusher11

My custom intro timings appear to be getting overwritten on each scan.

Link to comment
Share on other sites

Cheesegeezer
Posted (edited)
2 hours ago, crusher11 said:

My custom intro timings appear to be getting overwritten on each scan.

By what or how? Can you elaborate. 
 

if you use autoskip in the plugin, is that accurate.  If you are after the button skip could be a interchange issue while we migrate. 

Edited by Cheesegeezer
Link to comment
Share on other sites

binarygeek119

bob's burgers end credit dont work as the ending audio is different each episode, but im hoping if the text recognition it might work. just fyi the background for the ending is white with black text with animation to the side 

image.thumb.png.0d95995708aa22cd042558664c5f6f21.png

Link to comment
Share on other sites

crusher11
6 hours ago, Cheesegeezer said:

By what or how? Can you elaborate. 
 

if you use autoskip in the plugin, is that accurate.  If you are after the button skip could be a interchange issue while we migrate. 

It appears to only affect seasons that have had episodes added or altered between scans. All the intros get reset back to what they were before I edited them. End credits seem to be unaffected. 

Link to comment
Share on other sites

fbrassin

I've updated emby server to 4.8.0.0 and after that i realized intro skip plugin was not installed anymore.

So i installed it from catalog, now i have plugin installed with all series with intro recognized, autoskip is enabled, but my when i start an episode intro is not skipped anymore, nor with web app not with ATV.

Any idea?

Link to comment
Share on other sites

rbjtech
6 hours ago, crusher11 said:

It appears to only affect seasons that have had episodes added or altered between scans. All the intros get reset back to what they were before I edited them. End credits seem to be unaffected. 

So remember, if you manually edit anything in the Plugin - then you need to Reset the Metadata on the item you edited (or Season, Show etc) and then re-import the data again by running the 'IntroSkip Chapter Insertion' task.  Once the markers are in - they stay in, unless you manually reset the metadata.

It's going to be a bit of pain until the Intro systems from Core/Plugin are fully aligned - then we can remove the Intro detection from the Plugin - but we are fully dependent on the Core delivering an editor to do this.

Do not run the Core Introskip as well as the Plugin - there is no requirement to run both at this time.

Link to comment
Share on other sites

crusher11
Just now, rbjtech said:

So remember, if you manually edit anything in the Plugin - then you need to Reset the Metadata on the item you edited (or Season, Show etc) and then re-import the data again by running the 'IntroSkip Chapter Insertion' task.  Once the markers are in - they stay in, unless you manually reset the metadata.

It's going to be a bit of pain until the Intro systems from Core/Plugin are fully aligned - then we can remove the Intro detection from the Plugin - but we are fully dependent on the Core delivering an editor to do this.

Do not run the Core Introskip as well as the Plugin - there is no requirement to run both at this time.

No, you misunderstand.

I set up all my intros. While I was doing this, I added an episode from an ongoing show to the most recent season.

I then turned on the chapters, which I'd never previously used, and everything imported. Worked fine for the first few things I tried, but then failed on something from the season where I'd added the episode.

I checked the editor, and it had reset the intros for that season to what was originally auto-detected, which had a few errors. The episode I'd tried was one of the errors, and it had returned to its erroneous timings.

Link to comment
Share on other sites

rbjtech
2 minutes ago, crusher11 said:

No, you misunderstand.

I set up all my intros. While I was doing this, I added an episode from an ongoing show to the most recent season.

I then turned on the chapters, which I'd never previously used, and everything imported. Worked fine for the first few things I tried, but then failed on something from the season where I'd added the episode.

I checked the editor, and it had reset the intros for that season to what was originally auto-detected, which had a few errors. The episode I'd tried was one of the errors, and it had returned to its erroneous timings.

Nothing has changed in the Plugin at all - if you never used the Chapters - then that's all good, it would continue to work with auto-skip, your manual edits etc.

The only thing that has changed is we can now insert the hidden markers into the Core database - but in order to do this, you need to run the 'Introskip Chapter Insertion' task and it it needs to be run on an item WITHOUT previously added IntroSkip Plugin chapters - otherwise it will just skip that item.

ANY previously detected or manual edited entry prior to running this task will be used as a) the new chapter points and b) the hidden markers for the 'button'.

Any NEW detection or NEW editing after this will again need the Introskip Chapter Insertion task run to get the NEW markers added - the best way is simply ensure it has a scheduled task - every 4hours etc.   If you don't do this - then the Plugin auto-skip etc will carry on working, but you won't get the hidden markers added - thus the button won't work for just those NEW entries.

Does that explain it better ?

Link to comment
Share on other sites

crusher11

Ignore the chapters. Ignore the core.

 

I edited some intros in the plugin. I added an episode to that season. My intro timings for that season got reset in the plugin editor.

Nothing about the core or importing the data is relevant here. 

Link to comment
Share on other sites

Cheesegeezer
2 minutes ago, crusher11 said:

Ignore the chapters. Ignore the core.

 

I edited some intros in the plugin. I added an episode to that season. My intro timings for that season got reset in the plugin editor.

Nothing about the core or importing the data is relevant here. 

Did you hit save? or save all

nothing has changed in any of the code, except for chapters

 

Link to comment
Share on other sites

crusher11
3 minutes ago, Cheesegeezer said:

Did you hit save? or save all

nothing has changed in any of the code, except for chapters

 

I hit save on every episode I edited, yes.

I don't know how well it worked previously as I was avoiding digging too deep into editing while we waited for core implementation. It's possible I've simply stumbled on a bug that has always been there. 

Link to comment
Share on other sites

Cheesegeezer
1 minute ago, crusher11 said:

I hit save on every episode I edited, yes.

I don't know how well it worked previously as I was avoiding digging too deep into editing while we waited for core implementation. It's possible I've simply stumbled on a bug that has always been there. 

true.... and thanks.  

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...