Jump to content

Subtitles with garbage characters


CarlosLima
 Share

Go to solution Solved by Luke,

Recommended Posts

CarlosLima
After upgrading to the latest version of Emby Server, I noticed that legends, formerly perfect, are displaying garbage characters when the letter is accented.

In Brazil letters with accents are very common, so these characters in question mark format are all over the legend.

 

5903e932663ae_Capturar.png

Link to comment
Share on other sites

CarlosLima

Hi, can you please discuss a specific example? What kind of video/subtitles?

 

Hi, do you need more details besides the data in this image?

 

590400dc5eca6_Capturar.png

  • Like 1
Link to comment
Share on other sites

CarlosLima

Can you please zip up the subtitles and attach them here? thanks.

 

Sure, but how do I attach the file here?

The site says I do not have permission to attach file.

Edited by CarlosLima
Link to comment
Share on other sites

  • 2 weeks later...
jonaslpalma

Hi There, You could find out the solution for that issue? I have the same problem here. And more,  when reproducing DLNA the subtitle works fine until it find the first "especial caracter", a  accented letter.

 

Let me know if I can help with anything.

Link to comment
Share on other sites

Hi There, You could find out the solution for that issue? I have the same problem here. And more,  when reproducing DLNA the subtitle works fine until it find the first "especial caracter", a  accented letter.

 

Let me know if I can help with anything.

Hi, can you please discuss a specific example? What kind of video/subtitles?

Link to comment
Share on other sites

jonaslpalma

Sure, I have attached the .srt external subtitle and a print of what is wrong (in that case playing the video in Google Chrome). The correct frase is (from de .srt file):

 

2
00:00:02,085 --> 00:00:04,100
Pai, esta é a mãe do Sheldon,
Mary.

 

5910a77e9ab54_Capture.jpg

 

So every time when a Letter has an accent ( that scenario is very commun in my language) Emby don´t know how to "translate" to the correct letter. When I use DLNA ( Sony Bravia 2010 TV) the subtitle works until the letter with accent, after that, no more subtitles are displayed in the tv. I think this is related with the txt codification in the server.

 

 

The.Big.Bang.Theory.S10E01.1080p.HDTV.X264-DIMENSION.srt

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...