Jump to content


Photo

Breeze Freeze - any ideas?

breeze themes

Best Answer leedavies , 11 February 2014 - 08:33 AM

Hi Lee, 

 

Nice to hear you have found and fixed it!  :)

Is Crystal also having the same issue and could it be fixed similar? 

 

Yes, the fixes going into this new Breeze release will also be going into ROC and Crystal releases ASAP.

Go to the full post


  • Please log in to reply
11 replies to this topic

#1 divide_by_zero OFFLINE  

divide_by_zero

    Advanced Member

  • Members
  • 34 posts
  • Local time: 07:17 AM

Posted 05 February 2014 - 02:35 AM

Hi all,

 

Having a bit of an issue with Breeze, and wondering if it's a problem anyone else is encountering. When scrolling through movie titles (detail view), things will totally hang right around the time I get to "H". Shouldn't say "right around" - it's *always* when it gets to the first Harry Potter movie. When it hangs, the whole UI just becomes completely unresponsive, and the interface often goes grey like a hung Windows app. I've let it sit for several minutes and it never recovers - have to go to taskmgr and kill MCE. Same behavior if I scroll in reverse through the library - gets hung up somewhere in the "T" range I believe.

I've confirmed I have the same issue on both my HTPC (also running the MB server) as well as my laptop. Loving Breeze, but can't use as the daily driver until I find a fix. The movie library has 400+ titles, but can't imagine that being terribly unique around these parts. Also confirmed that I do not see the behavior when using either the default theme or Subdued.

 

Don't have access to specific build version numbers at the moment, but can tell you things should be current as I update both the server and themes whenever there's a notification upon launch, and that the problem has persisted over the past couple weeks when I first noticed it.

 

Any and all help is appreciated! I know I've said it before, but it merits repeating - MB (and Breeze for that matter!) is amazing, and thanks to the work of all the devs who make this possible!

 

Thanks,
db0



#2 leedavies OFFLINE  

leedavies

    Advanced Member

  • Members
  • 660 posts
  • Local time: 07:17 AM

Posted 05 February 2014 - 02:26 PM

Hi all,

 

Having a bit of an issue with Breeze, and wondering if it's a problem anyone else is encountering. When scrolling through movie titles (detail view), things will totally hang right around the time I get to "H". Shouldn't say "right around" - it's *always* when it gets to the first Harry Potter movie. When it hangs, the whole UI just becomes completely unresponsive, and the interface often goes grey like a hung Windows app. I've let it sit for several minutes and it never recovers - have to go to taskmgr and kill MCE. Same behavior if I scroll in reverse through the library - gets hung up somewhere in the "T" range I believe.

I've confirmed I have the same issue on both my HTPC (also running the MB server) as well as my laptop. Loving Breeze, but can't use as the daily driver until I find a fix. The movie library has 400+ titles, but can't imagine that being terribly unique around these parts. Also confirmed that I do not see the behavior when using either the default theme or Subdued.

 

Don't have access to specific build version numbers at the moment, but can tell you things should be current as I update both the server and themes whenever there's a notification upon launch, and that the problem has persisted over the past couple weeks when I first noticed it.

 

Any and all help is appreciated! I know I've said it before, but it merits repeating - MB (and Breeze for that matter!) is amazing, and thanks to the work of all the devs who make this possible!

 

Thanks,
db0

 

Hi

 

What view style are you using? Cover flow, thumb, poster?  Are all styles doing this or just one?

 

As a test, try increasing or decreasing your cover image size in the view options menu for a folder where you're seeing this hang.  Some of the view styles in my themes push Windows Media Center pretty hard and mess with the spacial positioning of objects.  I thought we'd nailed all the edge cases I've seen or had reported, but sometimes, the hang is simply that WMC can't work out which cover is "next", panics and gets stuck in a loop!

 

Anyway, let me know which view(s) and try the cover size trick - temporary workaround I know, but we'll find and fix the real problem.



#3 divide_by_zero OFFLINE  

divide_by_zero

    Advanced Member

  • Members
  • 34 posts
  • Local time: 07:17 AM

Posted 06 February 2014 - 03:35 AM

Hi Lee,

 

On both systems, I'm using the "Detail" view, which is what I'd like to use once this gets sorted out. This view does not have the option to increase or decrease image sizes.

 

Tried "Poster" for a few minutes to test tonight, and didn't seem to encounter the issue. Next I tried "Cover flow", and after browsing a bit I got a message along the lines of "Media Browser has stopped responding and will close". This happened twice, and I believe it was on different movie titles each time. I decreased the cover image size with Cover Flow selected and futzed around some more, and didn't seem to have any issues scrolling through the library several times with smaller images.

 

Please let me know if there are any additional settings I should tinker with.

Thanks!



#4 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 45381 posts
  • Local time: 03:17 AM

Posted 06 February 2014 - 09:53 AM

Lee - make sure you are using PreferredImageSmall as the binding for all items in a large list other than the currently selected one.



#5 leedavies OFFLINE  

leedavies

    Advanced Member

  • Members
  • 660 posts
  • Local time: 07:17 AM

Posted 06 February 2014 - 11:46 AM

Lee - make sure you are using PreferredImageSmall as the binding for all items in a large list other than the currently selected one.

 

Yeah, I do, and switch to the higher res image on focus.  In my experience the hangs have often been a JSON error thrown by MBC or MBC for some reason sending repeat property change notifications for preferredimage on the current item.



#6 1972 OFFLINE  

1972

    Advanced Member

  • Members
  • 79 posts
  • Local time: 09:17 AM
  • LocationTilburg, The Netherlands

Posted 10 February 2014 - 04:53 AM

Hi Lee, 

 

I also mentioned this in the Aztec freezing posting, but I see similar behavior in the Crystal theme with large collections. For instance my movie collection (>200) also freezes during scrolling. If I wait some time (e.g. several seconds), it will continue again normally but after some movies the issue repeats itself....  :(



#7 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 45381 posts
  • Local time: 03:17 AM

Posted 10 February 2014 - 08:56 AM

Can I see an MBC log from when you make this happen?



#8 divide_by_zero OFFLINE  

divide_by_zero

    Advanced Member

  • Members
  • 34 posts
  • Local time: 07:17 AM

Posted 11 February 2014 - 03:40 AM

Would a log from me be of any use as well? If so, please just point me at the logging steps, and I'll provide logs.

 

Since iI experience the issue on botn by my HTPC and my laptop, let me know if logging on both systems would be helpful.



#9 leedavies OFFLINE  

leedavies

    Advanced Member

  • Members
  • 660 posts
  • Local time: 07:17 AM

Posted 11 February 2014 - 08:06 AM

Would a log from me be of any use as well? If so, please just point me at the logging steps, and I'll provide logs.

 

Since iI experience the issue on botn by my HTPC and my laptop, let me know if logging on both systems would be helpful.

 

No logs needed, but thanks for the offer.  The List/Detail view hang/freeze issue is fixed and will be in a Breeze update going live hopefully later today,  This update should bring Breeze up to date with all the recent performance enhancements.  Breeze is flying along now and feeling great!



#10 1972 OFFLINE  

1972

    Advanced Member

  • Members
  • 79 posts
  • Local time: 09:17 AM
  • LocationTilburg, The Netherlands

Posted 11 February 2014 - 08:25 AM

Hi Lee, 

 

Nice to hear you have found and fixed it!  :)

Is Crystal also having the same issue and could it be fixed similar? 



#11 leedavies OFFLINE  

leedavies

    Advanced Member

  • Members
  • 660 posts
  • Local time: 07:17 AM

Posted 11 February 2014 - 08:33 AM   Best Answer

Hi Lee, 

 

Nice to hear you have found and fixed it!  :)

Is Crystal also having the same issue and could it be fixed similar? 

 

Yes, the fixes going into this new Breeze release will also be going into ROC and Crystal releases ASAP.


  • 1972 and divide_by_zero like this

#12 divide_by_zero OFFLINE  

divide_by_zero

    Advanced Member

  • Members
  • 34 posts
  • Local time: 07:17 AM

Posted 14 February 2014 - 01:15 AM

Hi Lee,

Thanks for the update! Things are definately improved - did a whole bunch of scrolling in "Detail" view and the hanging didn't occur - wahoo!

 

There does appear to be a wee bit of a new issue, however. In about 30 minutes spent inside MB, I've had a message along the lines of "Media Browser has stopped responding" twice. Not sure if the regression is with the MB client or the theme, as both were updated tonight. Not a showstopper, certainly, but I'll keep an eye on it and see if I can determine any patterns regarding when it occurrs.

 

Again, thanks for your work on this awesome theme! (I'll probably post a feature request or two, but it's already hovering at around 95% perfect for my needs!)







Also tagged with one or more of these keywords: breeze, themes

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users