Jump to content

Acciones muy muy lentas en algunos accesos


jorg8

Recommended Posts

Hola,

 

Llevo ya casi un mes dándole vueltas desde que instalé el servidor de Emby y después de conseguir afinar la configuración en muchos aspectos, hay uno que no consigo solucionar.

 

Utilizo la versión 3.2.1.0-1 instalada en un NAS synology DS216+, y de momento he añadido unas 595 películas, 60 series y 70 vídeos musicales a mi biblioteca.

 

El caso es que cuando empiezo a consultar el contenido desde la web (Chrome Emby Mobile 3.2.1.0) o desde Emby Theater hay algunas acciones que tardan mucho tiempo (desde 2 minutos hasta más de 10). Sobre todo cuando utilizo el buscador o consulto el detalle de algún contenido y veo las fotos de los actores, en estos dos casos pasa siempre. Durante este tiempo el servidor se queda inútil y no responde a nada más, luego cuando termina la consulta en cuestión desencadena el resto de acciones. Adjunto el log completo de un caso de búsqueda como ejemplo.

 

Puedo confirmar que no tengo ninguna tarea de ffmpeg funcionando que haga que ralentice la máquina:

*****@*******:~$ ps -ef | grep Emby
*****    23420 22309  0 13:16 pts/4    00:00:00 grep --color=auto Emby
embysvr  23567     1  4 10:39 ?        00:06:00 /var/packages/EmbyServer/target/mono/bin/mono /var/packages/EmbyServer/target/server/MediaBrowser.Server.Mono.exe -package synology -programdata /var/packages/EmbyServer/target/var -ffmpeg /var/packages/EmbyServer/target/ffmpeg/bin/ffmpeg -ffprobe /var/packages/EmbyServer/target/ffmpeg/bin/ffprobe -restartpath /var/packages/EmbyServer/scripts/restart

Y que las tareas del servidor las tengo configuradas para que empiecen por la noche y a partir de las 8 de la mañana ya han terminado todas.

 

También añadir que en el momento de la búsqueda el nivel de ocupación del procesador del NAS era de un 16% y un 65% de RAM, por lo que no parece que estuviera muy estresado.

 

He buscado bastante, pero no consigo encontrar una solución.

 

Gracias.

emby.log

Edited by jorg8
Link to post
Share on other sites

Hola @ jorg8, bienvenido! ¿Puede proporcionar un registro de Emby Server desde el momento de la actividad lenta? Usted puede aprender a hacer eso aquí:

 

Https://emby.media/community/index.php?/topic/739-how-to-report-a-problem/

 

Gracias !

 

Hola, adjunto el fichero de log con la prueba que acabo de hacer. Estos han sido los pasos:

  • Reinicio del servidor para empezar la prueba y que no hubiese ningún proceso funcionando. - OK (inicio correcto)
  • Acceso a la página de inicio a través del navegador (chrome). - OK (ha cargado las listas correctamente)
  • Pulsado el icono de búsqueda.- OK (se muestra la página para buscar)
  • Introducido una palabra de prueba en la caja de búsqueda. SLOW (3 minutos esperando el resultado, 3 coincidencias)
  • Selección de una de mis librerías de películas. - OK (se muestra el listado de sugerencias)
  • Consulta del listado completo de películas. - OK (se muestran los 100 primeros resultados y sus imágenes sin problemas)
  • Selección de una película. - OK (se muestra el contenido perfectamente)
  • Desplazo del scroll hacia abajo para ver las imágenes de los actores. - SLOW (muy muy lento, han aparecido 5 ó 6 al instante, pero para otras 6 ó 7 ha tardado más de 30 minutos en cargarlas)

Os agradecería mucho cualquier sugerencia, ya que 3 minutos una búsqueda y más de 30 las fotos de unos actores me resulta muy extraño.

 

¡Gracias!

server-63623190233.txt

Link to post
Share on other sites

Hola @@jorg8, ¿cuándo instalaste por primera vez Emby? En otras palabras, ¿qué edad tiene esta instalación? Si eliminas todos los complementos, ¿el problema persiste? Además, ¿ha creado algún boxsets (colecciones) de películas? Gracias !

Link to post
Share on other sites

Hola @@jorg8, ¿cuándo instalaste por primera vez Emby? En otras palabras, ¿qué edad tiene esta instalación? Si eliminas todos los complementos, ¿el problema persiste? Además, ¿ha creado algún boxsets (colecciones) de películas? Gracias !

 

Instalé el servidor hace un mes.

En cuanto a las colecciones, si, tengo creadas algunas con el plugin de boxsets.

 

He probado a eliminar todos los plugins que tenía: AutoBoxSets, Emby for Kodi y Trackt.

He parado el servidor, he borrado toda la caché, y me sigue pasando lo mismo. Puedo navegar hasta entrar a ver el detalle de un capítulo de una serie, pero en el momento que hago scroll e intenta cargar las fotos de los actores, tarda muchísimo en contestar:

2017-02-22 17:15:12.7400 Info HttpClient: HttpClientManager GET: https://www.thetvdb.com/banners/actors/82124.jpg
2017-02-22 17:15:12.8122 Info HttpServer: HTTP GET http://192.168.1.177:8096/emby/Users/27f6a9dfc71f4fa48dbeb84cdb86acd4/Items/0fd1f31db42203a29ce843cdac19dcf2. UserAgent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36
2017-02-22 17:15:13.2772 Info HttpServer: HTTP Response 200 to 10.8.0.6. Time: 465ms. http://192.168.1.177:8096/emby/Users/27f6a9dfc71f4fa48dbeb84cdb86acd4/Items/0fd1f31db42203a29ce843cdac19dcf2
2017-02-22 17:15:13.9176 Debug ProviderManager: Saving image to /volume1/data/emby/metadata/People/A/Annie Wersching/poster.jpg
2017-02-22 17:15:13.9560 Debug App: Saving /volume1/data/emby/metadata/People/A/Annie Wersching to database.
2017-02-22 17:16:18.0185 Info HttpServer: HTTP GET http://192.168.1.177:8096/emby/Users/27f6a9dfc71f4fa48dbeb84cdb86acd4/Items/a7d2bd48d085ed3900c5c4d3e8b1de02. UserAgent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36
2017-02-22 17:16:18.2635 Info HttpServer: HTTP GET http://192.168.1.177:8096/emby/Items/a7d2bd48d085ed3900c5c4d3e8b1de02/ThemeMedia?userId=27f6a9dfc71f4fa48dbeb84cdb86acd4&InheritFromParent=true. UserAgent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36
2017-02-22 17:16:18.9398 Info HttpServer: HTTP Response 200 to 10.8.0.6. Time: 676ms. http://192.168.1.177:8096/emby/Items/a7d2bd48d085ed3900c5c4d3e8b1de02/ThemeMedia?userId=27f6a9dfc71f4fa48dbeb84cdb86acd4&InheritFromParent=true
2017-02-22 17:21:01.0374 Debug SqliteItemRepository: GetItemList query time (slow): 346084ms. Query: select type,data,StartDate,EndDate,ChannelId,IsMovie,IsSports,IsKids,IsSeries,IsLive,IsNews,IsPremiere,EpisodeTitle,IsRepeat,CommunityRating,CustomRating,IndexNumber,IsLocked,PreferredMetadataLanguage,PreferredMetadataCountryCode,IsHD,ExternalEtag,DateLastRefreshed,Name,Path,PremiereDate,Overview,ParentIndexNumber,ProductionYear,OfficialRating,OfficialRatingDescription,HomePageUrl,DisplayMediaType,ForcedSortName,RunTimeTicks,VoteCount,DateCreated,DateModified,guid,Genres,ParentId,Audio,ExternalServiceId,IsInMixedFolder,DateLastSaved,LockedFields,Studios,Tags,SourceType,TrailerTypes,OriginalTitle,PrimaryVersionId,DateLastMediaAdded,Album,CriticRating,CriticRatingSummary,IsVirtualItem,SeriesName,SeasonName,SeasonId,SeriesId,SeriesSortName,PresentationUniqueKey,InheritedParentalRatingValue,InheritedTags,ExternalSeriesId,Tagline,Keywords,ProviderIds,Images,ProductionLocations,ThemeSongIds,ThemeVideoIds,TotalBitrate,ExtraType,Artists,AlbumArtists,ExternalId,SeriesPresentationUniqueKey from TypedBaseItems A where ((select Name from TypedBaseItems where guid=@PersonId0) in (select Name from People where ItemId=Guid))
2017-02-22 17:21:02.2678 Info HttpServer: HTTP Response 200 to 10.8.0.6. Time: 284249ms. http://192.168.1.177:8096/emby/Users/27f6a9dfc71f4fa48dbeb84cdb86acd4/Items/a7d2bd48d085ed3900c5c4d3e8b1de02
2017-02-22 17:21:02.2841 Info HttpServer: HTTP GET http://192.168.1.177:8096/emby/Users/27f6a9dfc71f4fa48dbeb84cdb86acd4. UserAgent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36
2017-02-22 17:21:02.5190 Info HttpServer: HTTP Response 200 to 10.8.0.6. Time: 235ms. http://192.168.1.177:8096/emby/Users/27f6a9dfc71f4fa48dbeb84cdb86acd4
2017-02-22 17:21:02.5383 Info HttpServer: HTTP GET http://192.168.1.177:8096/emby/Shows/6e8740913fd5dfe2739abd49e107ec14/Episodes?seasonId=a7d2bd48d085ed3900c5c4d3e8b1de02&userId=27f6a9dfc71f4fa48dbeb84cdb86acd4&Fields=ItemCounts%2CPrimaryImageAspectRatio%2CBasicSyncInfo%2CCanDelete. UserAgent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36
2017-02-22 17:21:02.5517 Info HttpServer: HTTP GET http://192.168.1.177:8096/emby/Items/a7d2bd48d085ed3900c5c4d3e8b1de02/ThemeMedia?userId=27f6a9dfc71f4fa48dbeb84cdb86acd4&InheritFromParent=true. UserAgent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36
2017-02-22 17:21:02.5556 Info HttpServer: HTTP Response 200 to 10.8.0.6. Time: 4ms. http://192.168.1.177:8096/emby/Items/a7d2bd48d085ed3900c5c4d3e8b1de02/ThemeMedia?userId=27f6a9dfc71f4fa48dbeb84cdb86acd4&InheritFromParent=true
2017-02-22 17:21:02.7663 Info HttpServer: HTTP Response 200 to 10.8.0.6. Time: 228ms. http://192.168.1.177:8096/emby/Shows/6e8740913fd5dfe2739abd49e107ec14/Episodes?seasonId=a7d2bd48d085ed3900c5c4d3e8b1de02&userId=27f6a9dfc71f4fa48dbeb84cdb86acd4&Fields=ItemCounts%2CPrimaryImageAspectRatio%2CBasicSyncInfo%2CCanDelete
2017-02-22 17:21:04.9677 Info HttpServer: HTTP Response 200 to 10.8.0.6. Time: 352704ms. http://192.168.1.177:8096/emby/Items/22f078298ef34cf1295bb4a79e40e33e/Images/Primary?maxWidth=160&tag=06f9e44ead5e81a2fddad394afbff00b&quality=90

He cogido la bbdd del servidor (library.db - 80Mb), me la he llevado a un pc (windows) y responde correctamente a las consultas que pruebo con un visualizador de sqlite3. ¿puede ser un problema de rendimiento del NAS?

 

server-63623379222.txt

Link to post
Share on other sites

Me contesto a mi mismo... Al margen de que he apagado por completo el NAS (cosa que no había hecho antes), le he cambiado la placa de memoria RAM para aumentarlo a 4GB (que sólo tenía 1GB) y por el momento va todo fenomenal, la misma búsqueda de antes, ahora tarda 130ms. y la descarga de las fotos de los actores, al momento. Seguiré probando, espero que se mantenga así.

Muchas gracias Luke por tu atención.

Link to post
Share on other sites
  • 1 month later...
cajacontrol

Hola, tanto emby como plex van fatal en las cajas de nas de synology, yo tuve varios nas de synology, despues de batallar mucho decidi pasarme a una pc dedicada para emby, usando un core i7 , 64 de ram , una tarjeta nvidia y 5 discos de dos teras. Desde este punto soy feliz, todo va super rapido, pudiendo hasta 20 personas usar al tiempo el emby con velocidades increibles , reproduccion a 1080p y trascodifi acion superfast.

 

El problema de los nas es que no estan hechos para transcodificar a menos que el procesador sea un corei7 y la ram se queda corta y cuando ya tres o cuatro personas van al mismo tiempo comienzan los problemas de frizeo.

Link to post
Share on other sites
  • 2 years later...
hermanseverino

hola como esta adminitrador de emby, Tengo fire stick tv pero cuando entro bien pero cuando intento mover de un lado a otro una pelicula se mueve lento y nunca puedo selecionar el centro de la pelicula para reproducirla entoce como ago por favor 

Link to post
Share on other sites
hermanseverino

hola como esta adminitrador de emby, Tengo fire stick tv pero cuando entro bien pero cuando intento mover de un lado a otro una pelicula se mueve lento y nunca puedo selecionar el centro de la pelicula para reproducirla entoce como ago por favor 

Link to post
Share on other sites
hermanseverino

hola como esta adminitrador de emby, Tengo fire stick tv pero cuando entro bien pero cuando intento mover de un lado a otro una pelicula se mueve lento y nunca puedo selecionar el centro de la pelicula para reproducirla entoce como ago por favor 

Link to post
Share on other sites

hola como esta adminitrador de emby, Tengo fire stick tv pero cuando entro bien pero cuando intento mover de un lado a otro una pelicula se mueve lento y nunca puedo selecionar el centro de la pelicula para reproducirla entoce como ago por favor 

 

Hi, are you saying you can't fast forward?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...