Jump to content

Emby for Kodi 18 not working


jemus
 Share

Recommended Posts

Hey,

 

I'm using an alpha build of Kodi 18 because it's possible to use amazon video with it.

 

Just recently I switched from the PlexMediaServer to Emby Media Server.

 

Unfortunately I can't use Emby for Kodi in Kodi 18.

Whenever I enable the Emby Addon in Kodi 18 it says:

 

"Emby for Kodi

 

Cancelling the database syncing process. The current Kodi version is unsupported."

 

So I wanted to ask, if the addon will be usable on Kodi 18 builds soon?

 

If this has already been asked and answered, I'm sorry, but I didn't find anything concerning this issue via Google.

 

 

Link to comment
Share on other sites

We get this question very often regarding version compatibility.

 

The answer is quite simple, we do not officially support versions that are not stable. So no there are no plans to start supporting kodi 18 until it becomes a stable release.

  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...

Hi, I just posted the same thing, because I did not read this post before, sorry.

 

I take it and leave the question: is the 17-Krypton version stable, so is it compatible?

Edited by CarlosLima
Link to comment
Share on other sites

Yes, Kodi 17 is released and is therefore supported.

 

Thanks so much

Link to comment
Share on other sites

  • 1 month later...

Ok we can understand no "official support" for an alpha build but I'm guessing you are going to have to fix this sooner or later so why not answer the question they are really asking....

Have you started working on a fix yet?

Are you saying that your alpha/beta testing won't even begin until after kodi release a stable public version.

You old beta was fine in kodi 17 alphas and betas that i tried (yes i appreciate that libraries seem to be changing in v18)

 

Do we need to switch to plex?

 

People want a better answer than "not officially supported"

 

I don't officially support 8 pints of beer but when i have drunk 8 pints of beer in the past i didn't stop existing or restore myself from a backup to an earlier state no I just stagerd around trying to find my shoes, eventually I got where I was going.

 

If you're not fixing this we understand...

It's OK....

It sounds like you are not...

I suspect you are however.

 

The people would like to know how you are getting on with it (not even a time scale)(just yer we're on the case or yer naa mate can't be f×(# with that just yet cos it could all change tomorrow)

 

Anyone think I'm trolling or putting pressure on them needs to understand that kodi could be completely different by the time it leaves alpha stages and a fix now in no way means it'll work with the finished product or even alpha 2.

 

We really are trying to understand but a slightly longer answer would be great.

Link to comment
Share on other sites

Apart from the library not updating emby seems to work 100% the library is all their and it all plays.

 

I'd even except a buggy emby sync alpha.

 

It's literally the only thing making kodi 18 not working for me.

 

(You don't see that very often in an early alpha)(for me it's more stable than 17.1)

Link to comment
Share on other sites

If you want to watch development, read Github commits.

 

If they aren't fast enough for you, do them yourself.

  • Like 1
Link to comment
Share on other sites

I think what xnappo is trying to say is that we'll take a look at it once it hits RC stage. Any earlier and things are just moving too quickly for us to react. You'd be surprised how many alpha issues resolve themselves just by updating to the next alpha build. We see this all the time with alpha or dev versions of web browsers and the web app. If we were to commit to supporting them we'd never be able to get anything else done.

 

Let us know if this answers your question. Thanks !

Link to comment
Share on other sites

But don't expect Kodi 18 support for quite some time - we are not going to chase their DB changes (and neither is the PlexKodiConnect dude)

Edited by xnappo
Link to comment
Share on other sites

And the picture is a whole lot clearer.

 

Anyone looking for a bodge to keep their Android device plodding on until it's fixed???

 

Its a bit of a pain...

 

Install a kodi fork (spmc or something) and set up emby and just copy from your forks libary address to mnt/Android/Data/org.xbmc.kodi/files/userdata/library (that path is off the top of my head so might not be %100 but most people get what I'm saying)

 

Just do that every time you want to sync the library.

Link to comment
Share on other sites

Xnappo i wouldn't have a clue mate.

 

I'd like a fix asap but....

i can not control the tide nor the rain and have only a jacket to defend myself.

 

My library is up to date for now so it's all good.

Link to comment
Share on other sites

Do not use alpha software, it is as simple as that.  Why do you need Kodi 18?  Hell I am still running 15.2 on one box.

Link to comment
Share on other sites

Well I need Kodi 18 because it enables me to use Amazon Video in Kodi, as I wrote in the first post ;)

 

Cool Amazon video working again...is that Amazon UK? Any chance it is able to stream at 4k yet?

 

By the way no one will support kodi 18....we have been through at least 3 iterations of this and it is a PITA to try and keep up with the Kodi team. Also as mentioned above, contributors are always welcome as the Kodi part of Emby is nothing to do with the official Emby team and any support is done purely on a voluntary basis (ie uses too much of our free time!) 

 

Cheers

Link to comment
Share on other sites

Well I am not that much into the development as I don't understand anything about coding.

But from what I read it isn't the usual hack as before and also plays the videos that are protected by the new amazon DRM.

 

Netflix support is also in development but the major new developments are now only availiable in kodi agile branch.

 

It is all from a german board but if anyone of you is interested:

 

https://www.kodinerds.net/index.php/Thread/55612-Wir-suchen-Beta-Tester-f%C3%BCr-Netflix/

https://www.kodinerds.net/index.php/Thread/44211-Release-Amazon-Prime-Instant-Video/?pageNo=1

https://www.kodinerds.net/index.php/Thread/50878-inputstream-Amazon-Prime-Skygo-f%C3%BCr-ANDROID/

Link to comment
Share on other sites

Thanks I have seen those links before and tried it out a few months back with semi success....when it worked it looked very good.  Was not aware it had improved with Kodi 18 so will revisit :)

Link to comment
Share on other sites

Well these agile builds are the only ones that really work on different platforms if I am not mistaken here.

I use an older 18 alpha build on my nvidia shield which the deveolopers from the kodinerds board provided I guess in december or january.

 

So on Android it still works perfect for me. Just some videos with DRM only play stereo audio instead of DD+ 5.1. But so far it works and I am excited to see and test what they are working on since.

 

And one day it will hopefully be possible to use Amazon IV, Netflix, maybe SkyGo and of course Emby on one kodi installation ;)

Link to comment
Share on other sites

Well I am not that much into the development as I don't understand anything about coding.

Hi @@jemus I am also not a coder, but it was really easy for me to integrate emby into kodi krypton when it was in alpha stage by the method mentioned by xnappo:

 

At the moment I use stable krypton only. So I don't know if it really works with Leia. Just try it out! ;)

 

Greetings Hoppel

Edited by hoppel118
Link to comment
Share on other sites

Yes, it ain't rocket science to force it to try to use the new DB version.  If it doesn't work, that is another story.

  • Like 1
Link to comment
Share on other sites

Yeah thanks for providing that link. I'll give it a try ;)

 

 

Edit:

So I gave it a try but I can't find:

 

-the expression "def getKodiVideoDBPath" in the file addons/plugin.video.emby/resources/lib/utils.py

-the file kodidb_functions.py at all

-the expression "kodiversion" in the file addons/plugin.video.emby/resources/lib/itemtypes.py

-the expression "# Process the album info" in the file addons/plugin.video.emby/resources/lib/itemtypes.py

 

Tried it first on my Android Smartphone and than on my PC running Kodi 17.0 RC3.

On the PC emby runs without problems, I just searched for the mentiones files and expressions there as well because I couldn't find them on my phone at first.

 

 

As you said in the other post, we shouldn't ask you for support and you really don't have to give me any help, I will just wait for everything being stable. Just wanted to tell, that I tried to solve it but failed ;)

Edited by jemus
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...