Jump to content

Emby DVR (premiere) - no playback


goku2k

Recommended Posts

Server = linux debian install

Client = Win 10 theater app

 

I can schedule recordings, and I see .ts files created, but playback only results in a cover-art displaying and no sound. Live TV works and can play, pause, rewind and fast forward. Recording shows do not show in the "recorded" category until after they are complete. Once completed, they display in the recorded category, and they can be selected to play - however at that point, only the coverart shows up on the screen and there is no sound.

Edited by goku2k
Link to post
Share on other sites

Server = linux debian install

Client = Win 10 theater app

 

I can schedule recordings, and I see .ts files created, but playback only results in a cover-art displaying and no sound. Live TV works and can play, pause, rewind and fast forward. Recording shows do not show in the "recorded" category until after they are complete. Once completed, they display in the recorded category, and they can be selected to play - however at that point, only the coverart shows up on the screen and there is no sound.

 

 

What version of ffmpeg is running on the server?  Could be a transcode issue.

 

Krs

 

Mark

ffmpeg version 3.2.2-1~bpo8+1 Copyright © 2000-2016 the FFmpeg developers
  built with gcc 4.9.2 (Debian 4.9.2-10)
 
I enabled debug logs and attached the most recent sever and ffmpeg logs as logs.zip

logs.zip

Link to post
Share on other sites

Hi @@goku2k, there is a regression in ffmpeg 3.2 that is affecting us here and causing the playback failure. We have submitted a patch to ffmpeg to resolve the issue and they accepted it and merged it in. 

 

What I would suggest doing is downloading the latest git build from here:

 

https://www.johnvansickle.com/ffmpeg/

 

then replacing ffmpeg and ffprobe at

/usr/bin/ffmpeg
/usr/bin/ffprobe

You will probably need to mark the new files as executable so that Emby Server will have permission to execute them. Thanks !

Link to post
Share on other sites
  • 1 month later...

Upgraded ffmpeg version, but still experiencing same issue. The latest debian version is the same version as on https://www.johnvansickle.com/ffmpeg/ (latest release on that site is release: 3.2.4, debian version is 3.2.4-1)

 

root@HP-OMV:~# ffmpeg
ffmpeg version 3.2.4-1~bpo8+1 Copyright © 2000-2017 the FFmpeg developers
  built with gcc 4.9.2 (Debian 4.9.2-10)
 
 
Something I noticed in both the old and new logs was:
017-03-08 06:58:19.0591 Error HttpClient: Error getting response from http://192.168.1.1:5000
 
Why would the server attempt to pull something from that address? (It happens to be the default gateway for the server and the router and dhcp server address)
Link to post
Share on other sites
mastrmind11

 

 

Something I noticed in both the old and new logs was:
017-03-08 06:58:19.0591 Error HttpClient: Error getting response from http://192.168.1.1:5000
 
Why would the server attempt to pull something from that address? (It happens to be the default gateway for the server and the router and dhcp server address)

 

Disable automatic port mapping on the server and that error will go away.

Link to post
Share on other sites

Disable automatic port mapping on the server and that error will go away.

Thanks - latest set of logs no longer have that specific error.

 

However, I am still experiencing issues with playback of recorded files. Live TV works, but playback of recorded files still results in a blank/black screen.

 

Fresh logs attached.

emby logs.zip

Edited by goku2k
Link to post
Share on other sites

Hi Luke,

 

This appears to work via web access - it's theater that is not playing the file. I've made sure I'm running the latest theater release from the store, and still no luck.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...