Jump to content
Luke

Emby Theater on Raspberry Pi

Recommended Posts

mbc0

Hi,

 

Is there a way for me to get ET to auto-log off a user with inactivity?

 

I have tried the Emby Openelec image and there are no options so I scrapped that and I currently have ET installed on my Pi 4 with Debian Buster trying to get the Pi to log off or shutdown/anything to force ET to logout the last users so my kids only get to see what they are allowed.

 

Many Thanks

Share this post


Link to post
Share on other sites
Luke

Hi,

 

Is there a way for me to get ET to auto-log off a user with inactivity?

 

I have tried the Emby Openelec image and there are no options so I scrapped that and I currently have ET installed on my Pi 4 with Debian Buster trying to get the Pi to log off or shutdown/anything to force ET to logout the last users so my kids only get to see what they are allowed.

 

Many Thanks

No but it's planned for the future. Thanks.

Share this post


Link to post
Share on other sites
nonyhaha

Hello,

I am having some issues with ET on Raspberry and I was wondering if these are known issues or if there is something I should do to them.

I have a pi3 and a pi4. Both run latest 3.0.9 image that i simply copied on the sd cards. After install I only changed hostname, enabled ssh, setup wifi and told them to wait for network before initialization.

The problems I run into are:

1. sometimes when I want to access the menu during playtime, I push center button but the image goes black and the raspberry freezes. the usual pause, previous, next and other buttons do not appear, just a black screen and I can't do anything. no back, no continue, nothing.

This can be reproduces by just pressing stop button on my remote. black screen on, nothing i can do. 
and
2. Whenever I enable subtitles, the video also freezes, usually with a black screen, and I can't do anything again. The only way out is to restart. on my android app, subtitles work fine. - tried with local and online subtitles. - This issue seems to happen when enabling subtitles on raspberry pi 4 while direct playing files.

These issues happen both on pi3 and pi4. (both are playing on local netowrk, pi4 uses direct streaming, pi3 uses 720p transcoding)

Any ideas what I should try to do?

Many thanks in advance.

L.E.
Unfortunately the black screen comes on after some inactivity time and i cant do anything to bring it back.

This is stressing me a lot. I have to restart it every time :(

Edited by nonyhaha

Share this post


Link to post
Share on other sites
nt-it-team

Hello,

 

Using the RPi image from the Linux thread, is it possible to join the Pi 4b to a WPA Enterprise (RADIUS) wifi connection?

 

Tested on ethernet and works great!

Share this post


Link to post
Share on other sites
Luke

Hi, I don't see why not. Have you checked system network settings?

Share this post


Link to post
Share on other sites
nt-it-team

I have escaped away from the auto-starting Emby client and signed in with the default Pi credentials... I don't see any network settings to configure! It looks like the OS is really lightweight.

Share this post


Link to post
Share on other sites
Luke

I have escaped away from the auto-starting Emby client and signed in with the default Pi credentials... I don't see any network settings to configure! It looks like the OS is really lightweight.

The desktop is lxde, so raspi-config should take care of the basics but installing network manager 'sudo apt-get install network-manager' should add extra functions

Share this post


Link to post
Share on other sites
nt-it-team

Well - finally got this working. To put it short, the driver in the Buster distro by default is broken and does not work with any 802.1x implementation. Only fix is to "swap" the driver being loaded.

 

For future anyone trying this:

 

Check first in terminal:

ps aux | grep wpa

The default (broken) return should contain:

wpa_supplicant -B -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dnl80211,wext

We need to change this around...

 

In terminal:

sudo nano /etc/wpa_supplicant/functions.sh

go to line 227 (as of the date on this post anyway). Change from

WPA_SUP_OPTIONS="$WPA_SUP_OPTIONS -D nl80211,wext"

to

WPA_SUP_OPTIONS="$WPA_SUP_OPTIONS -D wext,nl80211"

Save the file (write output) and exit. 

 

 

In terminal:

sudo nano /lib/dhcpcd/dhcpcd-hooks/10-wpa_supplicant

go to line 60 (again as of this post date). Change from:

wpa_supplicant_driver="${wpa_supplicant_driver:-nl80211,wext}"

to:

wpa_supplicant_driver="${wpa_supplicant_driver:-wext,nl80211}"

Now reboot the pi, in terminal:

sudo reboot

After it reboots, quit the emby auto launch and sign in to the desktop, and open terminal and run:

ps aux | grep wpa

it should now have the line:

wpa_supplicant -B -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -wext,Dnl80211

Now go ahead and configure the wpa_supplicant.conf file for your radius settings for WPA2 enterprise and it should connect. Not sure why this isn't documented anywhere, and I don't have accounts on other places to post it!

 

Hope this helps someone else using the emby pi image to connect!

 

Now to figure out how to stop the raspi-config loading by default, as it tests before the wifi connects...

Share this post


Link to post
Share on other sites
Luke

That's great info, thanks !

Share this post


Link to post
Share on other sites
Luke

Theater now has the virtual scrolling feature for vertical lists:

https://emby.media/community/index.php?/topic/82293-44012-virtual-scrolling/

 

That means the lists will no longer load your entire library contents all at once and will instead only load what you see at once. This will help make the entire app more responsive and improve navigation performance.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...