Jump to content
Marc_G

Kodi showing Emby Library movie content as music?

Recommended Posts

Marc_G

Hi all,

 

After starting this thread:

https://emby.media/community/index.php?/topic/42676-help-trouble-sorting-media-in-kodi-to-respect-emby-libraries/

 

I did research and was helped by wonderful folks in the community, and thought I had sort of figured out how to set up Kodi to show specific content from my libraries rather than lumping it all "Movie" type content together in annoying ways. I'm on Emby server 3.0.8500.0 (no, I haven't updated yet, and won't for a week or more until I know it's not likely to break anything... I'm cautions! ;)  ). My Kodi is the stable version (16.1 I think)

 

Short story: I made a test library with a couple movies in there, and made a link to it in Kodi, and it shows up, yea, but in multiple skins it shows up as music, and the movies aren't named correctly in Kodi, they show up as numbers (???).

 

 

Longer story:

 

For this test I created a new folder accessible to Emby. It happens to be on the E: drive of the Emby server, E:\TestShows\, and contains:

\Hollow Man\

\Close Encounters of the Third Kind\

 

I set this TestShows folder up as a library in Emby called MyTestShows (note distinction from filename, to enable me to trace what's going on). This content is set to type Movies and looks like this in the Emby library management screen:

585898b33b46f_MyTestShows.jpg

 

I opened Kodi, and having figured out the default Confluence skin doesn't support edits to the main items, I chose Titan skin, and went in and configured a new home menu item. As I recall I configured the item to go to: \Add ons\Video Add ons\Emby\MyTestShows\ and then confirmed the main MyTestShows in the selector box that followed. I then backed out to the home screen. My Test Shows was there, and when I went into it, it had just the two movies, but they were called 49 and 50. ??? And they showed as type Music. I repeated the test in Aeon Nox (same results).

 

58589abe21dd7_4950.jpg

 

58589af508021_MusicWTF.jpg

 

 

 

I'm very confused. What am I doing wrong? Why is it not displaying the content name (movie name in the row instead of 49 or 50), and why does it think it is music?

 

THANKS FOLKS

 

Marc

Share this post


Link to post
Share on other sites
Angelblue05

Check your action shortcut. Make sure it says ActivateWindow(10025,...) Not 10502.

 

Edit: Or alternatively... ActivateWindow(Videos,...), not Music.

Edited by Angelblue05
  • Like 1

Share this post


Link to post
Share on other sites
Marc_G

Aha!

 

Indeed it shows Music there.

58591a3e00278_music.jpg

 

This may sound silly... but how do I edit this? I tried lots of clicks, right clicks etc.. without finding the secret sauce that would let me go in and edit the text on this line. Clicking tends to bring up directory selector boxes and the like.

 

Thanks. I think I'm ALMOST getting the hang of this!

 

Marc

Share this post


Link to post
Share on other sites
Marc_G

Only had a little time to play tonight but definitely made a bit of progress. I dug through XML files until I found the one that mattered in this case. For the Aeon Nox skin test it was:

 

C:\Users\[ME]\AppData\Roaming\Kodi\userdata\addon_data\skin.aeon.nox.5\settings.xml

 

(yes, this is probably obvious to folks that mess with Kodi but hey I'm a Kodi noob)

 

In that XML I searched for the string shown above that includes ActivateWindow(Music and replaced with ActivateWindow(Videos...

 

After doing that and opening Kodi, I was rewarded with the filenames of the content as anticipated.

 

5859f6db74e55_Videoshooray.jpg

 

Will play more, later this week. Not sure this particular skin is the one I want, but need to spend more time poking around.

 

Has anyone created an "Emby Theater" Skin?

 

In fact I'll post a new thread to that effect... :-)

 

Thanks for help so far.

Share this post


Link to post
Share on other sites
Marc_G

Interestingly in the Titan settings.xml, I wasn't able to find the similar "music" string to change to "videos" to fix the problem in that skin. Maybe different settings format.

Share this post


Link to post
Share on other sites
im85288

I'm using a personal mod of the new estuary skin. Though I do plan to update it to the latest material design they added in the version 2 of the estuary skin.

  • Like 1

Share this post


Link to post
Share on other sites
Marc_G

@@badaas and myself created a skin that is similar ish to Emby theatre: http://forum.kodi.tv/forumdisplay.php?fid=248

However we no longer maintain it, you may like it though.

Hi @@im85288,

 

I noticed in the Eunique skin that the cursor doesn't show... makes it a bit hard for me to navigate. Is there a setting somewhere to show it? 

Share this post


Link to post
Share on other sites
xnappo

Kodi interfaces are designed to be used with a remote in general.

Share this post


Link to post
Share on other sites
Guardian Hope

Kodi interfaces are designed to be used with a remote in general.

 

Indeed. I am trying to think of a skin that exposes the cursor and the only ones I can think of are Kodi's defaults.

Share this post


Link to post
Share on other sites
CBers

Short story: I made a test library with a couple movies in there, and made a link to it in Kodi, and it shows up, yea, but in multiple skins it shows up as music, and the movies aren't named correctly in Kodi, they show up as numbers (???).

 

Looks like I've posted the same here: https://emby.media/community/index.php?/topic/42942-bug-movies-showing-as-numbers-in-ral/

 

I did find a work around though, by using the Smart Shortcuts in the Titan skin, instead of the Emby addon shortcut.

 

All Movie names now show correctly.

 

I'm running the Krypton beta and Titan Beta for Krypton.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...