Jump to content

movie titles showing up in the wrong place.


Tolbarus
 Share

Go to solution Solved by Angelblue05,

Recommended Posts

Hello,

 

It may have been reported somewhere else in this forum but i am having difficulty describing the problem accurately.

so i cannot find what i want using tags.

my problem is the following:

 

i am using emby server in combination with kodi for my htpc setup with The titan beta skin.

and i am very happy with how this works in general.

 

i have made my own folder structure where i stroe my movies according to genre. i have made all different entries for the seperate folders in emby library and use smart shortcuts in the titan skin in kodi to acces these "folders"through a submenu under movies in Kodi.

this works beautifully except for the one exception and that is that the movie tron legacy shows up in the the sub category thrillers? even if it is actually located in the folder sci fi. when i aproach the library entry sci fi trhough emby it does show up in the correct place. i have tried various things to remedy this problem but so far have not been able to.

i have deleted and reloaded the movie from the folder scanned the libray again and repaired nodes in kodi etc.

 

this problem has been going on for a while now and its a minor anoyance so i have not reported it before but does anybody have an idea?

 

Link to comment
Share on other sites

Angelblue05

What do you see as Genre tags in the emby metadata manager for the movie (genres will be located near the bottom of the list of fields). This is what would effect where the movie appears under Genres in Kodi. You can adjust or remove the unwanted tag and hit save. That should update the title in Kodi and fix the issue. Let me know.

 

Otherwise, maybe provide some screenshots to clarify what you are saying. Thanks

Edited by Angelblue05
Link to comment
Share on other sites

Hello Angelblue05,

 

thank you for the quick reply.

 

sorry print screen of my kodi is a bit difficult as I cannot seem to get it to work with my media keyboard.

 

I am not using genre tags to sort in kodi i am just using the smart short cuts to my emby library folders to sort the movies.

emby folders screenshot is below. when accesing the folder through the emby app all is in the correct place.

bassically my movies sub page in kodi looks exactly the same as the below picture with a tile for every smart shortcut to a folder.

 

but for some reason( in kodi only) the movies switch folders sometimes. ( so i click on the thriller tile and all the movies in the thriller folder are shown plus  "tron legacy" which is placed in the sci fi folder "tron legacy "is also shown under the sci fi tile. so it is shown in two locations even though it is only present in one

This does not seem random ( its among others always "tron legacy") which gives me hope that it can be solved

 

57d481e8c96ed_printscreenembyfolders.jpg

  • Like 1
Link to comment
Share on other sites

Angelblue05

Ok, yeah that's weird. Especially if the movie only exists once in your Emby library. Can you do the following test and provide your Kodi log: In the add-on settings > advanced tab > change the log level to Debug. Then in your Emby metadata manager, just hit save on Tron Legacy to refresh the movie in Kodi. Wait a few moments and post your Kodi the log, thanks. You can then change the log level back to info.

Edited by Angelblue05
Link to comment
Share on other sites

@@Angelblue05

 

I saw, in another post, about library items appearing in the wrong section in Kodi, where you asked the reporter to go to the item in the web client's Meta Data Manager and click Save and then provide feedback.

 

I tried it, and found that, for each show that I saved, in the web client, the item updates in Kodi and moves to the correct section. For example, Witnesses was in the Docu Series section (library) in Kodi. It should be in TV Series. I find it in TV Series in the Web Client (It is in the right library), I press save, it moves to the TV Series section in Kodi and disappears from Docu Series. I did this for a number of shows, and in each case the show moves to the correct section.

 

This feels like the problem lies in the procedures for Manual Sync and Initial Sync. I assume that the Initial and Manual Sync are obtaining their update data via a mechanism that is different to that of individual Save in the Meta Data Manager.

 

Hope this helps.

 

Cheers,

LongMan

Link to comment
Share on other sites

Angelblue05

Without a log, no it doesn't help much unfortunately.

 

I can't reproduce this issue. Best thing to do is provide that initial sync log (mostly interested in the media folders line vs the test I asked in that other post.

 

The initial sync - We pull the list of views from the server, then process each view by grabbing all the content that belongs to it from server. We use the view Id and ask the server to return all items that belong. So how could it get the wrong view name. Unless you are telling me that it's associated to the name that is not even a view name on the webclient? To me, it seems like an api bug/server otherwise, everyone would have that problem using the add-on, which is not the case.

 

After the initial sync, you say it fixes the issue but we pull the view name via the ancestor api entrypoint on individual items. Which returns everything thats at higher level it belongs to.

Edited by Angelblue05
Link to comment
Share on other sites

I will grab an initial sync log.

 

This is the thread of which I spoke.

http://emby.media/community/index.php?/topic/38951-movie-titles-showing-up-in-the-wrong-place/

 

The reporter is having a similar problem even though it  is not described in the same way. His movies are showing up in the wrong place because of the tags. If you do not reset your database, you won't have the problem. It occurs with the initial sync and is not corrected by a manual sync. Saving the individual item in the Metadata Manager, however, corrects it for that item.

 

I will post the log as soon as I can

 

Cheers,

LongMan

Link to comment
Share on other sites

Angelblue05

Yes, I knew which thread you are referring to.

 

A manual sync only compares, so it wouldn't correct the issue because it doesn't force update all content, just what is found to be different. Even a repair sync would not correct the issue, it would revert back the tags, because it's running the initial sync and forcing to repair all entries.

 

Sure, I'll wait for your log, thanks. I still don't believe it to be an emby for kodi issue directly. It would not make any sense.

Edited by Angelblue05
Link to comment
Share on other sites

10:10:32 T:140615618656000  NOTICE: EMBY.librarysync -> Media folders: [{'id': u'2f7492ad3fef37b855c9d5d8ad1d544d', 'name': u'Main Movies R'}, {'id': u'cfae3de418dd1304eba36c1162303261', 'name': u'Main Movies FF'}, {'id': u'26786edeb2432626b8fe1fd75aeda352', 'name': u'Docu Movies'}, {'id': u'7420614390edd3b1d53096584a86cf7d', 'name': u'Concerts'}, {'id': u'57703e1cea529d7d07ec197b8fb217ef', 'name': u'Kids Movies'}, {'id': u'b72567ec939c3cfa777b28f6a2dab380', 'name': u'Main Movies'}]
10:10:32 T:140615618656000  NOTICE: EMBY.librarysync -> Movies to update for Main Movies R: []
10:10:47 T:140615618656000  NOTICE: EMBY.librarysync -> Movies to update for Main Movies FF: [u'749543fed98f767a84db087ea6a1a327']
10:10:47 T:140615618656000  NOTICE: EMBY.itemtypes -> movieid: 2061 fileid: 25011 pathid: 1
10:10:47 T:140615618656000  NOTICE: EMBY.itemtypes -> UPDATE movie itemid: 749543fed98f767a84db087ea6a1a327 - Title: Gods of Egypt

 

Is this the section of which you speak?

  • Like 1
Link to comment
Share on other sites

Angelblue05

Yes, just let me know the tag assigned, and also capture in log the other test so I can compare the ancestor id, thanks. Enable emby for kodi debug (otherwise I won't see the full server response), hit save in the metadata manager and post that. Thanks

Edited by Angelblue05
Link to comment
Share on other sites

Angelblue05

thanks for the log @@LongMan - Unfortunately it's not enough information and I still can't see what the problem could be. I'll post a new beta tomorrow with increased logging. Can I trouble you with asking you to reset your local database and providing a new log (the movies section only) once you install the new beta version? 

 

It should be released in a few hours.

Edited by Angelblue05
Link to comment
Share on other sites

Angelblue05

Sorry, I ended up not releasing the new version today due to unexpected bug with another feature. I will let you know when I'll need you to test. Thanks again.

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

Hello,

 

sorry for the late reply i have been away for work for the week.

In my case pressing save in the webclient metadata manager does not move the items to the correct place.

( i am using media center master for my metadata don't know if that is related)

 

any way i can switch the logging to debug in the kodi addon and i can press save in the webclient what i cannot do/find however is where the ... i can open the log or how i can post it 

(in Kodi looking up event logs shows a empty list.)

 

Edit: found the explanation on how to upload logs will try next.

movie used to test is "dune" it shows up in war and should be in scifi

uploader said to post this so here it is:

 

https://paste.ubuntu.com/23186376/

 

hope this helps

Edited by Tolbarus
  • Like 1
Link to comment
Share on other sites

Angelblue05

@@Tolbarus

 

No problem. LongMan already provided a similar log to yours, so the issue really is during the initial sync. I've added extra logging in the latest beta version to try and pinpoint the source of the issue. The only test I need right now, is just for one of you to reset their local database and proceed to resync your content (log level set to info, no need for debug) and post the log which contains the movies being synced to Kodi.  Then we'll know if the issue is truly with the Emby add-on or some weird api bug that returns the wrong items under certain views.

Link to comment
Share on other sites

  • Solution
Angelblue05

@@Tolbarus

 

Ok I checked Tron legacy

10:58:33 T:828 NOTICE: EMBY.itemtypes -> ADD movie itemid: b8cefad2f3cc3e8b9f2b50a3732b1b36 - Title: TRON: Legacy
10:58:33 T:828 NOTICE: EMBY.itemtypes -> Applied tags: [u'Sci-Fi', u'artificial intelligence', u'thriller', u'science fiction', u'alternative', u'3d']

You must have that tag assigned in the metadata manager, remove it and it will stop showing under thriller. Go to the metadata manager > select Tron legacy > Tags (near the bottom) > remove the tag and save. Same thing must be happening to other titles too. The way we split your library in Kodi is using tags. We use the name of your library as tag, and since you have names that are "common" you will need to fix those entries in the metadata manager. The change should be reflected instantly.

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites

@@Angelblue05,

 

That did the trick thanx for the help, it is still a bit strange to me though that there are two ways to sort the titles working together/against each other, would it be an option to completely shut of the tagging sorting so you can control it by yourself?.

 

Edit: Sorry  I re-read the previous post and bassically there is just one way to sort the tiltes and it is my common name use that is creating the issues with my folder names being the same as tags used in the metadata.

 

thanx again for the assistance,

 

Regards Tolbarus.

Edited by Tolbarus
  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...