Jump to content


Photo

Networking-Remote Access/Ubuntu/ATT Uverse

Networking ubuntu Remote Access Port Forwarding Cant Connect Multiple Routers

  • Please log in to reply
2 replies to this topic

#1 frostgiant OFFLINE  

frostgiant

    Newbie

  • Members
  • 1 posts
  • Local time: 10:18 AM

Posted 22 August 2016 - 09:05 PM

I currently have Emby Server running on Ubuntu Server 16.04.  The main problem is that i am able to access the Emby sever on my LAN yet when I attempt to connect to the server for outside of the LAN I get the error "We're unable to connect to the selected server right now.  Please ensure it is running and try again".  I have read the Wiki of networking and have configured everything as suggested.  

 

I have already told my router to port forward port 8096, I have opened the port already through Ubuntu, and I currently have a static IP address for my server.  Yet this error continues to show for all devices (Iphone, Laptop, Android) that have attempted to connect from outside of the network.

 

Where I am having trouble with trouble shooting my problem is with how my home network is set-up.  I currently have ATT Uverse which forces me to use their router, a Motorola 5268AC, which is a very poor device, so I ended up shutting down the wireless features of this modem/router to behave as a modem only, then routed my personal router to modem.   When attempting to set up port forwarding on the Motorola device I have to write a new rule which allows me to select the port ranges which I set to 8096 , then application type with the choices of: FTP, DirectX Game, IRC, PPTP, SIP, or H.323.  So my question would be what setting would describe Emby server best.  Also there is a list of pre-created rules on the Modem yet none of these allow for the port number of 8096.  

 

I know this seems more like an ATT question, I have already contacted them multiple times and none of the Techs could help me with this set-up due to their lack of knowledge of Emby itself.

 

Thanks in advance!



#2 plexman OFFLINE  

plexman

    Advanced Member

  • Members
  • 332 posts
  • Local time: 05:18 PM
  • LocationSpain

Posted 22 August 2016 - 09:09 PM

Does the ssh access from outside your lan work? Are you opening the correct protocol TCP or UDP. Try accessing other services to your server from outside your LAN (like FTP, http) to determine if the problem is on the server or it's the router.

Edited by plexman, 22 August 2016 - 09:10 PM.


#3 mastrmind11 OFFLINE  

mastrmind11

    Advanced Member

  • Members
  • 2769 posts
  • Local time: 11:18 AM
  • LocationLong Island, NY

Posted 23 August 2016 - 08:43 AM

Also, "application type" is likely just a preset that will automatically set the corresponding port for the application... iow, it's probably irrelevant what you pick there, just make sure the port is correct.  You also have to map the port to point to your internal LAN IP:port where the server is listening.  Try to pick a different port on the WAN end and pointing it to the correct port on your LAN to see whether it's a port issue (blocked by ATT for some reason).  

 

I had similar issues with Verizon, and ended up putting my personal router in the DMZ on a different subnet and pointing the crappy Verizon router to the DMZ, which allows ALL external traffic to pass through the Verizon router and my 2nd router does all the heavy lifting, which I'd think would be your preference too if the ATT router is junk.







Also tagged with one or more of these keywords: Networking, ubuntu, Remote Access, Port Forwarding, Cant Connect, Multiple Routers

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users