Jump to content

UWP Testers


Recommended Posts

7illusions

Could be just my system, but the images seem to be loading a lot slower with .45

 

No changes to imageloading what so ever, so hopefully your system otherwise server related, but should not be caused by the app.

  • Like 1
Link to post
Share on other sites
7illusions

Any way you could increase the font size a little for some of the text to the right of the movie posters? Maybe throw in some color to break it up some. For the older crowd it's kind of small and there seems to be a lot of room.

 

On another note the text is easier to find now with the background shadowed

 

Edit: even using Bold may help some

 

Right of the Poster on which view, Movie details or list views?

 

 

Background, have you tried out the Grayscale option yet? That really improves readability, but might be a bit dull if you're in to colors

Link to post
Share on other sites
FrostByte

Ya, text movie details.  I think it's mainly the size of the fonts for me.  I tried grayscale, but still a problem.   Changing the Windows font scaling didn't seem to have any effect within the app

Link to post
Share on other sites
FrostByte

Hi,

 

Both Album Artists and Artists seem to broken in 26 on the server side

 

Ya, I can load them in the webclient but I just get the twirling circle thingy in the app like it's taking forever to load.  I'm just letting it sit now seeing if it ever comes back

Link to post
Share on other sites
7illusions

@@Luke what's changed here? Do I need to release a hotfix for the current app, or is it a server error?

Link to post
Share on other sites
Happy2Play

So is this something specific to the new UWP app? I have v3.4.6.367 with this issues as posted in other thread.

Link to post
Share on other sites

No it is broken in v3.4.6.367 I would not have posted in the server testing thread if it was just the alpha app.

Link to post
Share on other sites
Happy2Play

Then the question is why did the update work for me and Luke?  There has to be other variables.

 

Same versions

Link to post
Share on other sites
FrostByte

Album Artists doesn't work for me in either app (not sure if it ever did in uwp)  In the released app it crashes every time though now and I posted my logs. 

 

Edit: In the uwp app just keeps spinning and never stops

Edited by FrostByte
Link to post
Share on other sites

@@Happy2Play

 

How big is your music library? Your os WHS 2011, is different and I believe is based on a different core as well.

 

I looked at the .26 commits and the were a lot of changes to music queries, Luke has been updating the web ui in dev since. something has changed.

Edited by Vicpa
Link to post
Share on other sites

7 - what are the conditions the app is using to request records? What i'm seeing is that it's infinitely requesting 100 records at a time, going beyond the total record count. You might need to put the debugger on client-side and see what's going on. I've verified that the total record count on the result object is correct. I know the app uses some of the same endpoints as Dlna so I tested that as well.

Link to post
Share on other sites
Happy2Play

@@Happy2Play

 

How big is your music library? Your os WHS 2011, is different and I believe is based on a different core as well.

 

I looked at the .26 commits and the were a lot of changes to music queries, Luke has been updating the web ui in dev since. something has changed.

Just over 200 albums in that library.  Server .26 will be the same as if it is on Windows 7, 8, or 10 or WHS the core is the same that is why you can go portable if you want.

Link to post
Share on other sites
FrostByte

I have 4300+ albums if that makes a difference  :)    I had a few Windows updates on my server today also besides the new app and beta server releases.  May not be anything though

 

   Security Update for Adobe Flash Player for Windows 10 Version 1511 for x64-based Systems (KB3167685)

  Update for Windows 10 Version 1511 for x64-based Systems (KB3149135)

 Cumulative Update for Windows 10 Version 1511 for x64-based Systems (KB3163018)

​   Windows Malicious Software Removal Tool for Windows 8, 8.1, 10 and Windows Server 2012, 2012 R2 x64 Edition - June 2016 (KB890830)

Link to post
Share on other sites

It's due to a slight mismatch of total record count reported vs the actual number that gets sent back. I'm fixing this server-side but 7 I think it should be handled on both sides. In other words, if your StartIndex is 700 and TotalRecordCount is 780, and you request 100 more items, the app should know that it's the last page. Imagine for example the scenario of content getting deleted from the library while another user is scrolling through it from an app.

  • Like 2
Link to post
Share on other sites
FrostByte

It's due to a slight mismatch of total record count reported vs the actual number that gets sent back. I'm fixing this server-side but 7 I think it should be handled on both sides. In other words, if your StartIndex is 700 and TotalRecordCount is 780, and you request 100 more items, the app should know that it's the last page. Imagine for example the scenario of content getting deleted from the library while another user is scrolling through it from an app.

 

Just loaded .27 and the store app version .367 works again now.  Thanks

 

The UWP app still returns nothing, but that may be an UWP issue which 7 is working

Link to post
Share on other sites
7illusions

7 - what are the conditions the app is using to request records? What i'm seeing is that it's infinitely requesting 100 records at a time, going beyond the total record count. You might need to put the debugger on client-side and see what's going on. I've verified that the total record count on the result object is correct. I know the app uses some of the same endpoints as Dlna so I tested that as well.

 

Yes, I got this logic in place for all other items, but I obviously missed it for artists. It's fixed in next build. Thanks

  • Like 2
Link to post
Share on other sites
SilentAssassin

There's an issue with the sorting in the latest section of television. Mine is currently displaying one month ago first, then it's displaying Thursday, Wednesday  and Sunday and then more than a month ago.

Link to post
Share on other sites

Hi,

 

Yep, there are several sorting issues. Additionaly in music artists are displayed in decending sort order. Added to the list.

Link to post
Share on other sites

Hi 7, @@Luke

 

Thanks for sorting the artist issue in the production app.!!! There also appears to be a regression introduced in .26,.27 with genre's.

 

57652e9f6052c_Screenshot10.png

 

only 3 show up. in v3.4.6.367

 

Thanks

-vicpa

Link to post
Share on other sites

Hi All,

 

I really like the album detail page :)​ . I have all manner of potential feature requests.

But for now can you change the icon from the person to something else? Maybe a record symbol? It would be more intuitive. Wasn't sure at first if I was supposed to be on the artist page or a detail page.

 

Thanks!!

Link to post
Share on other sites
7illusions

Hi All,

 

I really like the album detail page :)​ . I have all manner of potential feature requests.

But for now can you change the icon from the person to something else? Maybe a record symbol? It would be more intuitive. Wasn't sure at first if I was supposed to be on the artist page or a detail page.

 

Thanks!!

 

Haha, yes I realized that last night playing around with the Xbox. It's supposed to be the artist page, buy I pass the albumId instead of artistid..

 

I'll add another button, a "i" I think, because the album detail is awesome but unintended and I'll fix the artistdetail thing. :)

Link to post
Share on other sites

Hi,

 

Even better :). Sometimes those unintended features, open up all manner of new ​possibilities.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...