Jump to content
Sign in to follow this  
booch

Can't direct play trailers with supported video and audio format

Recommended Posts

booch

Hi!

 

Today l bought an iOS app mostly due to trailers feature but I faced a problem - all my downloaded trailers plays with transcoding only due to missed "Direct" option in the settings while playing trailer (see attached screenshots)

 

I made simple experiment:

1. Saved movie with supported video and audio format, Emby server see it

2. On iPad I can select it, choose "Direct" option in playback settings and play it without transcoding

3. Create a copy of this file, add "-trailer" at the end of the name to make Emby treat it as movie trailer

4. On iPad's app "Trailer" button appears, I can play it but can't select "Direct" option for direct play :(

 

Is it possible to play offline trailers on iOS devices without transcoding?

Thanks in advance

post-132286-0-20644400-1462645776_thumb.png

post-132286-0-85213700-1462645798_thumb.jpeg

post-132286-0-76066300-1462645807_thumb.jpeg

Share this post


Link to post
Share on other sites
Luke

it should be the same either way. maybe it just hadn't finished scanning the media info yet.

Share this post


Link to post
Share on other sites
booch

I made library rescan several times, was waiting until the end and tried again with no success

Probably I found the cause in the log while playing trailer "Cannot direct play due to unknown content bitrate"

2016-05-07 23:03:42.6143 Info App: Profile: Unknown Profile, Path: \\192.168.0.101\nas\Video\Movies\2D\Captain America - Civil War (2016)\Captain America - Civil War (2016)-trailer.mp4, isEligibleForDirectPlay: False, isEligibleForDirectStream: False
2016-05-07 23:03:42.6143 Info App: Cannot direct play due to unknown content bitrate

In the Movie info I see that bitrate is "1386 kbps" (you can see it in my screenshot)

For the trailer it should be the same bitrate since it is just a copy of movie with added "-trailer" in the name.

 

Is it possible to see trailer's info in web UI or in the iOS app?

 

PS. I can provide this video file if you need it for investigation. It has just 18 MB in size

Edited by booch

Share this post


Link to post
Share on other sites
speechles

http://emby.media/community/index.php?/topic/34146-Did-channels-and-trailers-change?

 

This is the same thing I said before. Local trailers are NOT passing mediainfo. This is still a problem. There is no resolution. Trailers stored locally with your media (*-trailer.*) will NOT direct play. This is not the apps fault. When the server changed transcoding methods it broke local trailers.

 

Sent from my Nexus 7 using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites
Luke

Ok, yes, I can reproduce. Looking into it. If you want to try the beta server, I'll try to get this into a build for tomorrow. Thanks.

  • Like 1

Share this post


Link to post
Share on other sites
booch

Ok, yes, I can reproduce. Looking into it. If you want to try the beta server, I'll try to get this into a build for tomorrow. Thanks.

Thank you! Looking forward for the fix :)

 

BTW. Looks like Plex has same bug. Same file plays directly as movie but can't as trailer

Share this post


Link to post
Share on other sites
Luke

Just fyi, although i have it fixed, it will require refreshing affected titles from the detail screen, or a top level folder refresh from the metadata manager.

Share this post


Link to post
Share on other sites
booch

wow, fastest fix I've ever seen, thank you very much! 

when it will be available in public release?

Share this post


Link to post
Share on other sites
speechles

Just fyi, although i have it fixed, it will require refreshing affected titles from the detail screen, or a top level folder refresh from the metadata manager.

 

Sweet. Mainly because it broke that feature I added to the roku for library trailers. Also yeah, as the OP said, quick fix indeed.. Cracking toast, Gromit!!! Have you played around with the NameStartsWith/TvSeries issue?

Share this post


Link to post
Share on other sites
Happy2Play

Sweet. Mainly because it broke that feature I added to the roku for library trailers. Also yeah, as the OP said, quick fix indeed.. Cracking toast, Gromit!!! Have you played around with the NameStartsWith/TvSeries issue?

@@speechles, are you referring to this?

Share this post


Link to post
Share on other sites
speechles

@@speechles, are you referring to this?

I am if... That eliminates "the" from the front of tv series name. Is there a difference between NameStartsWith and NameStartsWithOrGreater? The difference being one allows sortname changes and the other doesnt? So yeah, not sure entirely. I assume or greater would include other letters after too. Then the filter as well would reduce this down to only that letter.

 

It makes it difficult to work on an app when changes break parts. Then you arent sure if its right to blame the server, or the app code, or just start screaming curse words? Knowing I did nothing in that area for NameStartsWith I knew it was the server. :)

 

Sidenote: this thread can be marked as solved since it has been. We are off topic discussing here in the iOS section. Sorry for the interruption. :)

 

Sent from my Nexus 7 using Tapatalk

Edited by speechles

Share this post


Link to post
Share on other sites
booch

I've verified fix on the latest server version 3.0.5971.0

Thank you very much!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...