Jump to content
Tanamur

ANSWERED Chocolate Theme: Episodes per Season All Show 0

Recommended Posts

Tanamur

My initial impression of the Chocolate enhancements are that they are very nice. Strangely, Chocolate reports I have no episodes in any season of multiple collections and will not let me enter the season folder.. 

 

I didn't find anyone else reporting this. Any suggestions? Thanks

Share this post


Link to post
Share on other sites
CBers

It has been reported previously - see here.

 

Which versions of Chocolate and MBC are you running ??

Edited by CBers

Share this post


Link to post
Share on other sites
Tanamur

It has been reported previously - see here.

 

Which versions of Chocolate and MBC are you running ??

Thanks @@CBers - Basic search in this forum did not highlight that entry with others reporting. I am running MBC:  3.0.100.0 B12-4.1 and Chocolate: 3.0.2.21 (had to look for that one.....)

Share this post


Link to post
Share on other sites
CBers

@@Tanamur - have a read through that thread from the post I quoted as there may be something you can try,

 

I am running la ater version of MBC than you (v3.0.104.0), but I am running the DEV release.

 

The DEV release is not recommened for every day use.

 

I am not seeing trhe zero episodes issue, but I have disabled the new view - see the thread above for further details.

Share this post


Link to post
Share on other sites
Tanamur

@@Tanamur - have a read through that thread from the post I quoted as there may be something you can try,

 

I am running la ater version of MBC than you (v3.0.104.0), but I am running the DEV release.

 

The DEV release is not recommened for every day use.

 

I am not seeing trhe zero episodes issue, but I have disabled the new view - see the thread above for further details.

HNY @@CBers - Thanks for the "dev" level suggestions. Strangely, when I entered the RAL listings of seasons (new rips) there was not a problem. Only 0 episodes were displayed when entering at the EHS>Collection>Series>Season level.

 

With the Version 3.0.5112.40848 beta update yesterday I was still seeing the problem. I opened Media Browser Classic (MBC) Configurator and noticed that while Chocolate was installed, the new/add plugins list did not have it listed in bold as with other themes. I simply uninstalled the Chocolate theme and re-installed it. It appears boldened in the list and now all works fine. So, unfortunately there were changes to two(2) things at once but I suspect the uninstall/re-install fixed the problem.

 

Cheers for the help, @Tanamur

Share this post


Link to post
Share on other sites
mentasm

So a re-install of chocolate now gives you the new series view and corrrectly shows the episodes in that view?

Share this post


Link to post
Share on other sites
Tanamur

So a re-install of chocolate now gives you the new series view and corrrectly shows the episodes in that view?

52c4a426a6c5d_chocolateepisodefix02.jpg

 

As I scroll through season banners or list on the left the episodes appear on the right. Entering the season give me an episode list on the left. Hope this is what you are after.

Share this post


Link to post
Share on other sites
mentasm

hmmm, for me that put me back to ver .19 of Chocolate and completely removed the new view, not fixed it.  Oh well, guess I'll have to wait till ebr finishes it and releases it

Share this post


Link to post
Share on other sites
Tanamur

hmmm, for me that put me back to ver .19 of Chocolate and completely removed the new view, not fixed it.  Oh well, guess I'll have to wait till ebr finishes it and releases it

Same version here as you. Not sure what the version was before I uninstalled/re-installed. However, the season episode feature does work.

52c5e7a3f07c4_chocolateepisodefix03.jpg

Share this post


Link to post
Share on other sites
mentasm

ahh, looking at your screenshot again I can see its not the new TV view, just the old one with banners enabled.  I had .22 installed I think.  ebr didn't mean to release it but did due to a bug.

Share this post


Link to post
Share on other sites
Tanamur

Ahh hah, yes it does look a little different without the number of episodes just next to/under the season banner. Sorry if I confused the issue. I am set for beta and not dev releases.

Share this post


Link to post
Share on other sites
godbodian
Okay I've created the problem the Series 0 issue, created the solution (although not permanent), then recreated the issue. The solution works for multiple seasons, meaning its corrects, retains and does not revert back any season showing as zero, while holding those previously corrected seasons. 

 

What I also noticed is my Chocolate.dll is 3.0.2.21 as opposed to 3.0.2.19. Although when I install version .19 the custom view that I would prefer disappears completely and the view in question can not be attained. I'm running MBServer version 3.0.5115.35703 and MBClassic version 3.0.100.0 B12-4.1, with my updates set to BETA in any and all regards.

 

Back to the temporary fix. What I found is while running version .21 of Chocolate, if I turn off the "custom view" while outside of the TV show(s). Then go into the TV Show and then into whatever respective season, if I then go into settings for Chocolate and turn on the "custom view" when I exit the "config" prompt the individual episodes are visible just as they were before I changed the view settings but once I exit back to the folder showing the multiple seasons, whatever season I was in shows up correctly, acts accordingly and properly until I completely exit the MBC session. 

 

This fix lasts through multiple season "fixings" and video playback (as long as the started session never comes to an end), to the point that, upon exit of playback without stopping the video itself, the video continues behind the visual template of the "custom view" much like it does for regular movie playback.

 

post-300-0-27752000-1388989427_thumb.jpg

Edited by godbodian

Share this post


Link to post
Share on other sites
ebr

Those of you that have this version of Chocolate and the 0 episodes problem, can you please try updating MBC to the current dev release (106)?

 

I cannot reproduce this issue anymore and I'm hoping it is due to some change in the core.  If not, then I'm going to have to get one of you to help me figure out why it is happening to you.

Share this post


Link to post
Share on other sites
mentasm

Will try and give it a go tonight

Share this post


Link to post
Share on other sites
godbodian

When I attempt to update with Dev priveledges it goes to version 3.0.107.0 and not 3.0.106.0, EBR do you want me to use this version and test?

Share this post


Link to post
Share on other sites
ebr

Yes.  I already pushed another dev version since I posted that.

Share this post


Link to post
Share on other sites
godbodian

Okay should I update all aspects of MBC and MBS to make certain the compatibility aspects are assured or can I run that Dev MBC off the last MBS Beta release? (3.0.5115.35703)

Share this post


Link to post
Share on other sites
WWWestern

Yesss! Cured.

MBC .107, Choco .20

  • Like 1

Share this post


Link to post
Share on other sites
godbodian

Okay the Dev version of MBC works perfectly. Should we revert settings to BETA and wait for the Beta release for stability purposes? Or remain on Dev, with regard to updates?

Thanks EBR.

Share this post


Link to post
Share on other sites
ebr

Okay, good to know.  Thanks.

 

You should be okay on that dev release of MBC.  I hope to promote it to Beta soon and you guys can tell me if there are any problems we missed ;).

Share this post


Link to post
Share on other sites
godbodian

No problem, anyone that has the problem will have to allow MBS to rerun image extractions, refresh people and scan, then restart MBC once all that is completed otherwise it MAY appear like the issue did not correct itself.

Share this post


Link to post
Share on other sites
mentasm

I managed to get MBC up to 108, but I don't seem to be able to get Chocolate to update beyond 19 at all even with plugin updates set at dev

Share this post


Link to post
Share on other sites
ebr

I managed to get MBC up to 108, but I don't seem to be able to get Chocolate to update beyond 19 at all even with plugin updates set at dev

 

Yeah, I haven't put the newer chocolate version up yet because the current version of MBC will deliver it to everyone.

Share this post


Link to post
Share on other sites
mentasm

ahh, thats still not fixed.  Thought it might have been squashed already

Share this post


Link to post
Share on other sites
ebr

ahh, thats still not fixed.  Thought it might have been squashed already

 

It is fixed in 108 but that version just went out today.

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...