Jump to content


Photo

Using SPMC on SATV

Kodi spmc Shield

  • This topic is locked This topic is locked
11 replies to this topic

#1 Pelon OFFLINE  

Pelon

    Advanced Member

  • Members
  • 154 posts
  • Local time: 03:55 AM

Posted 18 March 2016 - 12:09 AM

I'm currently running Emby on top of the new SPMC client that as of now looks like it is going to be the future of Kodi on Android.

So far it is running great, it can handle all audio passthrough and it even shows recommendations on the main screen.

I also like that it is a way to have two different kodi apps installed that can have different configurations and add-ons

System" screensaver to enable daydream; all other screensavers disable daydream
Get removable storage names from system
Basic Bluray 3D iso playback (experimental; amlogic)
Android TV recommendations and voice search (experimental)

http://spmc.semperpax.com/

#2 Tranquil OFFLINE  

Tranquil

    Advanced Member

  • Alpha Testers
  • 439 posts
  • Local time: 08:55 AM
  • LocationEurope, GER

Posted 18 March 2016 - 05:17 AM

Its so sad what is happening with KODI4Android atm.

Hope they will find another android maintainer soon. I would love to stay with the original KODI one.



#3 Nazgulled OFFLINE  

Nazgulled

    Advanced Member

  • Members
  • 70 posts
  • Local time: 09:55 AM

Posted 23 March 2016 - 10:05 PM

@Pelon Do you have the Emby addon working with the latest (16.1.2) SPMC? Because I can't get it to work... I got a popup stating that the "Kodi" version is not supported. How did you manage to get it working?



#4 wints OFFLINE  

wints

    Advanced Member

  • Members
  • 78 posts
  • Local time: 08:55 AM

Posted 24 March 2016 - 03:47 PM

Yeah I've got it working no problem and no errors



#5 xnappo OFFLINE  

xnappo

    Advanced Member

  • Developers
  • 4752 posts
  • Local time: 02:55 AM
  • LocationAustin, TX

Posted 24 March 2016 - 04:46 PM

@Nazgulled - can you post a log?



#6 Nazgulled OFFLINE  

Nazgulled

    Advanced Member

  • Members
  • 70 posts
  • Local time: 09:55 AM

Posted 25 March 2016 - 02:29 PM

Yes, here you go: https://gist.github....34c85a008c475d6



#7 xnappo OFFLINE  

xnappo

    Advanced Member

  • Developers
  • 4752 posts
  • Local time: 02:55 AM
  • LocationAustin, TX

Posted 25 March 2016 - 02:40 PM

Looks like the forking has begun.  It is using some experimental database:

18:21:12 T:1393244464  NOTICE: Running database version ShieldMusic56
18:21:12 T:1393244464  NOTICE: Running database version ShieldMovies99

Maybe this is optional?



#8 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 12690 posts
  • Local time: 02:55 AM

Posted 25 March 2016 - 03:22 PM

This is going to be nightmare to deal with...


Sent from my iPhone using Tapatalk

#9 Nazgulled OFFLINE  

Nazgulled

    Advanced Member

  • Members
  • 70 posts
  • Local time: 09:55 AM

Posted 25 March 2016 - 04:11 PM

So there's nothing that I can do?

 

I actually just noticed that my movies/tv shows are now displayed on SPMC but when launching SPMC and after Emby makes a successful login/sync, I get an error (not sure if that's on the log I posted).



#10 Nazgulled OFFLINE  

Nazgulled

    Advanced Member

  • Members
  • 70 posts
  • Local time: 09:55 AM

Posted 29 March 2016 - 08:17 AM

Looks like the forking has begun.  It is using some experimental database:

18:21:12 T:1393244464  NOTICE: Running database version ShieldMusic56
18:21:12 T:1393244464  NOTICE: Running database version ShieldMovies99

Maybe this is optional?

For the record, those are only named "Shield*" because I have some options on advancedsettings.xml (I just realized that yesterday), I was using a centralized database with mysql and to avoid possible table clashing in the future, I renamed those to Shield* instead of My*. In other words, the current SPMC fork uses the same database structure as Kodi and the databases have the same version numbers. No need to worry just yet :)


  • xnappo likes this

#11 xnappo OFFLINE  

xnappo

    Advanced Member

  • Developers
  • 4752 posts
  • Local time: 02:55 AM
  • LocationAustin, TX

Posted 29 March 2016 - 10:36 AM

Phew - good! That makes more sense - I was surprised he had the bandwidth to mess with the DB.

 

So it is working for you now?

 

xnappo



#12 Nazgulled OFFLINE  

Nazgulled

    Advanced Member

  • Members
  • 70 posts
  • Local time: 09:55 AM

Posted 29 March 2016 - 12:24 PM

Yes, but that was not the issue, I had other problems. The issue and the fix is described in that other thread.

 

Thanks.







Also tagged with one or more of these keywords: Kodi, spmc, Shield

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users