Jump to content


Photo

Emby 2.0 DVD Anamorphic Resolution issue

anamorphic dvd

  • Please log in to reply
68 replies to this topic

#1 arsim OFFLINE  

arsim

    Member

  • Members
  • 11 posts
  • Local time: 02:10 PM

Posted 04 March 2016 - 11:08 PM

@babgvant I have found an issue in the v2.0 emby theater where Anamorphic DVDs converted to mkv format are not displayed properly.

Emby seems to follow the video pixel width parameter (720) in the mkv header, but not the display width parameter (853).

This results in the video being player back in 4:3 (720x480) instead of 1.78 ratio (853x480). 

All other players seem to follow the display width including Emby server.

 

Has anyone else had this issue?



#2 Walter OFFLINE  

Walter

    Advanced Member

  • Members
  • 63 posts
  • Local time: 07:10 AM
  • LocationLos Angeles, CA

Posted 05 March 2016 - 12:59 AM

http://emby.media/co...on/#entry307555

#3 babgvant OFFLINE  

babgvant

    Advanced Member

  • Developers
  • 554 posts
  • Local time: 03:10 PM
  • LocationLondon, UK

Posted 05 March 2016 - 06:03 AM

@babgvant I have found an issue in the v2.0 emby theater where Anamorphic DVDs converted to mkv format are not displayed properly.

Emby seems to follow the video pixel width parameter (720) in the mkv header, but not the display width parameter (853).

This results in the video being player back in 4:3 (720x480) instead of 1.78 ratio (853x480). 

All other players seem to follow the display width including Emby server.

 

Has anyone else had this issue?

 

Could I get a sample file? Does it reproduce w/ madVR & EVR+?



#4 Walter OFFLINE  

Walter

    Advanced Member

  • Members
  • 63 posts
  • Local time: 07:10 AM
  • LocationLos Angeles, CA

Posted 06 March 2016 - 12:00 PM

@babgvant Its only in MadVR, here is a sample file.

Attached Files



#5 babgvant OFFLINE  

babgvant

    Advanced Member

  • Developers
  • 554 posts
  • Local time: 03:10 PM
  • LocationLondon, UK

Posted 06 March 2016 - 12:44 PM

@babgvant Its only in MadVR, here is a sample file.

 

So just to be clear. It works as expected with EVR+, but not madVR?



#6 Walter OFFLINE  

Walter

    Advanced Member

  • Members
  • 63 posts
  • Local time: 07:10 AM
  • LocationLos Angeles, CA

Posted 06 March 2016 - 02:15 PM

Yeah, only problem is in MadVR. If you use an older version of MadVR it works fine. I think it's related to the new zoom feature they added. I posted screen shots in this post http://emby.media/co...on/#entry307555.



#7 Harblar OFFLINE  

Harblar

    Advanced Member

  • Members
  • 172 posts
  • Local time: 09:10 AM

Posted 06 March 2016 - 11:12 PM

I'm having the same issue. Seems as though this happened in the past, as well, on the old Emby Theater.



#8 babgvant OFFLINE  

babgvant

    Advanced Member

  • Developers
  • 554 posts
  • Local time: 03:10 PM
  • LocationLondon, UK

Posted 07 March 2016 - 04:38 AM

Yeah, only problem is in MadVR. If you use an older version of MadVR it works fine. I think it's related to the new zoom feature they added. I posted screen shots in this post http://emby.media/co...on/#entry307555.

 

If you replace the version of madVR included w/ Emby with the latest on Doom9, does it still reproduce?

 

LMK if you need assistance with that process.



#9 Walter OFFLINE  

Walter

    Advanced Member

  • Members
  • 63 posts
  • Local time: 07:10 AM
  • LocationLos Angeles, CA

Posted 07 March 2016 - 12:44 PM

Yeah the latest version (0.90.15) still has the issue. I have (0.88.21) installed and that does not produce the stretched screen. That was the last version to not include the Zoom feature and black bar removal. 


Edited by Walter, 07 March 2016 - 12:55 PM.


#10 babgvant OFFLINE  

babgvant

    Advanced Member

  • Developers
  • 554 posts
  • Local time: 03:10 PM
  • LocationLondon, UK

Posted 07 March 2016 - 01:12 PM

Have you raised the issue on the madVR thread at Doom9?



#11 gcoupe OFFLINE  

gcoupe

    Advanced Member

  • Members
  • 326 posts
  • Local time: 03:10 PM

Posted 07 March 2016 - 01:18 PM

Yep, I'm seeing this issue as well:

 

http://emby.media/co...-47#entry309331



#12 Walter OFFLINE  

Walter

    Advanced Member

  • Members
  • 63 posts
  • Local time: 07:10 AM
  • LocationLos Angeles, CA

Posted 07 March 2016 - 01:50 PM

No, cause it only happens with MBTheater. MPC does not exhibit this issue. So I was thinking it was an issue with the player in Theater. I would just use EVR+ but as you can see in this screenshot it looks awful compared to MadVR. http://www.screensho...mparison/164734


Edited by Walter, 07 March 2016 - 02:27 PM.


#13 babgvant OFFLINE  

babgvant

    Advanced Member

  • Developers
  • 554 posts
  • Local time: 03:10 PM
  • LocationLondon, UK

Posted 07 March 2016 - 04:27 PM

That's odd. Wonder why it would only reproduce in ET.

 

What GPU are you using? Can you confirm the version of EVR+ (right click on the dll and look at the properties tab).



#14 Walter OFFLINE  

Walter

    Advanced Member

  • Members
  • 63 posts
  • Local time: 07:10 AM
  • LocationLos Angeles, CA

Posted 07 March 2016 - 04:47 PM

1.0.0.7, Nvidia GTX 970. But it does it all on my computers Intel, ATI and Nvidia. Did the file I send you play fine on your copy of ET? It was ripped with MakeMKV then converted in handbrake. I don't have any codecs installed the only players I use are ET and the MPC-HC to watch DVDs. I just wonder if something is broken on my end, EVR+ should not look so pixelated. I have tried everything I know, clean install, remove everything, etc. And its only broken for DVD content. 720p and 1080p work just fine.


Edited by Walter, 07 March 2016 - 04:53 PM.


#15 babgvant OFFLINE  

babgvant

    Advanced Member

  • Developers
  • 554 posts
  • Local time: 03:10 PM
  • LocationLondon, UK

Posted 07 March 2016 - 05:03 PM

1.0.0.7, Nvidia GTX 970. But it does it all on my computers Intel, ATI and Nvidia. Did the file I send you play fine on your copy of ET? It was ripped with MakeMKV then converted in handbrake. I don't have any codecs installed the only players I use are ET and the MPC-HC to watch DVDs. I just wonder if something is broken on my end, EVR+ should not look so pixelated. I have tried everything I know, clean install, remove everything, etc. And its only broken for DVD content. 720p and 1080p work just fine.

 

madVR will make a big difference on non-Intel HW, but it is curious that EVR+ looks that bad. I just changed the way it works so that's surprising. Although it's possible that GPU scaling for this type of content isn't great.

 

I haven't had a chance to look at the file yet.



#16 elshagon OFFLINE  

elshagon

    Advanced Member

  • Members
  • 163 posts
  • Local time: 06:10 AM

Posted 09 March 2016 - 03:17 AM

Not sure if this is related, but tonight I noticed a DVD converted to MKV play in 4x3 when it should have been 16x9 as well.  One odd thing is when I hit my mouse to take it out of full screen mode the video switched to 16x9 and stayed there.  I backed out and tried it again.  Once again the movie started in 4x3 and reverted to 16x9 once taken out of full screen.  You can then go back to full screen and retain the 16x9.



#17 Harblar OFFLINE  

Harblar

    Advanced Member

  • Members
  • 172 posts
  • Local time: 09:10 AM

Posted 09 March 2016 - 03:52 AM

Hitting the restore Icon twice (in the upper right corner) fixes the issue. Obviously a quirk somewhere, but I don't have a clue where or how to fix it.



#18 babgvant OFFLINE  

babgvant

    Advanced Member

  • Developers
  • 554 posts
  • Local time: 03:10 PM
  • LocationLondon, UK

Posted 16 March 2016 - 03:33 PM

Yeah, only problem is in MadVR. If you use an older version of MadVR it works fine. I think it's related to the new zoom feature they added. I posted screen shots in this post http://emby.media/co...on/#entry307555.

 

Should be fixed. Hopefully @Luke will have a chance to pull in soon.


  • njoak likes this

#19 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 145887 posts
  • Local time: 09:10 AM

Posted 16 March 2016 - 03:51 PM

I just posted 2.0.7.


  • babgvant likes this

#20 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13376 posts
  • Local time: 06:10 AM

Posted 16 March 2016 - 10:36 PM

56ea18d67e58c_Snapshot_9.jpg

 

Sorry guys, but it still happens in 2.0.7, only with EVR+, although, the aspect ratio does appear to be correct...

 

Here's a link to the file, babgvant, if you want to test. I have an i7 6700k with an intel HD530 GPU and running Win 10 pro.

 

https://drive.google...iew?usp=sharing


Edited by Doofus, 17 March 2016 - 12:11 AM.






Also tagged with one or more of these keywords: anamorphic, dvd

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users