Jump to content


Photo

Remote Access Stopped After KODI update

remote access KODI Update

Best Answer DParsons , 02 March 2016 - 12:52 PM

I have finally found what the problem is from the IT manager at my company who is familiar with port forwarding. I'll post the solution here so it might help others.

If you use a ddns to access emby remotely because your IP changes periodically there is one more IP that can change, your internal IP. You will need to permanently assign your internal IP address so that it will never change including the subnet mask and and default gateway. Make these changes to your Ip4 adapter settings and it's fixed. If you need any help getting your subnet mask or default gateway that is where I got info from my companies IT dept, but that is all you will need to change in order to make sure that your internal IP address never changes and your DDNS will work without interruptions as this has happened to me several times in the past and no one has been able to give any assistance on kodi or emby support forums. The typical setting is to automatically obtain an IP which is where the problem can arise.

 

 

Thanks Luke, I don't seem to get notifications of post replies and I just saw your response when I came here to post this solution.

 

Go to the full post


  • Please log in to reply
6 replies to this topic

#1 DParsons OFFLINE  

DParsons

    Advanced Member

  • Members
  • 87 posts
  • Local time: 11:18 AM

Posted 26 February 2016 - 12:25 AM

About two days ago I updated KODI to the latest version and ever since then I have not been able to connect remotely. I'm not sure where to even ask for support about this issue but since it is Emby that provides the remote access to my content I thought I should start here. Nothing was changed and all ports are forwarded on my router and I'm using the same DDNS to access my content but it just stopped working after updating KODI. Does anyone have any suggestions are known fixes for this problem.



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 139743 posts
  • Local time: 06:18 AM

Posted 26 February 2016 - 01:00 AM

Hi, can you provide the server log?

 

http://emby.media/co...port-a-problem/

 

Thanks.



#3 DParsons OFFLINE  

DParsons

    Advanced Member

  • Members
  • 87 posts
  • Local time: 11:18 AM

Posted 02 March 2016 - 12:52 PM   Best Answer

I have finally found what the problem is from the IT manager at my company who is familiar with port forwarding. I'll post the solution here so it might help others.

If you use a ddns to access emby remotely because your IP changes periodically there is one more IP that can change, your internal IP. You will need to permanently assign your internal IP address so that it will never change including the subnet mask and and default gateway. Make these changes to your Ip4 adapter settings and it's fixed. If you need any help getting your subnet mask or default gateway that is where I got info from my companies IT dept, but that is all you will need to change in order to make sure that your internal IP address never changes and your DDNS will work without interruptions as this has happened to me several times in the past and no one has been able to give any assistance on kodi or emby support forums. The typical setting is to automatically obtain an IP which is where the problem can arise.

 

 

Thanks Luke, I don't seem to get notifications of post replies and I just saw your response when I came here to post this solution.

 

Attached Files


  • ebr likes this

#4 Vidman OFFLINE  

Vidman

    Advanced Member

  • Alpha Testers
  • 2662 posts
  • Local time: 07:18 PM

Posted 03 March 2016 - 05:48 AM

So it had nothing to do with updating kodi
The issue was your server negotiated a new IP from your router

Edited by Vidman, 03 March 2016 - 05:49 AM.


#5 DParsons OFFLINE  

DParsons

    Advanced Member

  • Members
  • 87 posts
  • Local time: 11:18 AM

Posted 03 March 2016 - 10:15 AM

I'm not sure, that does sound right, but it was very coincidental. I'm assuming still that maybe inadvertently the update had something to do with the IP being reassigned to another device but again I'm not certain what exactly happened. I'll see if I can change the title here to just how to set a static internal IP along with using a DDNS or something more appropriate. 


Edited by DParsons, 03 March 2016 - 10:18 AM.


#6 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 47409 posts
  • Local time: 06:18 AM

Posted 03 March 2016 - 10:44 AM

Every time you re-start a machine on your network, if it is using DHCP for its IP address, it has the potential to get a different one.  If operating a server, you need to define a static IP or permanent lease in DHCP.



#7 DParsons OFFLINE  

DParsons

    Advanced Member

  • Members
  • 87 posts
  • Local time: 11:18 AM

Posted 03 March 2016 - 10:53 AM

My IT friend had mentioned the same thing, the DHCP, and he had mentioned that he was surprised it had not happened before. Networking is beyond my current pc experience so it was always a mystery to me. But it did happen before and I suppose the IP must have cycled back to the right one eventually because it just started to work again several days later but it has definitely happened before.







Also tagged with one or more of these keywords: remote access, KODI Update

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users