Jump to content


Photo

Pictures not displayed

FreeNAS Pictures

  • Please log in to reply
7 replies to this topic

#1 gebhard OFFLINE  

gebhard

    Advanced Member

  • Members
  • 47 posts
  • Local time: 02:49 PM

Posted 09 February 2016 - 03:02 PM

Hi,

 

I've put some pictures (JPG) in a directory of a mixed library.

 

Directory listing: Attached File  Directory Listing.png   12.74KB   2 downloads

The directory can be accessed by Emby, the pictures should also be accessible (other: r).

 

But the content of the Folder "Dies-und-das" is not displayed, the folder in the library is empty: Attached File  Library Content.png   31.77KB   2 downloads

 

Log: Attached File  log.txt   21.74KB   2 downloads

 

Emby Version 3.0.5821.0

 

 

Thanks,

Gebhard

 

 



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156950 posts
  • Local time: 09:49 AM

Posted 09 February 2016 - 03:04 PM

Hi, for photos you need to use Content Type Photos. They are not supported in any other kind of library at the moment. thanks.


  • gebhard likes this

#3 gebhard OFFLINE  

gebhard

    Advanced Member

  • Members
  • 47 posts
  • Local time: 02:49 PM

Posted 09 February 2016 - 03:32 PM

aaaahhh... this helps... thanks for the fast reply... really feeling like a n00b :-(

#4 gebhard OFFLINE  

gebhard

    Advanced Member

  • Members
  • 47 posts
  • Local time: 02:49 PM

Posted 09 February 2016 - 05:03 PM

When I try to download a picture I get an error and the following shows up in the log:

2016-02-09 20:57:07.7622 Info HttpServer: HTTP Response 200 to 192.168.1.108. Time: 12ms. http://192.168.1.165...8b0e5f9613c8ec4
2016-02-09 20:57:10.3117 Info HttpServer: HTTP GET http://192.168.1.165...48eaccede0a4f1d. UserAgent: Mozilla/5.0 (Linux; Android 5.1.1; ONE A2003 Build/LMY47V; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/47.0.2526.100 Mobile Safari/537.36
2016-02-09 20:57:10.3139 Error DtoUtils: ServiceBase<TRequest>::Service Exception
*** Error Report ***
Version: 3.0.5821.0
Command line: /usr/pbi/emby-amd64/lib/emby-server/MediaBrowser.Server.Mono.exe -ffmpeg /usr/pbi/emby-amd64/bin/ffmpeg -ffprobe /usr/pbi/emby-amd64/bin/ffprobe -programdata /var/db/emby-server
Operating system: Unix 9.1.0.0
Processor count: 2
64-Bit OS: True
64-Bit Process: True
Program data path: /var/db/emby-server
Mono: 4.2.1 (Stable 4.2.1.124/39edf24 Sun Jan 10 05:27:13 UTC 2016)
Application Path: /usr/pbi/emby-amd64/lib/emby-server/MediaBrowser.Server.Mono.exe
Item does not support downloading
System.ArgumentException
at MediaBrowser.Api.Library.LibraryService.Get (MediaBrowser.Api.Library.GetDownload request) <0x8167ea780 + 0x0033d> in <filename unknown>:0
at (wrapper dynamic-method) System.Object:lambda_method (System.Runtime.CompilerServices.Closure,object,object)
at ServiceStack.Host.ServiceRunner`1[TRequest].Execute (IRequest request, System.Object instance, ServiceStack.Host.TRequest requestDto) <0x80ffb2a40 + 0x0045b> in <filename unknown>:0

2016-02-09 20:57:10.3139 Error HttpServer: Error processing request for /emby/Items/9ca068ada71b8eacf259b95f785ef4bf/Download?api_key=f6bcfb9a70d74d58948eaccede0a4f1d
*** Error Report ***
Version: 3.0.5821.0
Command line: /usr/pbi/emby-amd64/lib/emby-server/MediaBrowser.Server.Mono.exe -ffmpeg /usr/pbi/emby-amd64/bin/ffmpeg -ffprobe /usr/pbi/emby-amd64/bin/ffprobe -programdata /var/db/emby-server
Operating system: Unix 9.1.0.0
Processor count: 2
64-Bit OS: True
64-Bit Process: True
Program data path: /var/db/emby-server
Mono: 4.2.1 (Stable 4.2.1.124/39edf24 Sun Jan 10 05:27:13 UTC 2016)
Application Path: /usr/pbi/emby-amd64/lib/emby-server/MediaBrowser.Server.Mono.exe
Item does not support downloading
ServiceStack.HttpError
No Stack Trace Available

2016-02-09 20:57:10.3155 Info HttpServer: HTTP Response 400 to 192.168.1.108. Time: 4ms. http://192.168.1.165...48eaccede0a4f1d
2016-02-09 20:57:12.3731 Info App: Scan media library Completed after 0 minute(s) and 15 seconds
2016-02-09 20:57:20.4789 Info App: HttpClientManager GET: http://192.168.1.104...Description.xml
2016-02-09 20:57:20.6947 Info App: HttpClientManager GET: http://192.168.1.104...ringControl.xml
2016-02-09 20:57:20.7051 Error App: Error getting response from http://192.168.1.104...ringControl.xml
*** Error Report ***
Version: 3.0.5821.0
Command line: /usr/pbi/emby-amd64/lib/emby-server/MediaBrowser.Server.Mono.exe -ffmpeg /usr/pbi/emby-amd64/bin/ffmpeg -ffprobe /usr/pbi/emby-amd64/bin/ffprobe -programdata /var/db/emby-server
Operating system: Unix 9.1.0.0
Processor count: 2
64-Bit OS: True
64-Bit Process: True
Program data path: /var/db/emby-server
Mono: 4.2.1 (Stable 4.2.1.124/39edf24 Sun Jan 10 05:27:13 UTC 2016)
Application Path: /usr/pbi/emby-amd64/lib/emby-server/MediaBrowser.Server.Mono.exe
One or more errors occurred.
System.AggregateException
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x80fe288f0 + 0x00038> in <filename unknown>:0
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x80fe28110 + 0x00118> in <filename unknown>:0
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x80fe27830 + 0x000b3> in <filename unknown>:0
at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0x80808cb30 + 0x00042> in <filename unknown>:0
at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () <0x808123920 + 0x0001f> in <filename unknown>:0
at MediaBrowser.Common.Implementations.HttpClientManager.HttpClientManager+<SendAsyncInternal>c__async4.MoveNext () <0x80ff62650 + 0x01110> in <filename unknown>:0
InnerException: System.Net.WebException
The remote server returned an error: (404) Not Found.
at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) <0x80fd50e00 + 0x0020d> in <filename unknown>:0
at System.Threading.Tasks.TaskFactory`1[TResult].FromAsyncCoreLogic (IAsyncResult iar, System.Func`2 endFunction, System.Action`1 endAction, System.Threading.Tasks.Task`1 promise, Boolean requiresSynchronization) <0x80ffc8580 + 0x00093> in <filename unknown>:0

2016-02-09 20:57:20.7062 Error Dlna: Error creating PlayTo device.
*** Error Report ***
Version: 3.0.5821.0
Command line: /usr/pbi/emby-amd64/lib/emby-server/MediaBrowser.Server.Mono.exe -ffmpeg /usr/pbi/emby-amd64/bin/ffmpeg -ffprobe /usr/pbi/emby-amd64/bin/ffprobe -programdata /var/db/emby-server
Operating system: Unix 9.1.0.0
Processor count: 2
64-Bit OS: True
64-Bit Process: True
Program data path: /var/db/emby-server
Mono: 4.2.1 (Stable 4.2.1.124/39edf24 Sun Jan 10 05:27:13 UTC 2016)
Application Path: /usr/pbi/emby-amd64/lib/emby-server/MediaBrowser.Server.Mono.exe
One or more errors occurred.
MediaBrowser.Model.Net.HttpException
at MediaBrowser.Common.Implementations.HttpClientManager.HttpClientManager+<SendAsyncInternal>c__async4.MoveNext () <0x80ff62650 + 0x0197d> in <filename unknown>:0
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x80fe288f0 + 0x00038> in <filename unknown>:0
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x80fe28110 + 0x00118> in <filename unknown>:0
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x80fe27830 + 0x000b3> in <filename unknown>:0
at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0x80808cb30 + 0x00042> in <filename unknown>:0
at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () <0x808123920 + 0x0001f> in <filename unknown>:0
at MediaBrowser.Common.Implementations.HttpClientManager.HttpClientManager+<SendAsync>c__async1.MoveNext () <0x80ff5d170 + 0x0022c> in <filename unknown>:0
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x80fe288f0 + 0x00038> in <filename unknown>:0
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x80fe28110 + 0x00118> in <filename unknown>:0
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x80fe27830 + 0x000b3> in <filename unknown>:0
at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0x80808cb30 + 0x00042> in <filename unknown>:0
at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () <0x808123920 + 0x0001f> in <filename unknown>:0
at MediaBrowser.Common.Implementations.HttpClientManager.HttpClientManager+<Get>c__async0.MoveNext () <0x80ffec3f0 + 0x00188> in <filename unknown>:0
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x80fe288f0 + 0x00038> in <filename unknown>:0
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x80fe28110 + 0x00118> in <filename unknown>:0
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x80fe27830 + 0x000b3> in <filename unknown>:0
at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0x80808cb30 + 0x00042> in <filename unknown>:0
at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () <0x808123920 + 0x0001f> in <filename unknown>:0
at MediaBrowser.Dlna.PlayTo.SsdpHttpClient+<GetDataAsync>c__async2.MoveNext () <0x8168a9920 + 0x00310> in <filename unknown>:0
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x80fe288f0 + 0x00038> in <filename unknown>:0
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x80fe28110 + 0x00118> in <filename unknown>:0
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x80fe27830 + 0x000b3> in <filename unknown>:0
at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0x80808cb30 + 0x00042> in <filename unknown>:0
at System.Runtime.CompilerServices.TaskAwaiter`1[TResult].GetResult () <0x815a37d00 + 0x0001f> in <filename unknown>:0
at MediaBrowser.Dlna.PlayTo.Device+<GetRenderingProtocolAsync>c__async11.MoveNext () <0x8168e2fb0 + 0x003a3> in <filename unknown>:0
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x80fe288f0 + 0x00038> in <filename unknown>:0
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x80fe28110 + 0x00118> in <filename unknown>:0
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x80fe27830 + 0x000b3> in <filename unknown>:0
at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0x80808cb30 + 0x00042> in <filename unknown>:0
at System.Runtime.CompilerServices.ConfiguredTaskAwaitable+ConfiguredTaskAwaiter.GetResult () <0x80808cb00 + 0x0001a> in <filename unknown>:0
at MediaBrowser.Dlna.PlayTo.Device+<CreateuPnpDeviceAsync>c__async12.MoveNext () <0x8168a71a0 + 0x01ca5> in <filename unknown>:0
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x80fe288f0 + 0x00038> in <filename unknown>:0
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x80fe28110 + 0x00118> in <filename unknown>:0
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x80fe27830 + 0x000b3> in <filename unknown>:0
at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0x80808cb30 + 0x00042> in <filename unknown>:0
at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () <0x808123920 + 0x0001f> in <filename unknown>:0
at MediaBrowser.Dlna.PlayTo.PlayToManager+<_deviceDiscovery_DeviceDiscovered>c__async0.MoveNext () <0x80ffe04a0 + 0x00935> in <filename unknown>:0
InnerException: System.AggregateException
One or more errors occurred.
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x80fe288f0 + 0x00038> in <filename unknown>:0
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x80fe28110 + 0x00118> in <filename unknown>:0
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x80fe27830 + 0x000b3> in <filename unknown>:0
at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0x80808cb30 + 0x00042> in <filename unknown>:0
at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () <0x808123920 + 0x0001f> in <filename unknown>:0
at MediaBrowser.Common.Implementations.HttpClientManager.HttpClientManager+<SendAsyncInternal>c__async4.MoveNext () <0x80ff62650 + 0x01110> in <filename unknown>:0
InnerException: System.Net.WebException
The remote server returned an error: (404) Not Found.
at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) <0x80fd50e00 + 0x0020d> in <filename unknown>:0
at System.Threading.Tasks.TaskFactory`1[TResult].FromAsyncCoreLogic (IAsyncResult iar, System.Func`2 endFunction, System.Action`1 endAction, System.Threading.Tasks.Task`1 promise, Boolean requiresSynchronization) <0x80ffc8580 + 0x00093> in <filename unknown>:0

2016-02-09 20:57:28.2233 Info HttpServer: HTTP GET http://192.168.1.165...tem/info/public. UserAgent: Mozilla/5.0 (Linux; Android 5.1.1; ONE A2003 Build/LMY47V; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/47.0.2526.100 Mobile Safari/537.36
2016-02-09 20:57:28.2252 Info HttpServer: HTTP Response 200 to 192.168.1.108. Time: 2ms. http://192.168.1.165...tem/info/public
2016-02-09 20:57:28.2733 Info HttpServer: HTTP GET http://192.168.1.165...mby/System/Info. UserAgent: Mozilla/5.0 (Linux; Android 5.1.1; ONE A2003 Build/LMY47V; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/47.0.2526.100 Mobile Safari/537.36

Thanks,
Gebhard

#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156950 posts
  • Local time: 09:49 AM

Posted 09 February 2016 - 05:05 PM

I don't know. please always attach complete log files. thanks.



#6 gebhard OFFLINE  

gebhard

    Advanced Member

  • Members
  • 47 posts
  • Local time: 02:49 PM

Posted 10 February 2016 - 02:36 PM

Attached. Thanks.

Attached Files



#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156950 posts
  • Local time: 09:49 AM

Posted 10 February 2016 - 02:47 PM

Thanks. can you please discuss what you tried to do prior to that screen? thanks.



#8 gebhard OFFLINE  

gebhard

    Advanced Member

  • Members
  • 47 posts
  • Local time: 02:49 PM

Posted 10 February 2016 - 03:20 PM

Hi, I've tried to download one of the pictures I mentioned earlier in this post.

Cheers







Also tagged with one or more of these keywords: FreeNAS, Pictures

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users