Jump to content

last.fm addon gone?


Guest petwri
 Share

Recommended Posts

haudankaivajasi

Great job! 

 

Somehow this is not working with my set up :o

I unzipped the contents (the .dll-file) to my QNAP location "/share/CACHEDEV1_DATA/.qpkg/Emby/Emby/ProgramData-Server/plugins" , or atleast I think this is the right location. I restarted the emby server and now this plugin is visible in the plugins-tab and I am able to set my last.fm login details, but for some reason it won't scrobble :o

 

Any ideas for this problem?

 

Edit: The connection seems to be working because when I click the favorite button on Emby, it updates instantly to my last.fm page :o no scrobbling though

Edited by haudankaivajasi
Link to comment
Share on other sites

Deliah Blue

Edit: The connection seems to be working because when I click the favorite button on Emby, it updates instantly to my last.fm page :o no scrobbling though

are you letting the songs complete in Emby before checking last.fm? Edited by Deliah Blue
Link to comment
Share on other sites

haudankaivajasi

Yeah, played some albums from start to finish but still nothing. Refreshed the last.fm page after the whole album.

Edited by haudankaivajasi
Link to comment
Share on other sites

Yeah, played some albums from start to finish but still nothing. Refreshed the last.fm page after the whole album.

 

Please make sure to provide the information requested in how to report a problem. That should help him see what's going on. Thanks!

Link to comment
Share on other sites

Symphony

Ah, sure. Should I start a new topic about this problem or..?

The main thing would be providing a log, which should help give some answers as to why you're experiencing issues.

Link to comment
Share on other sites

Symphony

Here is a log file from one listening session. Didn't do anything else at the time than listen to music.

 

I've had a look at the log and it looks like it's falling over because it can't determine the file being played.

 

 

Value cannot be null.
Parameter name: stringToEscape
System.ArgumentNullException
 at System.Uri.EscapeDataString (System.String stringToEscape) <0xed0622d8 + 0x001fb> in <filename unknown>:0 
 at LastfmScrobbler.Api.BaseLastfmApiClient+<>c.<EscapeDictionary>b__9_1 (KeyValuePair`2 item) <0xed0622b0 + 0x00013> in <filename unknown>:0 
 at System.Linq.Enumerable.ToDictionary[TSource,TKey,TElement] (IEnumerable`1 source, System.Func`2 keySelector, System.Func`2 elementSelector, IEqualityComparer`1 comparer) <0xed0620e8 + 0x000cf> in <filename unknown>:0 
 at System.Linq.Enumerable.ToDictionary[TSource,TKey,TElement] (IEnumerable`1 source, System.Func`2 keySelector, System.Func`2 elementSelector) <0xed0620b0 + 0x00027> in <filename unknown>:0 
 at LastfmScrobbler.Api.BaseLastfmApiClient.EscapeDictionary (System.Collections.Generic.Dictionary`2 dic) <0xed061f40 + 0x00143> in <filename unknown>:0 
 at LastfmScrobbler.Api.BaseLastfmApiClient+<Post>d__4`2[TRequest,TResponse].MoveNext () <0xed060428 + 0x00197> in <filename unknown>:0 
--- End of stack trace from previous location where exception was thrown ---
 at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0xf51fcfc0 + 0x00035> in <filename unknown>:0 
 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0xf51fbfd0 + 0x000b7> in <filename unknown>:0 
 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0xf51fbf40 + 0x00084> in <filename unknown>:0 
 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0xf51fbef0 + 0x0003f> in <filename unknown>:0 
 at System.Runtime.CompilerServices.TaskAwaiter`1[TResult].GetResult () <0xf51fc240 + 0x00024> in <filename unknown>:0 
 at LastfmScrobbler.Api.LastfmApiClient+<NowPlaying>d__3.MoveNext () <0xed05fa30 + 0x0044f> in <filename unknown>:0 Value cannot be null.
Parameter name: stringToEscape
System.ArgumentNullException
 at System.Uri.EscapeDataString (System.String stringToEscape) <0xed0622d8 + 0x001fb> in <filename unknown>:0 
 at LastfmScrobbler.Api.BaseLastfmApiClient+<>c.<EscapeDictionary>b__9_1 (KeyValuePair`2 item) <0xed0622b0 + 0x00013> in <filename unknown>:0 
 at System.Linq.Enumerable.ToDictionary[TSource,TKey,TElement] (IEnumerable`1 source, System.Func`2 keySelector, System.Func`2 elementSelector, IEqualityComparer`1 comparer) <0xed0620e8 + 0x000cf> in <filename unknown>:0 
 at System.Linq.Enumerable.ToDictionary[TSource,TKey,TElement] (IEnumerable`1 source, System.Func`2 keySelector, System.Func`2 elementSelector) <0xed0620b0 + 0x00027> in <filename unknown>:0 
 at LastfmScrobbler.Api.BaseLastfmApiClient.EscapeDictionary (System.Collections.Generic.Dictionary`2 dic) <0xed061f40 + 0x00143> in <filename unknown>:0 
 at LastfmScrobbler.Api.BaseLastfmApiClient+<Post>d__4`2[TRequest,TResponse].MoveNext () <0xed060428 + 0x00197> in <filename unknown>:0 
--- End of stack trace from previous location where exception was thrown ---
 at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0xf51fcfc0 + 0x00035> in <filename unknown>:0 
 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0xf51fbfd0 + 0x000b7> in <filename unknown>:0 
 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0xf51fbf40 + 0x00084> in <filename unknown>:0 
 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0xf51fbef0 + 0x0003f> in <filename unknown>:0 
 at System.Runtime.CompilerServices.TaskAwaiter`1[TResult].GetResult () <0xf51fc240 + 0x00024> in <filename unknown>:0 
 at LastfmScrobbler.Api.LastfmApiClient+<NowPlaying>d__3.MoveNext () <0xed05fa30 + 0x0044f> in <filename unknown>:0 

 

 

 

 

Unfortunately I'm unable to recreate the issue you're experiencing. Would you be happy to share the album / artist and filename of the track you are attempting to play so I can try to recreate the issue? After some research this morning (As I still know next to nothing about Last.fm) it appears that they have filters on names that can/can't be scrobbled, see here: http://www.last.fm/forum/21713/_/70366/1#f714635

Link to comment
Share on other sites

Since it's throwing ArgumentNullException, maybe some of the metadata fields you're using are null. I would just make sure to check them for null or empty before attempting to encode them into your request.

Link to comment
Share on other sites

haudankaivajasi

I've had a look at the log and it looks like it's falling over because it can't determine the file being played.

 

 

 

 

 

Unfortunately I'm unable to recreate the issue you're experiencing. Would you be happy to share the album / artist and filename of the track you are attempting to play so I can try to recreate the issue? After some research this morning (As I still know next to nothing about Last.fm) it appears that they have filters on names that can/can't be scrobbled, see here: http://www.last.fm/forum/21713/_/70366/1#f714635

Hey.

The logs are from a session where I played I See Stars - 3D -album, basically any song on it because I played the whole album that time.

 

But the on thing here is that I don't understand is that the favorite function works like a charm and it recognizes the right artist - song -pattern and then the scrobbling fails. That said either the metadata is ok or the scrobble function uses some other metadata than the favorite function :o

Edited by haudankaivajasi
Link to comment
Share on other sites

  • 3 weeks later...
haudankaivajasi

Hey.

There has been some progress regarding this issue! I played some new songs that I have added to my library and they seemed to scrobble just fine. After this I tried some older tracks and they didn't seem to scrobble at all. I refreshed my whole music library inside Emby and now all songs seem to be scrobbling! There seems to have been some kind of metadata problem with the tracks and the refresh seemed to fix this issue.

 

Thanks again for this neat addon!

Link to comment
Share on other sites

  • 4 weeks later...
  • 2 months later...
techmonaut

Hi, I've ran into a bit of a problem with the plugin, it doesn't wanna save the credentials, again, using the last uploaded version of the dll linked in the thread.

 

Anyone got an ideas?

2016-12-31 12:27:17.6941 Info HttpServer: HTTP GET http://10.10.10.11:8096/emby/Plugins/1f5e1261-1e09-4bed-8839-dc07afe096c2/Configuration. UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chro$
2016-12-31 12:27:17.6962 Info HttpServer: HTTP Response 200 to 10.10.10.14. Time: 2ms. http://10.10.10.11:8096/emby/Plugins/1f5e1261-1e09-4bed-8839-dc07afe096c2/Configuration
2016-12-31 12:27:17.7211 Info HttpServer: HTTP POST http://10.10.10.11:8096/emby/Lastfm/Login. UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36
2016-12-31 12:27:17.7214 Error HttpServer: Error processing request
        *** Error Report ***
        Version: 3.1.2.0
        Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server -ffmpeg /usr/bin/ffmpeg -ffprobe /usr/bin/ffprobe -restartpath /usr/lib/emby-server/restart.sh
        Operating system: Unix 4.4.0.57
        64-Bit OS: True
        64-Bit Process: True
        Mono: 4.6.2 (Stable 4.6.2.7/08fd525 Mon Nov 28 20:49:26 UTC 2016)
        Processor count: 2
        Program data path: /var/lib/emby-server
        Application directory: /usr/lib/emby-server/bin
        System.IO.FileNotFoundException: Unable to find the specified file.
        System.IO.FileNotFoundException
        No Stack Trace Available

2016-12-31 12:27:17.7214 Info HttpServer: HTTP Response 404 to 10.10.10.14. Time: 1ms. http://10.10.10.11:8096/emby/Lastfm/Login

Link to comment
Share on other sites

Bernie V

 

Hi, I've ran into a bit of a problem with the plugin, it doesn't wanna save the credentials, again, using the last uploaded version of the dll linked in the thread.

 

Anyone got an ideas?

2016-12-31 12:27:17.6941 Info HttpServer: HTTP GET http://10.10.10.11:8096/emby/Plugins/1f5e1261-1e09-4bed-8839-dc07afe096c2/Configuration. UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chro$
2016-12-31 12:27:17.6962 Info HttpServer: HTTP Response 200 to 10.10.10.14. Time: 2ms. http://10.10.10.11:8096/emby/Plugins/1f5e1261-1e09-4bed-8839-dc07afe096c2/Configuration
2016-12-31 12:27:17.7211 Info HttpServer: HTTP POST http://10.10.10.11:8096/emby/Lastfm/Login. UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36
2016-12-31 12:27:17.7214 Error HttpServer: Error processing request
        *** Error Report ***
        Version: 3.1.2.0
        Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server -ffmpeg /usr/bin/ffmpeg -ffprobe /usr/bin/ffprobe -restartpath /usr/lib/emby-server/restart.sh
        Operating system: Unix 4.4.0.57
        64-Bit OS: True
        64-Bit Process: True
        Mono: 4.6.2 (Stable 4.6.2.7/08fd525 Mon Nov 28 20:49:26 UTC 2016)
        Processor count: 2
        Program data path: /var/lib/emby-server
        Application directory: /usr/lib/emby-server/bin
        System.IO.FileNotFoundException: Unable to find the specified file.
        System.IO.FileNotFoundException
        No Stack Trace Available

2016-12-31 12:27:17.7214 Info HttpServer: HTTP Response 404 to 10.10.10.14. Time: 1ms. http://10.10.10.11:8096/emby/Lastfm/Login

 

I'm having also this issue :-(

Link to comment
Share on other sites

Bernie V

Does someone have an example of the lastfm-scrobbler.xml file in the /var/lib/emby-server/plugins/configurations folder?

Link to comment
Share on other sites

  • 5 months later...
  • 4 weeks later...
MrSmoke

Hey guys,

 

Yeah sorry about that. Some shit went down when i was looking into it last year and I completely forgot about it. Since then I started working on it to fix it up however the LastFM API (the worst api i've ever used) decided to remove the authentication method I was using without warning. I've implemented the OAuth login flow which is easy enough but getting the callback working in Emby is a bit of a pain as there are no redirect methods in the emby core so I need to figure out how to get that working. Aside from that everything else works (excluding the scheduled task sync but who even used that anyway?)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...