Jump to content


Photo

Emby + Domain Name?

URL Domain IP

  • Please log in to reply
50 replies to this topic

#41 pir8radio OFFLINE  

pir8radio

    NGINX

  • Members
  • 2926 posts
  • Local time: 10:58 AM
  • LocationChicago

Posted 24 August 2017 - 11:27 AM

Heya everyone!

 

So this thread has been super helpful thus far - I think I'm at the very end of figuring this out. Basically I've done the following things:

 

1) Registered a domain

2) Changed the A record to point to my IP

3) Changed the CNAME record to point to my URL

4) Changed my http port numbers to 80 in Emby

5) Changed my https port numbers to 443 in Emby

6) Forwarded those ports in my NAT for Emby's internal IP

 

My DNS is still propagating through the aether so that isn't working yet, but when I attempt to hit my server via IP the connection is timing out. In fact it appears to start loading Emby (the black background loads in) before I get the error.

 

Any ideas where I might be screwing up? My ISP does not block port 80 for what it's worth.

 

Thanks for the PM.....  I tried your domain name and it points to your IP correctly... I get a 404 error which only a web server can send me.. Which leads me to believe either your ISP is sending me that as a form of blocking, or you have something on the emby pc running on port 80 already.    Try changing emby back to the default ports, and then open those ports in your NAT     then try again connecting to   yourdomain.com:8096    see if that works, let me know if it does, I can try it as well remotely.. 



#42 NYD3030 OFFLINE  

NYD3030

    Newbie

  • Members
  • 8 posts
  • Local time: 11:58 AM

Posted 24 August 2017 - 11:55 AM

Thanks for the PM.....  I tried your domain name and it points to your IP correctly... I get a 404 error which only a web server can send me.. Which leads me to believe either your ISP is sending me that as a form of blocking, or you have something on the emby pc running on port 80 already.    Try changing emby back to the default ports, and then open those ports in your NAT     then try again connecting to   yourdomain.com:8096    see if that works, let me know if it does, I can try it as well remotely.. 

 

Alright, that appears to have worked from outside my network (tried it on a mobile hotspot). Obviously port 80 isn't playing nice. Thanks for the help so far! Two things to work out at this point:

 

1) Inside my network I can't use the domain name or IP to connect to emby. I believe onhub might be the problem here.

2) Ideally I'd like to not have to plug in the port after the domain name - what do I need to do to configure this?



#43 pir8radio OFFLINE  

pir8radio

    NGINX

  • Members
  • 2926 posts
  • Local time: 10:58 AM
  • LocationChicago

Posted 24 August 2017 - 12:16 PM

Alright, that appears to have worked from outside my network (tried it on a mobile hotspot). Obviously port 80 isn't playing nice. Thanks for the help so far! Two things to work out at this point:

 

1) Inside my network I can't use the domain name or IP to connect to emby. I believe onhub might be the problem here.

2) Ideally I'd like to not have to plug in the port after the domain name - what do I need to do to configure this?

 

1.) Yes onhub is probably the issue, look for an option to "allow loop-back connections" or something similar, enable it. https://support.goog...03#nat-loopback

 

2.) Well, the only way to not have to enter the ports with a domain name is to use 80 for regular http and 443 for https.  which are browser default ports.  You might have to make sure they are not blocking it..    If you go on your emby server and go to http://127.0.0.1 do you get anything?  timeout? 404 error?


Edited by pir8radio, 24 August 2017 - 12:20 PM.


#44 BAlGaInTl OFFLINE  

BAlGaInTl

    Advanced Member

  • Members
  • 703 posts
  • Local time: 11:58 AM

Posted 24 August 2017 - 01:00 PM

1.) Yes onhub is probably the issue, look for an option to "allow loop-back connections" or something similar, enable it. https://support.goog...03#nat-loopback

 

2.) Well, the only way to not have to enter the ports with a domain name is to use 80 for regular http and 443 for https.  which are browser default ports.  You might have to make sure they are not blocking it..    If you go on your emby server and go to http://127.0.0.1 do you get anything?  timeout? 404 error?

 

Couldn't you also achieve the desired result with a reverse proxy?  I would like to set that up in the future.

 

According to that link... Google says NAT loop-back should just work... Unless I'm reading it wrong.  There is no separate setting with the Google WiFi App.

 


NAT loopback lets devices on your private Wi-Fi (like a laptop or IP camera) communicate with a public network (WAN). This lets them “share” a connection with each other. This means you’ll be able to see your port forwarded devices from inside your home Wi-Fi.

To use NAT Loopback, just set the appropriate port forwarding rules for the desired device and you’re all set.

 

I'll try this with mine when I get home to see if I can get it to work.



#45 NYD3030 OFFLINE  

NYD3030

    Newbie

  • Members
  • 8 posts
  • Local time: 11:58 AM

Posted 24 August 2017 - 01:51 PM

1.) Yes onhub is probably the issue, look for an option to "allow loop-back connections" or something similar, enable it. https://support.goog...03#nat-loopback

 

2.) Well, the only way to not have to enter the ports with a domain name is to use 80 for regular http and 443 for https.  which are browser default ports.  You might have to make sure they are not blocking it..    If you go on your emby server and go to http://127.0.0.1 do you get anything?  timeout? 404 error?

 

1) I'll mess around with it and see what I can find. I can always just use the local IP to connect in my network, no big deal really.

2) 127.0.0.1 gives an 'ERR_CONNECTION_REFUSED'. 



#46 pir8radio OFFLINE  

pir8radio

    NGINX

  • Members
  • 2926 posts
  • Local time: 10:58 AM
  • LocationChicago

Posted 24 August 2017 - 02:03 PM

1) I'll mess around with it and see what I can find. I can always just use the local IP to connect in my network, no big deal really.

2) 127.0.0.1 gives an 'ERR_CONNECTION_REFUSED'. 

 

Err connection refused, is what i would expect if you were not running anything else on port 80..  Looks like it might be your ISP blocking HTTP, yet the port seems open.. Strange way to block its usage, i guess so they can say they don't block any ports?


  • NYD3030 likes this

#47 pir8radio OFFLINE  

pir8radio

    NGINX

  • Members
  • 2926 posts
  • Local time: 10:58 AM
  • LocationChicago

Posted 24 August 2017 - 02:05 PM

Couldn't you also achieve the desired result with a reverse proxy?  I would like to set that up in the future.

 

Not with port 80 blocked...   nginx/reverse proxy would still need to listen on port 80, but its being hosed on the ISP side.  I bet a call to them can get it freed up..   Just as long as you are opening it for a legitimate reason, like some family photo sharing application, called emby, I would avoid the usage of the word "server".  ;)


Edited by pir8radio, 24 August 2017 - 02:06 PM.

  • David Martin likes this

#48 BAlGaInTl OFFLINE  

BAlGaInTl

    Advanced Member

  • Members
  • 703 posts
  • Local time: 11:58 AM

Posted 24 August 2017 - 07:41 PM

I confirmed that the OnHub seems to handle the NAT loop-back just fine.

 

I changed my port and everything just worked locally and remotely.


  • Tur0k likes this

#49 NYD3030 OFFLINE  

NYD3030

    Newbie

  • Members
  • 8 posts
  • Local time: 11:58 AM

Posted 28 August 2017 - 10:28 PM

I confirmed that the OnHub seems to handle the NAT loop-back just fine.

 

I changed my port and everything just worked locally and remotely.

I'm obviously doing something wrong - how did you set the port to enable loop-back? I've tried simply forwarding the port like normal with no luck.



#50 NYD3030 OFFLINE  

NYD3030

    Newbie

  • Members
  • 8 posts
  • Local time: 11:58 AM

Posted 28 August 2017 - 10:30 PM

Not with port 80 blocked...   nginx/reverse proxy would still need to listen on port 80, but its being hosed on the ISP side.  I bet a call to them can get it freed up..   Just as long as you are opening it for a legitimate reason, like some family photo sharing application, called emby, I would avoid the usage of the word "server".  ;)

I did find some evidence on the interwebs that charter does block port 80 traffic initiated outside your network and just says 'we don't block port 80' because they don't block it entirely.



#51 BAlGaInTl OFFLINE  

BAlGaInTl

    Advanced Member

  • Members
  • 703 posts
  • Local time: 11:58 AM

Posted 28 August 2017 - 10:32 PM

I'm obviously doing something wrong - how did you set the port to enable loop-back? I've tried simply forwarding the port like normal with no luck.

 

I didn't do anything.  As I said... it just worked internal and external when I forwarded port 80.

 

As @pir8radio said... it seems your ISP may be intercepting port 80.  You could try with something like port 8888 and see if it works internal and external.







Also tagged with one or more of these keywords: URL, Domain, IP

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users