Jump to content

Full auto or full manual updating


Recommended Posts

With the default settings in MB Classic/MB Server I'm often interrupted to update either the server or the client and/or to perform restarts. I have MB Server running as a service. I would like to know: is it possible to fully automate all updates to occur at a scheduled time (like 3AM), that requires no day to day intervention? If not, how do I disable the existing semi-automatic updating and then manually update?

 

Link to post
Share on other sites

What do I need to do to disable the automatic updating? I assume after that I would just invoke updates from the Dashboard. Is the same true of MB Classic?

 

Is there any specific advantage to running MB Server as a service, other than maintaining the service through logins/logouts? I'm running client and server on the same machine, so I suspect it might be simpler to not run as a service and take advantage of completely automatic updates.

Link to post
Share on other sites

Done. Do I now need to change the "Check for application updates" task to run at a scheduled time instead of the default (On application startup + Every 24 hours)?

Link to post
Share on other sites

The updates occur automatically but it will wait for you to restart the server in order to apply them. kind of like how chrome updates.

Link to post
Share on other sites

Aaah, okay thanks. I installed the restart plug-in, and I assume the Scheduled Server Restart task item is a result of that. I think I should be fully automatic now.

 

One semi-bug I noticed: Earlier I deleted the default triggers in the Check for application updates task. I attempted to put those back; however, the default interval was 24 hours, but for a new interval trigger the maximum selectable value is 12 hours. 24 hours should probably be there, but ideally I think it should give 1-7 day, 1-N week options as well.

 

Thanks again for your help.

Link to post
Share on other sites

Ha, good point. Just noticed that in the UI. I was just confused because the default trigger was "every 24 hours", and there doesn't appear to be a way to recreate that in the UI. Not an issue, though.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...