Jump to content

No Program Data Available


Go to solution Solved by theniteow1,

Recommended Posts

I noticed in the last couple of weeks all the sudden my OTA channels here in Denver, all so No Program Data Available.  The regular cable channels I get through my provider all have guide information just fine, but most of the OTA guide information is missing?  Is anybody else experiencing this?  I've tried initiating a download of the guide information several times, and always end up with the same results.  Thanks!

Link to comment
Share on other sites

  • Solution

Folks, in case you come across this, I was able to resolve the issue.  Basically, it comes down to Microsoft switching providers for their EPG guide.  It used to be Zap2It, and now it is Rovi.  Rovi has some gaps in their data collection of channels, especially with OTA.  More information on this issue is located here:




In short, if you encounter this problem, this is what you will need to do the fix the issue:


1. Open a Command Prompt as Administrator. It should open in C:\Windows\System32.
2. Change directory to C:\Windows\System32\Drivers\etc.
3. Type notepad hosts. Notepad should open the HOSTS file as an administrator.
4. Type the following at the bottom of the file: data.tvdownload.microsoft.com cdn.epg.tvdownload.microsoft.com
5. Save and close notepad.
6. Back in the command prompt type ipconfig /flushdns.
7. Ensure that you close Windows Media Center, disconnect any extenders if you have them.
8. Open Task Scheduler by going Control Panel > System and Security > Administrative Tools > Schedule Tasks.
9. In the left tree expand Task Scheduler Library > Microsoft > Windows > Media Center.
10. In the right pane under name, right-click ObjectStoreRecoveryTask, and click Run (let it run for 2 mins)
11. Close Task Scheduler.
12. Launch Windows Media Center.  You may get the error that their is missing guide information, and it needs to download, go ahead and click Ok.
13. Your guide should start populating.  Sometimes it takes a while so be patient.
WARNING, when I did this it broke my other guides that are not OTA.  I'm not sure if this will happen to you.  If it does I corrected it by quoting out at the IP Addresses in the HOST file with a #, and re-running the ObjectStoreRecoveryTask.  Then all my guide data downloaded properly.  Good luck!
Edited by theniteow1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...