Jump to content


Photo

Emby not workin on DLNA device

freenas dnla video formats

  • Please log in to reply
81 replies to this topic

#41 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124352 posts
  • Local time: 06:21 PM

Posted 30 December 2018 - 09:16 PM

You need to install Emby Server. The instructions are in the quick start guide I've provided to you already. Thanks.



#42 DenysR OFFLINE  

DenysR

    Member

  • Members
  • 13 posts

Posted 30 December 2018 - 09:20 PM

Can u send the link once again
Im learning
Regards

#43 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124352 posts
  • Local time: 06:21 PM

Posted 30 December 2018 - 09:29 PM

https://github.com/M...iki/Quick-start



#44 JAAlperin OFFLINE  

JAAlperin

    Advanced Member

  • Members
  • 38 posts
  • Local time: 11:21 PM

Posted 03 January 2019 - 05:41 PM

I installed the 3.5 emby server plugin for FreeNAS.  My Oppo BDP-93 sees it and browses it just fine.

 

It appears that the problem I previously described is related to 3.6.



#45 DenysR OFFLINE  

DenysR

    Member

  • Members
  • 13 posts

Posted 03 January 2019 - 08:25 PM

Can anybody invite to their server
By email

#46 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124352 posts
  • Local time: 06:21 PM

Posted 03 January 2019 - 11:06 PM

I installed the 3.5 emby server plugin for FreeNAS.  My Oppo BDP-93 sees it and browses it just fine.

 

It appears that the problem I previously described is related to 3.6.

 

That's interesting, thanks for the info.



#47 JAAlperin OFFLINE  

JAAlperin

    Advanced Member

  • Members
  • 38 posts
  • Local time: 11:21 PM

Posted 05 January 2019 - 12:13 PM

But, still no love.  3.5.3.0 works OK for Oppo BDP-93 and WD TV Live.  However the Emby app on Roku crashes.  Log shows:

 

2019-01-05 10:49:02.804 Error App: Error in ffprobe
    *** Error Report ***
    Version: 3.5.3.0
    Command line: /usr/local/opt/emby-server/system/EmbyServer.exe -os freebsd -ffmpeg /usr/local/opt/emby-server/bin/ffmpeg -ffprobe /usr/local/opt/emby-server/bin/ffprobe -programdata /var/db/emby-server -updatepackage emby-server-freebsd_{version}_amd64.txz
    Operating system: Unix 11.2.0.0
    64-Bit OS: True
    64-Bit Process: True
    User Interactive: False
    Mono: 5.10.1.57 (5.10.1.57 Thu Dec 20 09:44:11 UTC 2018)
    Processor count: 8
    Program data path: /var/db/emby-server
    Application directory: /usr/local/opt/emby-server/system
    System.Exception: ffprobe failed for file:"/tv/Active/Corner Gas/Season 4/Corner Gas s04e14.mkv" - streams and format are both null.

 

I assume this was due to the known ffmpeg problems with 3.5.0.3.  I tried to upgrade ffmpeg per gbarone123, but 11.1 is not supported and I keep getting errors in the make build process.

 

So, Looks like I'll have to run two Emby servers - one for me (and my Oppo) and one for my remote Roku friends and family.  Not the end of the world, but inelegant.  Probably have to remove all metadata and non-media files from libraries, and tell servers to keep that stuff separate.

 

Any chance 3.6 will support Oppo BD-93 in near future (before I make changes)?  I there another server version I could try?


Edited by JAAlperin, 05 January 2019 - 12:15 PM.


#48 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124352 posts
  • Local time: 06:21 PM

Posted 07 January 2019 - 02:59 PM

We are still looking into it. I  just have not been able to reproduce this yet on my test devices. Thanks.



#49 JAAlperin OFFLINE  

JAAlperin

    Advanced Member

  • Members
  • 38 posts
  • Local time: 11:21 PM

Posted 11 January 2019 - 12:29 AM

Had been running 3.5.3, but it suddenly stopped communicating with Oppo BDP-93.  Restarted Emby, no go.  Restarted Oppo, no go.  Multiple times, no go.

 

Back to using the old FreeNAS 11 plugin for Emby 3.3.1.0.



#50 JAAlperin OFFLINE  

JAAlperin

    Advanced Member

  • Members
  • 38 posts
  • Local time: 11:21 PM

Posted 14 January 2019 - 12:12 PM

Continuing search for an Emby server to run on FreeNAS that will work with Oppo BDP-93 locally and Roku remotely.

 

Installed 4.0.0.1.  Installed Emby backup plugin 1.3.3.  Restored last night's backup (by 1.2.3 plugin on 3.3.1 server).  All libraries show twice on Home screen and in metadata manager.  Can't fix.

 

DLNA server is not seen at all by Oppo even with Client Discovery and Blast Alive both set to 10 seconds.



#51 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124352 posts
  • Local time: 06:21 PM

Posted 14 January 2019 - 01:25 PM

Thanks for the info.



#52 dack64 OFFLINE  

dack64

    Newbie

  • Members
  • 2 posts

Posted 17 January 2019 - 09:09 AM

After the last update (4.0.2), the LG TV(Netcast) does not detect the DLNA server. It only helps to turn off and turn on the DLNA server, after turning off the TV, everything repeats.



#53 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124352 posts
  • Local time: 06:21 PM

Posted 17 January 2019 - 01:28 PM

After the last update (4.0.2), the LG TV(Netcast) does not detect the DLNA server. It only helps to turn off and turn on the DLNA server, after turning off the TV, everything repeats.

 

Hi there @dack64, can you please attach the emby server log? thanks.



#54 guyp2k OFFLINE  

guyp2k

    Newbie

  • Members
  • 4 posts
  • Local time: 04:21 PM

Posted 17 January 2019 - 08:50 PM

I assume my issue running Roon and Emby on the same box/QNAP is not going to be addressed until .net core 3.0?

 

https://community.ro...p-1900/58299/10



#55 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124352 posts
  • Local time: 06:21 PM

Posted 18 January 2019 - 01:04 AM

I assume my issue running Roon and Emby on the same box/QNAP is not going to be addressed until .net core 3.0?

 

https://community.ro...p-1900/58299/10

 

That's correct, please see here for technical explanation:

 

https://emby.media/c...e-2#entry670391

 

You CAN still use Dlna with Emby Server in the meantime, but it will require you to shutdown all other dlna software on the server machine.



#56 dack64 OFFLINE  

dack64

    Newbie

  • Members
  • 2 posts

Posted 20 January 2019 - 08:30 AM

Hi there @dack64, can you please attach the emby server log? thanks.

20.01.2019 - 19:22 il restart dlna, after that LG TV discover it.



#57 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124352 posts
  • Local time: 06:21 PM

Posted 20 January 2019 - 12:32 PM

Thanks for the feedback.



#58 JAAlperin OFFLINE  

JAAlperin

    Advanced Member

  • Members
  • 38 posts
  • Local time: 11:21 PM

Posted 22 January 2019 - 12:29 AM

Still desperately seeking a version of Emby server that will work with all my devices.  Please see prior posts in this topic for past efforts and results.

 

Thought I had a good thing going with 3.5.2 on DietPi.  It worked properly with my Oppo, my WD TV Live, and my various Rokus.  But, the Emby server kept quitting, and I have not been able to pin down the cause.

 

So, back to FreeNAS.  Installed 4.1.0.1.  All devices are working, but regardless of which TV episode I select, the Oppo will play the first episode of that season.  Happens for all TV shows, only on Oppo BDP-93.  Browser, Rokus, WD TV all play properly.  No problems yet found with movies.

 

So, watched TV series tonight using 3.3.1.

 

Both FreeNAS and Emby used to be rock solid, but recent releases of both are giving me fits.



#59 JAAlperin OFFLINE  

JAAlperin

    Advanced Member

  • Members
  • 38 posts
  • Local time: 11:21 PM

Posted 22 January 2019 - 09:59 AM

Reported above that Oppo BDP-93 requests episode 4 from 4.1.0.1, but gets/plays episode 1.  Makes no difference what TV show or season, Oppo always gets the first episode of the season.  Other devices do not show this problem.  Log attached. Please see 2019-01-22 08:34:44.048 and following.

Attached Files


Edited by JAAlperin, 22 January 2019 - 10:00 AM.


#60 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124352 posts
  • Local time: 06:21 PM

Posted 22 January 2019 - 12:52 PM

I'll have to get an oppo in order to test this personally.





Also tagged with one or more of these keywords: freenas, dnla, video formats

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users