Jump to content

Unable to install Add-on from repository


xtherebellion
 Share

Recommended Posts

xtherebellion

Hey guys,

 

I'm new here (obviously lol), but I am also very new to Kodi (never had XBMC before), I picked up an Android TV box (M8S) and at first it seemed good. But to be honest, the reviews online are misleading.. the box isn't as fast and responsive as the videos (but that's a whole other problem).

 

The problem:

 

So, out of the box it came with Kodi Isengard (15.2), I had downloaded the zip file for Emby from https://emby.media/downloads/emby-for-kodi/ (version, 1.0.2)

 

I installed from the zip-file, and now I get the "Kodi for emby add-on enabled", I then go into "Install from repository" as the old "Get add-ons" has been changed to this *Doesn't mention this in Emby installation guide, maybe I'm missing something.

 

 

Every time I click this add-on, it sort of refreshes the menu (The Kodi Emby add-on, becomes the top item on the list) but nothing - no messages saying anything has been added, nor errors. I've searched through "All add-ons", can't find anything. If I click the option on the Kodi Emby addon, it gives me some information with only 2 enabled options, -Uninstall, -Disable.

 

 

I've tried googling my problem, and most I've come up with is post installation errors. I've done a clean install of Kodi (uninstalling it, and installing from the kodi download file, afterwards installing "Beast Wizard by ChrisB"

 

Any help is appreciated, again pardon my inexperience in all of this. Thank you!

Link to comment
Share on other sites

Angelblue05

What you installed is the Stable emby for Kodi add-on repository (it contains actual add-ons available to install). You then need to go to Install from repository > Kodi Emby Add-ons > Video add-ons > Install Emby.

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites

xtherebellion

What you installed is the Stable emby for Kodi add-on repository (it contains actual add-ons available to install). You then need to go to Install from repository > Kodi Emby Add-ons > Video add-ons > Install Emby.

 

" Kodi Emby Add-ons > Video add-ons > Install Emby." this seems to be the part that isn't working for me.

 

Once I click "Kodi Emby add-ons" from within the Install from repository directory, nothing happens.

Link to comment
Share on other sites

Angelblue05

Ok, can you enable Kodi debug? Settings > system > debugging (if you don't see it, check the setting level, make sure it's set as advanced or higher) Then try to open Kodi Emby add-ons. To grab the log, check here: http://emby.media/community/index.php?/topic/17599-how-to-report-a-problem/

 

Normally, it should open the listing when you open Kodi Emby add-ons, but if nothing happens, that's not normal.

  • Like 1
Link to comment
Share on other sites

xtherebellion

Ok, can you enable Kodi debug? Settings > system > debugging (if you don't see it, check the setting level, make sure it's set as advanced or higher) Then try to open Kodi Emby add-ons. To grab the log, check here: http://emby.media/community/index.php?/topic/17599-how-to-report-a-problem/

 

Normally, it should open the listing when you open Kodi Emby add-ons, but if nothing happens, that's not normal.

http://xbmclogs.com/pupmcuqsn#line-195

 

This is the link for my log file. I see some emby related messages around that line number. Unsure what to make of any of it though.

 

I appreciate your help

Link to comment
Share on other sites

xtherebellion

Remove this line: <cachemembuffersize>1739587584</cachemembuffersize>

from your advancedsettings.xml to see if it fixes the issue.

 

http://forum.kodi.tv/showthread.php?tid=228643

So this sort of fixed my problem. The advancedsettings.xml was not there. I created it and made the value 52428800 which is a lot less. Where the default should have been 20mb it somehow was such a high number. Odd, but thank you for your help. It is working now

  • Like 1
Link to comment
Share on other sites

  • 4 weeks later...

Hello, newbie here.

 

I am having the same issue and I cant seem to fix it.  I've tried to install the add-in from 3 different machines, Win 10, Win 8 and Win 7.  All were base 15.2 fresh installs, and I tried both 1.0.2 and 1.0.4.  I tried adding in the XML settings as above but no dice.

 

Logs have been uploaded per the instructions.  ID: p7w0admny

 

Thank you,

 

SGF

Link to comment
Share on other sites

jpaytoncfd

I was having this issue with my odroid. My solution was to check for updates before and after installing the repository. If I did not do it first I think it cached a dependency error and ignored emby. Then since nothing actually changed it would never fully check the emby plugin for compatability again. 

 

Where you have already installed, uninstall the REPO and delete your addons DB file. (.kodi/userdata/Database/addons*.db.), restart the device and from the settings>addons menu press the left arrow and select Check For Updates, Now install the repo and check for updates again. You should now be able to go to settings>addons>Install From Repo>Emby for Kodi Repo>Video Addons>Emby>INSTALL!

 

You might be able to skip deleting the database file, I have not tried yet. There may be delays too. I had to update after installing twice before anything showed. On my second Odroid I updated before installing the repo and after and it was right there and installed with no issues.  

Link to comment
Share on other sites

Angelblue05

Wow, the addon system for Kodi sure is complex. ;) Thanks for posting, I'll refer people to your post, if they have this issue.

 

The dependencies are in the beta repository. I don't know why it would flag them as missing...

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

Hi There - thanks for the post, but it is still not working.

 

Tried to uninstall the repo, delete DB, restart, check for updates (2 or 3 times), install Emby addons, check for updates (2 or 3 times).  No dice.

 

Also tried it starting from a fresh install of Kodi adding in the check for updates steps.  Not working either.

Link to comment
Share on other sites

Angelblue05

If you are using isengard, enable the Kodi debug again. Go into the Emby add-ons repository (stable) - then open the side menu, make sure hide incompatible is unchecked. Does that make the add-on appear? If so, try to install it (it will fail) and post your Kodi log once more. Thanks

Link to comment
Share on other sites

jpaytoncfd

Hi There - thanks for the post, but it is still not working.

 

Tried to uninstall the repo, delete DB, restart, check for updates (2 or 3 times), install Emby addons, check for updates (2 or 3 times).  No dice.

 

Also tried it starting from a fresh install of Kodi adding in the check for updates steps.  Not working either.

 

I just want to confirm that you know the zip you are installing is the emby repository. Not the addon. You install the repo from a zip, then browse to the video section of the repository and select the emby addon. I only mention this because you said "install Emby addons" If you ment repo, and are not seeing the addons in the repo, just ignore me :)

Link to comment
Share on other sites

Hide Foreign and Hide incompatible are both grayed out and cannot be selected.

 

To be clear, I cannot select or browse into the Kodi Emby Addons repository after I install the repository.  I did upload the logs, but here are the first error lines in it:

 

16:59:24 T:7640   ERROR: CCurlFile::FillBuffer - Failed: Timeout was reached(28)
16:59:24 T:7640  NOTICE: CCurlFile::FillBuffer - Reconnect, (re)try 1
16:59:24 T:7640   ERROR: CCurlFile::FillBuffer - Failed: HTTP returned error 416
16:59:24 T:7640    INFO: CFileCache::Process - Hit eof.
16:59:24 T:7640   DEBUG: Thread FileCache 7640 terminating
16:59:24 T:6596   ERROR: Failed to read directory listing http://www.mb3admin.com/downloads/addons/xbmb3c/kodi-repo/addons.xmlfor repository repository.emby.kodi.
 

I did attempt to increase the timeout in the advancedsettings.xml but it had no effect.

Link to comment
Share on other sites

jpaytoncfd

Hide Foreign and Hide incompatible are both grayed out and cannot be selected.

 

To be clear, I cannot select or browse into the Kodi Emby Addons repository after I install the repository.  I did upload the logs, but here are the first error lines in it:

 

I did attempt to increase the timeout in the advancedsettings.xml but it had no effect.

 

Can you load the repo in your web browser on the clients? http://www.mb3admin.com/downloads/addons/xbmb3c/kodi-repo/addons.xml. The HTTP 416 error is a very odd one. Since all your clients are having it I would look at your network and firewall. Do you use a VPN or Proxy?

  • Like 3
Link to comment
Share on other sites

Hey thanks for the post.  It got me thinking about some of the content restrictions I had on my Meraki gateway.  Turns out one of the content filters was not allowing the installation to proceed.  Once I disabled all of the filters it worked.

 

Thanks everyone for the assistance!

 

sgf

  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...