Jump to content

Sync Error on Emby for Kodi 1.1.61 (latest beta)


walking_carpet
 Share

Go to solution Solved by Angelblue05,

Recommended Posts

walking_carpet

Hi,

 

First, thanks for making this product. 

 

I'm getting the following sync error on the new beta

05:48:43 T:140333610424064  NOTICE: EMBY UserClient -> |---- Starting UserClient ----|
05:48:43 T:140333610424064   ERROR: Exception in thread Thread-5:
                                            Traceback (most recent call last):
                                              File "/home/stephan/projects/openelec-6.0/build.OpenELEC-Generic.x86_64-6.0.0/Python-2.7.3/.install_pkg/usr/lib/python2.7/threading.py", line 551, in __bootstrap_inner
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/UserClient.py", line 430, in run
                                                self.authenticate()
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/UserClient.py", line 303, in authenticate
                                                result = self.loadCurrUser()
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/UserClient.py", line 272, in loadCurrUser
                                                self.hasAccess()
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/UserClient.py", line 216, in hasAccess
                                                result = self.doUtils.downloadUrl(url)
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/DownloadUtils.py", line 206, in downloadUrl
                                                url = url.replace("{UserId}", self.userId, 1)
                                            TypeError: expected a character buffer object

When you try a subsequent manual sync, the following error occurs:

05:48:54 T:140333627209472  NOTICE: Thread LanguageInvoker start, auto delete: false
05:48:54 T:140335142823808   ERROR: Control 550 in window 10025 has been asked to focus, but it can't
05:48:54 T:140333627209472  NOTICE: -->Python Interpreter Initialized<--
05:48:55 T:140333627209472  NOTICE: plugin.video.emby started
05:48:55 T:140333627209472  NOTICE: Parameter string:
05:48:55 T:140333627209472  NOTICE: plugin.video.emby stopped
05:48:55 T:140333870466816  NOTICE: Thread BackgroundLoader start, auto delete: false
05:48:58 T:140333627209472  NOTICE: Thread LanguageInvoker start, auto delete: false
05:48:58 T:140333627209472  NOTICE: -->Python Interpreter Initialized<--
05:48:58 T:140333627209472  NOTICE: plugin.video.emby started
05:48:58 T:140333627209472  NOTICE: Parameter string: ?mode=manualsync
05:48:59 T:140333627209472  NOTICE: EMBY LibrarySync -> Sync Database, Incremental Sync Using Server Time: 2015-11-30T21:48:59Z
05:48:59 T:140333627209472  NOTICE: EMBY LibrarySync -> Sync Database, Incremental Sync Using Server Time -5 min: 2015-11-30T21:43:59Z
05:48:59 T:140333627209472  NOTICE: EMBY LibrarySync -> Sync Database, Incremental Sync Setting Last Run Time Saved: 2015-11-30T21:43:59Z
05:48:59 T:140333627209472  NOTICE: Sync DB -> syncDatabase Exiting
05:48:59 T:140333627209472  NOTICE: plugin.video.emby stopped
05:48:59 T:140333627209472 WARNING: CPythonInvoker(6, /storage/.kodi/addons/plugin.video.emby/default.py): the python script "/storage/.kodi/addons/plugin.video.emby/default.py" has left several classes in memory that we couldn't clean up. The classes include: N9XBMCAddon9xbmcaddon5AddonE,N9XBMCAddon7xbmcgui6WindowE,N14PythonBindings31XBMCAddon_xbmc_Monitor_DirectorE
05:48:59 T:140335142823808   ERROR: GetDirectory - Error getting plugin://plugin.video.emby/?mode=manualsync
05:48:59 T:140335142823808   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.emby/?mode=manualsync) failed

My setup is:

- OpenElec 6.0.0 on Asus Chromebox

- Emby v3.0.5780.36522 on Ubuntu 15.10 'Wily'

- Emby for Kodi v1.1.61

 

Hope this helps.

 

Cheers

 

 

Link to comment
Share on other sites

  • Solution
Angelblue05

Almost makes it seem like 1. The plugin folder somehow got corrupted. Or 2. Your add-on setting files got corrupted.

 

Can you try to reinstall the add-on and re-set your add-on settings to see if that fixes your problem? No need to reset your library, just uninstall the add-on and reinstall it.

 

Let me know if the error persists.

 

 

Sent from my iPhone using Tapatalk

  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...