Jump to content
fc7

ANSWERED Multi-disc music albums problem

Recommended Posts

fc7

In my music library, multi-disc albums are not detected correctly.

Meaning that all the songs from both discs are showed under the same disc so on the same album I end up with two tracks number 1, two tracks number 2, etc, as you can see in the attached screenshot.

Moreover, even when each disc folder has the correct artwork files, Emby is not showing any artwork at all.

 

56278cb3257f0_webclient.jpg

 

I'm running Emby server 3.0.5724.6 (latest stable version) on CentOS 7.

I double checked that I'm following the correct naming guidance from Emby's website (example folder organization attached in a screenshot).

 

56278cd92fde8_folder_struc_1.jpg

 

56278cf54428b_folder_struc_2.jpg

 

I can upload a library scanning log if needed but I didn't see any errors at all.

 

Thanks.

Share this post


Link to post
Share on other sites
Luke

make sure the files are tagged with the disc number

  • Like 1

Share this post


Link to post
Share on other sites
fc7

That will be the most probable cause.

I will check and come back.

 

Thanks a lot Luke.

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
fc7

Confirmed. The problem was the missing "Discnumber" tag.

After adding it now the songs are grouped correctly.

I'm still having problems with the album name and the artwork (still missing but the artwork is present in each disc subfolder) that I will check that later.

 

@Luke: maybe you want to add to the wiki in Emby site that for multi-disc albums having the songs tagged with the proper discnumber tag is a must in order for Emby to add them to the library correctly since this tag doesn't seem to be a well known one. This can prevent further questions like this in the future. :)

 

Thanks.

Edited by fc7

Share this post


Link to post
Share on other sites
fc7

Is it normal that after adding the discnumber tag and refreshing the album now the album name is equal to the string in the album tag of the first CD in a multi-disc set?

 

Using the same example as in the picture above, I would expect that after refresh the album name will be just "The Lamb Lies Down on Broadway" and include both discs.

But in reality the album name is "The Lamb Lies Down on Broadway Disc 1" and includes both discs.

 

I can see the same happening with several other multi-disc albums that I have in my library and that I added the discnumber tab to them. They are correctly grouped under the same album but the album name is equal to the first CD in the set and not just the album name. :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...