Jump to content

Playback Error on Android App

Recommended Posts



i am new with Emby and i got a huge problem with the android app, using a DynDns with HTTPs.


Each time i will play a video or something, i get the Message "Playback Error" - There was an error processing the request. Please try again later.


I tested much, it seems to be the HTTPs encryption without a signed .pfx file.


Can that be the problem?


I tried using my VPN or http by port 8096, in this cases the same video was played by the app.


Then i tried to create own .pfx file by openssl, but that didn´t worked so....


Webclient is working with https, only android app got the problem.


Hope someone can help me.


Thanks :)

Link to post
Share on other sites

Hi, and welcome. Yes, you are correct. There is still more work to do with the app to allow it to handle untrusted certs. At the moment you would either need a trusted cert, or you'd need to just use http.

Link to post
Share on other sites

Hello Luke,


I have the exact same problem excel that weirdly enough th app works just fine on the wifi network.


My set up

- Nginx  on my home server listens on 443 only and reverse proxy /emby to localhost:8096 (emby runs on the same machine)

- My router NATs 443 from the outside to 443 on my home server

- Certificate is unsigned

=> I connect through wifi to https://my.server.ip.address/emby => works flawlessly (very impressive what you've done here btw)

=> I connect through cellular to my external DDNS provider https://my-server.noip.xxx => playback crashes with aforementionned message


If the issue was 100% unsigned certificate related I would ve thought the app would not work on wifi (I do use the 443 on my lan on my LAN).


EDIT: got confirmation from a friend that streaming via the DDNS from an outside web client works as well .. so it's definitely the mobile app. Out of curisoiry, has this been flagged already? what's the issue with https certificates?


App log below


10:41:46.580 [main] DEBUG App - Connected to PlaybackService
10:41:46.594 [main] DEBUG App - Begining startPlayback
10:41:46.598 [main] DEBUG App - vlcVout.addCallback
10:41:46.599 [main] DEBUG App - vlcVout.attachViews
10:41:46.601 [main] ERROR App - Invalid surface size
10:41:46.706 [main] DEBUG App - Parsed uri: https://my-server.noip.xxx/emby/Videos/xxxxx/stream.mkv?Static=true&mediaSourceId=xxxx&deviceId=xxx&api_key=xxxx
10:41:46.755 [main] DEBUG App - Loading position 0 in [com.mb.android.media.MediaWrapper@c27f7e3]
10:41:46.781 [main] DEBUG App - Calling mMediaPlayer.play
10:41:47.669 [main] WARN  App - Warning: invalid next index, aborted !
10:41:48.858 [JavaBridge] DEBUG App - Vlc received command: stop
10:41:48.865 [JavaBridge] INFO  App - event.trigger ended
10:41:48.870 [JavaBridge] INFO  App - playback stopped
10:41:48.885 [main] DEBUG App - updatePlaybackState, playback state=0
10:41:48.890 [main] DEBUG App - MediaService.handleIntent action=action_stop
10:41:48.893 [main] DEBUG App - handleStopRequest: mState=0 error=
10:41:48.893 [main] DEBUG App - updatePlaybackState, playback state=1
10:41:48.894 [main] DEBUG App - giveUpAudioFocus
10:41:48.895 [main] DEBUG App - relaxResources. releaseMediaPlayer=
10:41:48.896 [main] DEBUG App - updatePlaybackState, playback state=1
10:41:48.896 [main] DEBUG App - updatePlaybackState, playback state=1
10:41:48.946 [JavaBridge] INFO  App - event.trigger playbackstop
10:41:48.954 [JavaBridge] INFO  App - Requesting url without automatic networking: https://my-server.noip.xxx/emby/Sessions/Playing/Stopped
10:41:49.019 [JavaBridge] INFO  App - nowplaying event: playbackstop
10:41:49.041 [JavaBridge] INFO  App - event.trigger ended
10:42:18.899 [main] DEBUG App - Stopping service with delay handler.
10:42:18.908 [main] DEBUG App - MediaService.onDestroy
10:42:18.909 [main] DEBUG App - handleStopRequest: mState=1 error=
10:42:18.909 [main] DEBUG App - updatePlaybackState, playback

Edited by ytzelf
Link to post
Share on other sites

I suddenly started getting Video playback error  in the android app after updating Emby to the latest beta.  This occurs when i try to view live tv in the app.


log from server attached


Edited by speedingcheetah
Link to post
Share on other sites

There is no Emby folder on my phones sd card...


Figures...now the app is streaming live tv fine....seems to be the trend with my experience with Emby....things work for a while then randomly stop working, then randomly work again....without changing anything.

Edited by speedingcheetah
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...