Jump to content


Photo

DLNA profile order

dlna profile order

Best Answer coudy , 06 September 2015 - 05:24 AM

Problem SOLVED:

 

I have realized, that TV is identified by network/host name. So I changed network/host names on both TVs and updated DLNA profiles friendly name to network/host name.

 

p.s. how can I close, or rename this topic ?

Go to the full post


  • Please log in to reply
3 replies to this topic

#1 coudy OFFLINE  

coudy

    Advanced Member

  • Members
  • 43 posts
  • Local time: 07:03 AM

Posted 04 September 2015 - 05:22 PM

Hi,

 

I have 2 vlans with same smart TV (LG WebOS) on each vlan.  I want to limit access to library for 1st TV in 1st vlan, and allow full access for 2nd TV in 2nd vlan. Because, they are almost equals models (700/730) I can't filter it by User-Agent.

I have cloned profile, but changed names, so I have 2 profiles, and in each profile I have selected different user.

 

1. Can I (how to) filter by device IP ?

I have tried this in identification section, but it does not work

<Identification>
    <FriendlyName>LG Smart+ TV</FriendlyName>
    <ModelNumber>1.0</ModelNumber>
    <SerialNumber />
    <ModelName>LG TV</ModelName>
    <DeviceDescription />
    <ModelUrl>http://www.lge.com/</ModelUrl>
    <Manufacturer>LG Electronics.</Manufacturer>
    <ManufacturerUrl>http://www.lge.com</ManufacturerUrl>
    <Ip>192.168.2.8</Ip>
    <Headers>
      <HttpHeaderInfo name="User-Agent" value="LGE WebOS TV LGE_DLNA_SDK" match="Substring" />
    </Headers>
  </Identification>

2. I have tried identify by host server IP (because emby runs on multiple interfaces, host is different for each vlan)

<Identification>
    <FriendlyName>LG Smart+ TV</FriendlyName>
    <ModelNumber>1.0</ModelNumber>
    <SerialNumber />
    <ModelName>LG TV</ModelName>
    <DeviceDescription />
    <ModelUrl>http://www.lge.com/</ModelUrl>
    <Manufacturer>LG Electronics.</Manufacturer>
    <ManufacturerUrl>http://www.lge.com</ManufacturerUrl>
    <Headers>
      <HttpHeaderInfo name="User-Agent" value="LGE WebOS TV LGE_DLNA_SDK" match="Substring" />
      <HttpHeaderInfo name="Host" value="192.168.2.5" match="Substring" />
    </Headers>
  </Identification>

3. is there any other way how to unique identify TVs ?

 

I'm running latest dev version 3.0.5725.41620.

 

Thank You

 



#2 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 13825 posts
  • Local time: 11:03 PM
  • LocationWashington State

Posted 04 September 2015 - 10:35 PM

You should see a description.xml link in your log for each device.  You should find something unique to each device (serial number, custom friendly names).  Do you have DLNA debug logging enabled?



#3 coudy OFFLINE  

coudy

    Advanced Member

  • Members
  • 43 posts
  • Local time: 07:03 AM

Posted 05 September 2015 - 02:11 AM

yes, I have debuuging enabled, and there is:

: Ip: 192.168.2.8:52140. Headers: SOAPAction="urn:schemas-upnp-org:service:ContentDirectory:1#Search",
DLNADeviceName.lge.com=%5bLG%5d%20webOS%20TV,User-Agent=Linux/3.10.19-32.afro.5 UPnP/1.0 LGE WebOS TV LGE_DLNA_SDK/
1.6.0/04.45.25 DLNADOC/1.50,Host=192.168.2.5:8096,Content-Length=742,Content-Type=text/xml; charset="utf-8"

So, there is IP parameter, and  I want to filter by IP. It is possible ? My previous attempts failed.



#4 coudy OFFLINE  

coudy

    Advanced Member

  • Members
  • 43 posts
  • Local time: 07:03 AM

Posted 06 September 2015 - 05:24 AM   Best Answer

Problem SOLVED:

 

I have realized, that TV is identified by network/host name. So I changed network/host names on both TVs and updated DLNA profiles friendly name to network/host name.

 

p.s. how can I close, or rename this topic ?


  • Happy2Play likes this





Also tagged with one or more of these keywords: dlna, profile, order

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users