Jump to content

Movies not displaying/showing


Recommended Posts

I have a windows 8 MB3 installation.  I have a very large movie collection, near 1000 movies.  Up and until a few days ago this displayed all my movies in the folder just fine.  Now today when I go through the different media library folders, all content displays but my movies.  It shows the count as 0/0.  However there are definitely movies in that directory and I can play them via windows explorer, and GOM media player.  Also if I go through the Web Interface to the movie folder, it shows all of my movies.

 

I have since uninstalled and reinstalled MB3 but still having the same issue.  No movies.  The path is correct.   Does anyone have an idea of what is going on?

 

I am on version 3.0.5076.20161 as of 11/26/13.

 

I was going to paste a dump of my log file, but there is not enough space to upload it.  SO I think I have successfully pasted a URL to dropbox.

 

https://dl.dropboxusercontent.com/u/46573484/log.rtf

 

This is when I use the MB3 classic application to view MB3 on my media server.  All from the same PC.

 

 

Edited by kuebs
Link to post
Share on other sites

According to your log, you do.

 

 

2013-11-26 11:47:16.2463, Info, App, Loading MediaBrowser.Plugins.Anime, Version=1.0.5070.30310, Culture=neutral, PublicKeyToken=null

 

Also, you can just attach the log file directly in here.  You don't need to change its format.

Link to post
Share on other sites

Hi All,

 

I experience this also. It seems to happen if I haven't logged into MBC for a while. I'll try and get some logs to you.

No issues on other clients (MBT, WP8, iOS or Web)

 

Thanks

Adam 

Link to post
Share on other sites

Yes I do. I do have the anime client installed.  I had thought I uninstalled it.  I do apologize.  Once I uninstalled that from the server configuration page, movies seemed to work fine.

 

Thanks I do appreciate the help.

 

I would have run this to ground sooner, but was out of town for the holiday.'

 

Now if I could just stop MB3 from asking for a password now every time I restart the client, things would be nearly perfect.  I am not sure what happened there.  Must have screwed something up when I was tweaking it.

Link to post
Share on other sites

There were some exceptions being thrown by the anime plugin in that log. Some of the code was not as robust as it should have been, which I may have fixed now, but the exceptions are more a symptom of some other root cause. I haven't seen that error in my own library, which might make it difficult to reproduce.

 

Regardless, I do not know how the plugin could break movies, as it does not touch anything to do with them, especially in such a way that it only breaks the MBC client.

Link to post
Share on other sites

Hello, here are my logs: http://sdrv.ms/19d25uA (Hopefully I've go the logging correct!)

 

I've included two - the first is the movie section showing zero movies. the second after exiting MBC, then going back in and it's working with movies available.

 

Thanks

Adam

Edited by asmithau
Link to post
Share on other sites

Now if I could just stop MB3 from asking for a password now every time I restart the client, things would be nearly perfect.  I am not sure what happened there.  Must have screwed something up when I was tweaking it.

 

In the MBC Configurator, you can set it up to automatically log in to any profile.

Link to post
Share on other sites

I set it so no PW is needed.  But now I think I want something more discrete.

 

Regarding my password issue, I want it set up so that when I go into MB3 on my main PC, I don't need a password, but if I come in remotely, via the web interface (which is very good BTW), that it would challenge me for user name and password. 

Link to post
Share on other sites

If you use the functionality I pointed out to provide an automatic login for MBC and put your password back, you will have exactly what you are asking for.

Link to post
Share on other sites

Sorry to chime in here, but I'm having the exact same issue as @@kuebs is. I've removed the anime plugin from my server. Server is Version 3.0.5083.27698 and MBC version is 3.0.96.0 B11-19.1.

 

My MBServer is brand new as of last night, and I believe I reinstalled MBC a few nights ago (I deleted all the MBC folders that I could find on my HTPC). In addition to my movies, the games folder is doing the same thing. I've put the most recent log from MBC here, the MBC configurator log here and the most recent log from the server here. I tried looking through them, but honestly I'm not sure what I'm looking for.

 

When I use the web client, everything shows up fine (same with on the Android client).

 

Any assist would be greatly appreciated!

Link to post
Share on other sites

How many items are in that Anime library?  It took your server 23 seconds to service the request and our standard time-out is 20 seconds.

Link to post
Share on other sites

There are 309 folders (62 root rest are sub) and 15,246 files. My Anime shows up fine, it's movies and games that are the issue in Mid.

 

Sent from my SGH-I747 using Tapatalk

 

 

Link to post
Share on other sites

Okay.  At some point I will try and make the time-out configurable - at least by manual editing.  This will allow people with really huge libraries to make it work but not slow down any normal setups.

  • Like 1
Link to post
Share on other sites
Okay. At some point I will try and make the time-out configurable - at least by manual editing. This will allow people with really huge libraries to make it work but not slow down any normal setups.

 

Do you suspect that is why my movies and games aren't displaying in mbc but are displaying fine in the Web client and Android app?

 

Sent from my Galaxy SIII Running LiquidSmooth 2.37 using Tapatalk

 

Edited by TrainAss
Link to post
Share on other sites

I know it is.

 

Both the Web client and Android apps page their requests so they only get things a chunk at a time.  They are designed this way because they were built for remote access.

 

MBC was adapted from MB2 so the entire infrastructure is not designed for this type of paging.  I have been able to do things in chunks in some instances but the interface expects the entire contents of any single folder to be available when that folder is displayed so a really huge folder can cause an issue.

 

Increasing the timeout I allow in MBC will cause the items to show up, but it will not help with the fact that it could take 30+ seconds to get into a folder.  Future improvements on the server end - or an upgrade of server hardware, could alleviate the issue as well as the actual bottleneck is on the server.

  • Like 1
Link to post
Share on other sites

I know it is. Both the Web client and Android apps page their requests so they only get things a chunk at a time. They are designed this way because they were built for remote access. MBC was adapted from MB2 so the entire infrastructure is not designed for this type of paging. I have been able to do things in chunks in some instances but the interface expects the entire contents of any single folder to be available when that folder is displayed so a really huge folder can cause an issue. Increasing the timeout I allow in MBC will cause the items to show up, but it will not help with the fact that it could take 30+ seconds to get into a folder. Future improvements on the server end - or an upgrade of server hardware, could alleviate the issue as well as the actual bottleneck is on the server.

Oh sweet. I was wondering if it was something I had done and was starting to get frustrated. My server is limited as it's what I had (2.6Ghz Athlon64 x2, 4GB DDR-2, radeon x1200 IGP, Intel gigabit nic). Other than the movies/games it's been awesome.

 

Hey @@ebr will this be in an update to MBC, MBT, the server or all 3?

 

Sent from my Galaxy SIII Running LiquidSmooth 2.37 using Tapatalk

Edited by TrainAss
Link to post
Share on other sites

For me, once I uninstalled the anime plugin, my movie folder displayed just fine.  I have a large number of directories, and I did start culling them in an effort to make this better, but without the anime plugin, it works perfectly.

 

Hardware wise, I did upgrade last year, to a quad core i3 CPU and new motherboard with 8GB of RAM.  My C: drive (system drive) is on an SSD and that was the biggest performance improvement I ever made.

Link to post
Share on other sites
  • 4 weeks later...
alexanderspecial

I know it is.

 

Both the Web client and Android apps page their requests so they only get things a chunk at a time.  They are designed this way because they were built for remote access.

 

MBC was adapted from MB2 so the entire infrastructure is not designed for this type of paging.  I have been able to do things in chunks in some instances but the interface expects the entire contents of any single folder to be available when that folder is displayed so a really huge folder can cause an issue.

 

Increasing the timeout I allow in MBC will cause the items to show up, but it will not help with the fact that it could take 30+ seconds to get into a folder.  Future improvements on the server end - or an upgrade of server hardware, could alleviate the issue as well as the actual bottleneck is on the server.

 

thank you for that.

By the way excellent work on MB3.

Good architecture to keep building on and improving.

 

I have this problem with MBC.

I have a large collection of movies and your above explanation means that my movies are not showing.

 

Is there any workaround in the meantime for using MBC and being able to see a large collection?

 

Thanks

Link to post
Share on other sites
  • 2 months later...
Trevor68

I have my movies split into HD and SD libraries, the HD library has just stopped updating at 431 folders. the last 2 movies added display fine in web client, and also Boxsets and Movies by Genre, its only the HD libarary that has ceased to update.

 

This is on a Q9400 with 8gig ram running W7 Pro 64bit. Attaching log.server-63531302400.log

Link to post
Share on other sites

400 isn't that many.  I think you are probably hitting some other issue.  Can I please see the MBC log?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...