Jump to content

Android - Cannot Connect via External Network (4G/3G/WiFi)


Go to solution Solved by iam4uk,

Recommended Posts

Last Saturday I uninstalled MB2 and installed MB3.  Main interest was Android app for portable access to my library, so of course I also bought the Android App.

I've set up MB Server, MB Classic in 7MC, and MBforAndroid.  Some quirks getting used to the new way of "serving" the media to clients, but all programs and apps are at least basically functioning.

I can play movies (MKV and WTV attempted so far) via the Android MB client, but only on my own WiFi network--nothing external.

I have set my ASUS RT-AC66R router to do Port Forwarding on port 8096 for the IP of my MB Server computer, per another thread here on these forums.


Issue:  How can I use MB Android via external networks (4G or WiFi-other-than-my-own)?  Currently, when running that client app on external network, it "Cannot connect to server."


Media Browser Server version: 3.0.5070.20258

Media Browser Classic version B11-19.1

Media Browser Android version 1.0.2 (191113)




Many thanks to all involved in producing these programs and applications!


Link to comment
Share on other sites


Have you tried navigating to the mediabrowser dashboard using the devices web browser in order to confirm the ports are open..

  • Like 1
Link to comment
Share on other sites

  • Solution

Thanks for the reply, theojt.

I use my own modem, and it has no firewall enabled.

But I figured out what Redshirt meant in another thread when he answered another "n00b question" on this topic... he mentioned having two devices to access the one MB Server via Android MB Client -- one for local WiFi, and one for external.  I had tried that unsuccessfully, but I researched DDNS in the ASUS router manual, and tried their DDNS service ([mychosenaddressname].asuscomm.com).  That, along with Port Forwarding, did the trick.


Now I have discovered how important it is to set the bitrate for both WiFi and cellular within the MB Android app.  Set it as high as the network can constantly support, but no higher, or there will be much buffering.  Too low would sacrifice quality, of course.


Having my CinemaPC library portable via Android is the fulfillment of a long-term quest.  Thanks, developers!

  • Like 1
Link to comment
Share on other sites

I had not tried the web browser check, Redshirt, but I'll keep that troubleshooting tip in mind.  Thank you for the amazing work you've done--these capabilities are worth a lot.

Link to comment
Share on other sites

  • 6 months later...

I Know the post is really old but thought this may help with this issue. some are having the same problem I did.


I hope it will help. If it helps one person then it was worth passing the  info on.

Edited by NeverMore
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...