Jump to content


Photo

Metadata Manager Issues

Metadata Manager

  • Please log in to reply
28 replies to this topic

#1 blade005 OFFLINE  

blade005

    Advanced Member

  • Alpha Testers
  • 710 posts
  • Local time: 12:58 AM

Posted 28 July 2015 - 12:04 PM

WebUI: Chrome 44.0.2403.107
Emby Server: 3.0.5675.1

 

Continuing to have library access and Metadata Manager issues.

 

If I try to select Metadata Manager from the pull down menu in the WebUI all I get is a spinning circle and the LOADING descriptor, but the Metadata Manager menu never appears. Once this occurs the entire library becomes unresponsive. If I wait long enough, whatever is timing out may eventually release and I can get the library to become responsive again.

 

 


  • speechles likes this

#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 137931 posts
  • Local time: 01:58 AM

Posted 28 July 2015 - 02:34 PM

Please see http://emby.media/co...port-a-problem/



#3 blade005 OFFLINE  

blade005

    Advanced Member

  • Alpha Testers
  • 710 posts
  • Local time: 12:58 AM

Posted 28 July 2015 - 03:08 PM

Luke,

 

I have posted in a separate thread my issue with the library becoming inaccessible along with logs.

 

http://emby.media/co...e-emby-library/

 

 

Attached is the latest log in which you will see a number of ERROR REPORTS flagged when the library becomes unresponsive.

 

http://paste2.org/zO2pPD5w

 

As stated in previous post, removing LIVE TV seems to have reduced the frequency of the library becoming unresponsive, but not eliminated it completely. It appears that the REFRESH GUIDE task seemed to be the culprit. It would either hang at 0% or 100% and the library would become unresponsive. Any attempt to access the Metadata Manger after removing Live TV support (ServerWMC) just gives me a spinning loading icon and then the library is unresponsive after that. It will occur if I try to access Metadata Manager from the pull down menu or if I try to EDIT an item from the Home Page.


Edited by blade005, 28 July 2015 - 03:12 PM.


#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 137931 posts
  • Local time: 01:58 AM

Posted 28 July 2015 - 03:12 PM

you're going to want to turn off the library's realtime-monitor as it appears so many file changes are happening that it's reaching a threshold and causing some instability.

 

also, there were chapter image extractions going on during this time, which will have some noticeable cpu impact. Consider disabling that feature, or at the very least, unchecking the box that does the images as part of the library scan.



#5 blade005 OFFLINE  

blade005

    Advanced Member

  • Alpha Testers
  • 710 posts
  • Local time: 12:58 AM

Posted 28 July 2015 - 03:26 PM

Luke,

 

I will do both, but what I don't understand is why so many file changes are being seen. There were not any additions to the library or changes to any system paths that should trigger so much activity. This has just become an issue in the last few weeks. Puzzling.



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 137931 posts
  • Local time: 01:58 AM

Posted 28 July 2015 - 03:29 PM

you have automatic updates from fanart and other providers enabled. that's going to cause lots of changes on a regular basis.

 

maybe it's time to just take those features away



#7 blade005 OFFLINE  

blade005

    Advanced Member

  • Alpha Testers
  • 710 posts
  • Local time: 12:58 AM

Posted 28 July 2015 - 04:20 PM

you have automatic updates from fanart and other providers enabled. that's going to cause lots of changes on a regular basis.

 

maybe it's time to just take those features away

Luke,

 

I had those turned on only to pick up the images for new TV series or seasons that may not be there when first added to the library. I didn't consider that they would trigger lots of changes at any given point in time.



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 137931 posts
  • Local time: 01:58 AM

Posted 28 July 2015 - 04:29 PM

well i think if you disable all of the things previously mentioned, it will probably perform better.



#9 blade005 OFFLINE  

blade005

    Advanced Member

  • Alpha Testers
  • 710 posts
  • Local time: 12:58 AM

Posted 28 July 2015 - 05:02 PM

Luke,

 

I did as you suggested. But, the issue is still with the library becoming unresponsive intermittently. I shut down the server after changes, restarted and let the library scan complete. Metadata Manger was accessible for about 20 minutes and then the next attempt gave me the spinning loading icon and an unresponsive library again.

 

FYI... I uninstalled ServerWMC Live TV plugin a couple of days ago, but on a server restart I am still getting a REFRESH GUIDE task running even though no trigger is in the Scheduled Tasks. This will cause the library to become unresponsive as well unless manually stopped. Is there a clean up process for removing all Live TV files and settings I could follow?



#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 137931 posts
  • Local time: 01:58 AM

Posted 28 July 2015 - 05:06 PM

just let the guide task finish.



#11 blade005 OFFLINE  

blade005

    Advanced Member

  • Alpha Testers
  • 710 posts
  • Local time: 12:58 AM

Posted 28 July 2015 - 05:09 PM

just let the guide task finish.

How long should I wait? Why is it needed without Live TV? It just sits there at 0% or in the past at 100% for minutes on end. No library access when it is in this state.



#12 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 137931 posts
  • Local time: 01:58 AM

Posted 28 July 2015 - 05:11 PM

it will only happen once. since you've removed live tv it is removing all the live tv entries from the database.



#13 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15710 posts
  • Local time: 10:58 PM
  • LocationWashington State

Posted 28 July 2015 - 05:14 PM

For some reason Refresh Guide is a default task.  I don't have an issue with it on my system, and I don't have live tv at all but I know everyone has different powered systems.

 

You can create a custom task so it will no longer run if you wish.  Instructions here.

 

 

it will only happen once. since you've removed live tv it is removing all the live tv entries from the database.

Is this something new?

 

*The task was present in dev build also but deleting it, the task doesn't repopulate as before.


Edited by Happy2Play, 28 July 2015 - 05:23 PM.
update


#14 blade005 OFFLINE  

blade005

    Advanced Member

  • Alpha Testers
  • 710 posts
  • Local time: 12:58 AM

Posted 28 July 2015 - 06:44 PM

it will only happen once. since you've removed live tv it is removing all the live tv entries from the database.

Luke,

 

This just isn't working for me. I shut down all activities you suggested. I let the Refresh Guide task run completely. It has run a couple of times since then and locks up the library. The Metadata Manager will be available briefly after a re-start, but eventually will become unresponsive again.  I don't know what is going on.

 

Latest log after unresponsive Metadata Manager and Library: http://paste2.org/MEXcnLv5



#15 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 137931 posts
  • Local time: 01:58 AM

Posted 28 July 2015 - 06:48 PM

please always post complete logs as mentioned in post #2



#16 blade005 OFFLINE  

blade005

    Advanced Member

  • Alpha Testers
  • 710 posts
  • Local time: 12:58 AM

Posted 28 July 2015 - 06:56 PM

please always post complete logs as mentioned in post #2

That was the complete log. I had recently restarted the server and the logs were cleared out.



#17 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 137931 posts
  • Local time: 01:58 AM

Posted 28 July 2015 - 07:00 PM

it can't be. it's missing the server startup sequence and probably quite a bit after that.



#18 blade005 OFFLINE  

blade005

    Advanced Member

  • Alpha Testers
  • 710 posts
  • Local time: 12:58 AM

Posted 28 July 2015 - 07:07 PM

Luke, 

 

Just shutdown server and will let it start up and begin a new log. I will see how long it runs before the next issue and will provide the complete log.

 

I know you said to let Refresh Guide run through to clean up Live TV.  I have done that, and it continues to trigger and run at start up and even during library scans.



#19 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 137931 posts
  • Local time: 01:58 AM

Posted 28 July 2015 - 07:09 PM

apart from not being a full log, that most recent log looks fine from the server standpoint. so one other thing you could try is to see if the behavior is any different in another browser, or from another machine.



#20 blade005 OFFLINE  

blade005

    Advanced Member

  • Alpha Testers
  • 710 posts
  • Local time: 12:58 AM

Posted 28 July 2015 - 07:13 PM

apart from not being a full log, that most recent log looks fine from the server standpoint. so one other thing you could try is to see if the behavior is any different in another browser, or from another machine.

I will check once library scan is complete. Previously it didn't matter. When it becomes unresponsive, it was that way from Chrome, IE on same machine as Emby Server or different machines. It was also the same from Emby WMC, Emby Theater and Emby for Android.







Also tagged with one or more of these keywords: Metadata Manager

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users