Jump to content

Android Mobile


Redshirt

Recommended Posts

Redshirt

@@Redshirt

 

i reset my device but have the same profile problem. You'll be glad to know kinectimals displays the same behaviour so it is definitely an os issue.

 

any chance of a kids simplified theme? I know its easy already but my little girl is three!!

 

 

 

beh

There's a few young users that I'm aware of. The deductive nature of some of these little people amaze me.

At this point I don't have the time to look at alternative themes but it is an interesting idea.

Link to post
Share on other sites

Looking back at your original post I saw clearly that you were using the poster view. I need to do better tracking issues... I'm still investigating this one, the answer is far from forthcoming. 

 

@@Redshirt i think I may have found where the bug is. Thru my testing, it turns out that if a single series is missing a Primary Image (poster) then it causes the whole Poster View in the client to not display them also.

 

As soon as I added a poster to the series with the missing one, they magically all appear now. Can you confirm my findings? The same goes for season posters also.

Link to post
Share on other sites
Redshirt

@@seanbuff

 

I tried to recreate the issue. I created a series folder that had a name that doesn't exist on tvdb, so no image would be found. I tried several names that would have placed the folder in various positions in the grid and in each instance all the other posters loaded and I was left with just a single show without an image. In other words I can't make it happen :) There haven't been any other complaints about this issue, and you've got it sorted now so I'm willing to just chalk it up to a random oddity. Thanks for the update.

Link to post
Share on other sites

I love the app and the way that MB has come over the years....props to you boys for keeping up the great work...I do have one issue.  Someone was able to once help me get my gs4 phone to work when the app was in beta pre-play store...once it was available for purchase .. I jumped all over it...but recently i tried to connect from my phone...and although it says I am connected...(local or outside the local network)  none of my medial shows up...I have the app set to default to my library but nothing is shown...any ideas as to what may be causing this?

Link to post
Share on other sites
Redshirt

they're stored on the sdcard Usually SDCard0\MB3AndroidData\Logs. If your phone/tablet doesn't come with a file manager, I'd recommend ASTRO or ES Explorer.

Link to post
Share on other sites
[Thu Dec 12 21:30:27 EST 2013] , Info , Application Version: 1.0.6 , 1 , main[Thu Dec 12 21:30:27 EST 2013] , Info , Device: SPH-L720 , 1 , main[Thu Dec 12 21:30:27 EST 2013] , Info , Screen Width: 1080 , 1 , main[Thu Dec 12 21:30:27 EST 2013] , Info , Screen Height: 1920 , 1 , main[Thu Dec 12 21:30:27 EST 2013] , Info , Total Memory Available: 245 MB , 1 , main[Thu Dec 12 21:30:27 EST 2013] , Info , Max Memory usable per Application: 128 MB , 1 , main[Thu Dec 12 21:30:27 EST 2013] , Info , Application object initialized , 1 , main[Thu Dec 12 21:30:27 EST 2013] , Info , HomeScreen Activity: onCreate , 1 , main[Thu Dec 12 21:30:27 EST 2013] , Info , HomeScreen Activity: onStart , 1 , main[Thu Dec 12 21:30:27 EST 2013] , Error , AsyncRequestItemResult, IOException java.net.UnknownHostException: Unable to resolve host "null": No address associated with hostname	at java.net.InetAddress.lookupHostByName(InetAddress.java:424)	at java.net.InetAddress.getAllByNameImpl(InetAddress.java:236)	at java.net.InetAddress.getAllByName(InetAddress.java:214)	at libcore.net.http.HttpConnection.<init>(HttpConnection.java:70)	at libcore.net.http.HttpConnection.<init>(HttpConnection.java:50)	at libcore.net.http.HttpConnection$Address.connect(HttpConnection.java:340)	at libcore.net.http.HttpConnectionPool.get(HttpConnectionPool.java:87)	at libcore.net.http.HttpConnection.connect(HttpConnection.java:128)	at libcore.net.http.HttpEngine.openSocketConnection(HttpEngine.java:316)	at libcore.net.http.HttpEngine.connect(HttpEngine.java:311)	at libcore.net.http.HttpEngine.sendSocketRequest(HttpEngine.java:290)	at libcore.net.http.HttpEngine.sendRequest(HttpEngine.java:240)	at libcore.net.http.HttpURLConnectionImpl.connect(HttpURLConnectionImpl.java:81)	at com.mb.api.asyncrequests.AsyncRequestItemResult.doInBackground(AsyncRequestItemResult.java:51)	at com.mb.api.asyncrequests.AsyncRequestItemResult.doInBackground(AsyncRequestItemResult.java:22)	at android.os.AsyncTask$2.call(AsyncTask.java:287)	at java.util.concurrent.FutureTask.run(FutureTask.java:234)	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1080)	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:573)	at java.lang.Thread.run(Thread.java:841)Caused by: libcore.io.GaiException: getaddrinfo failed: EAI_NODATA (No address associated with hostname)	at libcore.io.Posix.getaddrinfo(Native Method)	at libcore.io.ForwardingOs.getaddrinfo(ForwardingOs.java:61)	at java.net.InetAddress.lookupHostByName(InetAddress.java:405)	... 19 more , 8637 , AsyncTask #2[Thu Dec 12 21:30:27 EST 2013] , Info , HomeScreen Activity: onResume , 1 , main[Thu Dec 12 21:30:27 EST 2013] , Error , AsyncRequestItemResult, IOException java.net.UnknownHostException: Unable to resolve host "null": No address associated with hostname	at java.net.InetAddress.lookupHostByName(InetAddress.java:394)	at java.net.InetAddress.getAllByNameImpl(InetAddress.java:236)	at java.net.InetAddress.getAllByName(InetAddress.java:214)	at libcore.net.http.HttpConnection.<init>(HttpConnection.java:70)	at libcore.net.http.HttpConnection.<init>(HttpConnection.java:50)	at libcore.net.http.HttpConnection$Address.connect(HttpConnection.java:340)	at libcore.net.http.HttpConnectionPool.get(HttpConnectionPool.java:87)	at libcore.net.http.HttpConnection.connect(HttpConnection.java:128)	at libcore.net.http.HttpEngine.openSocketConnection(HttpEngine.java:316)	at libcore.net.http.HttpEngine.connect(HttpEngine.java:311)	at libcore.net.http.HttpEngine.sendSocketRequest(HttpEngine.java:290)	at libcore.net.http.HttpEngine.sendRequest(HttpEngine.java:240)	at libcore.net.http.HttpURLConnectionImpl.connect(HttpURLConnectionImpl.java:81)	at com.mb.api.asyncrequests.AsyncRequestItemResult.doInBackground(AsyncRequestItemResult.java:51)	at com.mb.api.asyncrequests.AsyncRequestItemResult.doInBackground(AsyncRequestItemResult.java:22)	at android.os.AsyncTask$2.call(AsyncTask.java:287)	at java.util.concurrent.FutureTask.run(FutureTask.java:234)	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1080)	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:573)	at java.lang.Thread.run(Thread.java:841) , 8638 , AsyncTask #3[Thu Dec 12 21:30:27 EST 2013] , Info , Initializing WebSocket , 1 , main[Thu Dec 12 21:30:27 EST 2013] , Info , WebSocket: Connect , 1 , main[Thu Dec 12 21:30:27 EST 2013] , Info , WebSocket: Successfully Connected , 8640 , Thread-8640[Thu Dec 12 21:30:31 EST 2013] , Info , HomeScreen Activity: onPause , 1 , main

_is this what your looking for?

Link to post
Share on other sites

Yup that's it. What do you have as the host name? I seem to remember that android cannot translate pc name on lan (from memory). If you have your pc name try changing it to the ip (red will correct if I am wrong.

Edited by Tikuf
Link to post
Share on other sites

for the host name i use <snip> since i access from the outside as well.

 

Edited out  ddns name for you - tikuf

Edited by Tikuf
Link to post
Share on other sites

Ah ok your router may not be able to loopback to use that as your internal. Set up one for external and one for internal (ip)

Edited by Tikuf
Link to post
Share on other sites
Redshirt

as tikuf said. For now you'll need to define two separate connections. One for internal and one for external. 

Link to post
Share on other sites


[Thu Dec 12 21:30:33 EST 2013] , Info , Application Version: 1.0.6 , 1 , main

 

[Thu Dec 12 21:30:33 EST 2013] , Info , Device: SPH-L720 , 1 , main

 

[Thu Dec 12 21:30:33 EST 2013] , Info , Screen Width: 1080 , 1 , main

 

[Thu Dec 12 21:30:33 EST 2013] , Info , Screen Height: 1920 , 1 , main

 

[Thu Dec 12 21:30:33 EST 2013] , Info , Total Memory Available: 246 MB , 1 , main

 

[Thu Dec 12 21:30:33 EST 2013] , Info , Max Memory usable per Application: 128 MB , 1 , main

 

[Thu Dec 12 21:30:33 EST 2013] , Info , Application object initialized , 1 , main

 

[Thu Dec 12 21:30:33 EST 2013] , Info , Logger Started , 1 , main

 

[Thu Dec 12 21:30:33 EST 2013] , Info , Initializing FileUtils helper class , 1 , main

 

[Thu Dec 12 21:30:33 EST 2013] , Info , Loading server list from app directory , 1 , main

 

[Thu Dec 12 21:30:33 EST 2013] , Info , Trying to load last connected server from file system , 1 , main

 

[Thu Dec 12 21:30:33 EST 2013] , Info , Loading last connected server from app directory , 1 , main

 

[Thu Dec 12 21:30:33 EST 2013] , Info , ServerConfiguration callback , 1 , main

 

[Thu Dec 12 21:30:33 EST 2013] , Info , ServerConfiguration successfully received , 1 , main

 

[Thu Dec 12 21:30:33 EST 2013] , Info , ServerInfo callback , 1 , main

 

[Thu Dec 12 21:30:33 EST 2013] , Info , ServerInfo received , 1 , main

 

[Thu Dec 12 21:30:33 EST 2013] , Info , Saving last connected to app directory , 1 , main

 

[Thu Dec 12 21:30:33 EST 2013] , Info , GetAllUsersCallback , 1 , main

 

[Thu Dec 12 21:30:33 EST 2013] , Info , 1 user(s) received , 1 , main

 

[Thu Dec 12 21:30:33 EST 2013] , Info , Attempting Authentication , 1 , main

 

[Thu Dec 12 21:30:33 EST 2013] , Info , AuthenticateUserCallback , 1 , main

 

[Thu Dec 12 21:30:33 EST 2013] , Info , Data received , 1 , main

 

[Thu Dec 12 21:30:33 EST 2013] , Info , HTTP RESPONSE 200 , 1 , main

 

[Thu Dec 12 21:30:33 EST 2013] , Info , Call Homescreen Activity , 1 , main

 

[Thu Dec 12 21:30:34 EST 2013] , Info , HomeScreen Activity: onCreate , 1 , main

 

[Thu Dec 12 21:30:34 EST 2013] , Info , HomeScreen Activity: onStart , 1 , main

 

[Thu Dec 12 21:30:34 EST 2013] , Info , HomeScreen Activity: onResume , 1 , main

 

[Thu Dec 12 21:30:34 EST 2013] , Info , Initializing WebSocket , 1 , main

 

[Thu Dec 12 21:30:34 EST 2013] , Info , WebSocket: Connect , 1 , main

 

[Thu Dec 12 21:30:34 EST 2013] , Info , WebSocket: Successfully Connected , 8664 , Thread-8664

 

[Thu Dec 12 21:30:39 EST 2013] , Error , AsyncRequestItemResult, SocketTimeoutException java.net.SocketTimeoutException

at java.net.PlainSocketImpl.read(PlainSocketImpl.java:491)

at java.net.PlainSocketImpl.access$000(PlainSocketImpl.java:46)

at java.net.PlainSocketImpl$PlainSocketInputStream.read(PlainSocketImpl.java:240)

at java.io.InputStream.read(InputStream.java:163)

at java.io.BufferedInputStream.fillbuf(BufferedInputStream.java:142)

at java.io.BufferedInputStream.read(BufferedInputStream.java:227)

at libcore.io.Streams.readAsciiLine(Streams.java:201)

at libcore.net.http.HttpEngine.readResponseHeaders(HttpEngine.java:579)

at libcore.net.http.HttpEngine.readResponse(HttpEngine.java:827)

at libcore.net.http.HttpURLConnectionImpl.getResponse(HttpURLConnectionImpl.java:283)

at libcore.net.http.HttpURLConnectionImpl.getHeaderField(HttpURLConnectionImpl.java:139)

at java.net.URLConnection.getContentEncoding(URLConnection.java:245)

at java.net.HttpURLConnection.getContentEncoding(HttpURLConnection.java:697)

at com.mb.api.asyncrequests.AsyncRequestItemResult.doInBackground(AsyncRequestItemResult.java:53)

at com.mb.api.asyncrequests.AsyncRequestItemResult.doInBackground(AsyncRequestItemResult.java:22)

at android.os.AsyncTask$2.call(AsyncTask.java:287)

at java.util.concurrent.FutureTask.run(FutureTask.java:234)

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1080)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:573)

at java.lang.Thread.run(Thread.java:841)

, 8657 , AsyncTask #1

 

Link to post
Share on other sites
Redshirt

Just to be clear. Does no media mean just a blank page. Or do you mean images aren't showing for your items but the names are visible?

Link to post
Share on other sites

Think that error is benign.

 

Do you have media shown in the dash if you access from the droid with a web browser ?

serverip:8096/mediabrowser/dashboard/index.html
Edited by Tikuf
Link to post
Share on other sites
Redshirt

oh wait. You added a log as I was typing. 

 

The log shows a socket timeout. Which means the server may not be sending the info fast enough. How responsive is the web dashboard and other clients?

Link to post
Share on other sites

client is set to library but nothing comes up at all no images or names same if i click on movies or tv .. i sometimes get a message

No content available. Add media libriaries through the MediaBrower Server Dashboard

Link to post
Share on other sites
Redshirt

I saw this error a couple or weeks ago with another user. I believe it had something to do with his storage setup causing the server to not be able to generate the data fast enough. My client was timing out waiting for the server to transmit the data. 

 

I'm going to raise the default timeout from 5 seconds to a more reasonable number. Can you let me know how this goes after the next public release. Probably early next week.

Link to post
Share on other sites

 

Think that error is benign.

 

Do you have media shown in the dash if you access from the droid with a web browser ?

serverip:8096/mediabrowser/dashboard/index.html

going in this way shows media using local server ip as well and external.

Edited by MoNkLorD
Link to post
Share on other sites
Redshirt

aye. The Android OS doesn't support DNS names. so for example "myserver" doesn't work, but "myserver.mydomain.com" does work. It's a big oversight in their design and they've acknowledged it, they're just slow to fix it.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...