Jump to content

Synology Setup


Luke
 Share

Recommended Posts

@spietrza

 

Mono v4.2.1.102-6 is current from synocommunity

 

@mittedude

 

I do not know that your Synology is. Enabling SSH would not slow your system. if you have a slow NAS and Mono and emby are running it will take some time to settle down. Web access is slow if it's using 100%cpu

 

@Luke 

 

link working as intended ;)

Edited by Gernash
Link to comment
Share on other sites

@Gernash

i have a DS411j not the fastet NAS, but the problem is...i have install everthing i need i think, Emby-beta, ffmpeg, imagemagick, mono-beta and these are up and running.

But it can't connect to server/ip of my nas it says "The connection failed".

 

Must be some settnings i have forget to check?

Link to comment
Share on other sites

You cannot connect to your Synology dashboard or the emby wizard at 1st start? If it's the wizard then you may have to

uninstall emby

then reinstall

then run it and complete the 1st run wizard

then update it.

Link to comment
Share on other sites

How can i run Emby on my DS216play?

 

monaco

  • x16 Series
    • DS216play - synology_monaco_216play

I have to use the monaco version, is it available yet?

Is it possible to use a different version?

  • Like 2
Link to comment
Share on other sites

  • 3 weeks later...

I have a DS413 with a FREESCALE QorIQ P1022 CPU and 1024MB of total Physical memory. When I followed the instructions under “Pre-Installation” and “Installation” in the original post I could not install “Mono” from the Package Centre as it did not appear there. The other packages “Mediainfo” and “ImageMagick” were listed and available for installation. A bit of research seemed to indicate to me that “mono” was not compatible with the Freescale Architecture.

 

Does anyone know if Mono can be installed on my machine?

 

Also, there did not seem to be any Installation instructions for the Freescale CPU – does this mean even after the Package moves from Beta, I will not be able to install on my machine?

 

Many Thanks

Link to comment
Share on other sites

 

Updating

 

4. Copy the contents of the zip file into /volume1/@appstore/emby/share/emby (or wherever it has been installed, the contents of the zip should look like the contents of the folder you are copying into)

 

 

 

I am having trouble doing this, I get an error with Terminal on OS X.

I have downloaded and unzipped the update folder. Moved that folder to the folder I keep Emby Metadata in (/volume1/Media/Emby/Emby.Mono), and the run the following which should be correct, but no go.

 

DiskStation> cd /volume1/Media/Emby

DiskStation> cp Emby.Mono /volume1/@appstore/emby/share/emby

cp: omitting directory 'Emby.Mono'

DiskStation> 

 

Should I change the Emby.Mono folder name to something else, or am I doing something else wrong?

Link to comment
Share on other sites

You don't need to rename anything if that's what you're asking. You should just find the folder that has the same files and overwrite them. What is the issue you are having?

Link to comment
Share on other sites

I assumed the unzipped Emby.Mono folder was the same name and structure and thus you simply copied that over in its entirety.

If I am not copy the entire update folder, exactly what am I supposed to copy, individual files multiple times?

 

When I do this: ls -all /cp /volume1/@appstore/emby/share/emby

It shows a list of files as per the unzipped folder, plus a few more folder too. So do I copy across all of the individual files one at a time?

 

 

DiskStation>  ls -all /cp /volume1/@appstore/emby/share/emby

ls: /cp: No such file or directory

/volume1/@appstore/emby/share/emby:

drwxr-xr-x    5 emby     root          4096 Sep 30 09:09 .

drwxr-xr-x    3 emby     root          4096 Sep 30 09:10 ..

-rw-r--r--    1 emby     root         78336 Jan 12  2015 BDInfo.dll

-rw-r--r--    1 emby     root         18432 Jan 12  2015 DvdLib.dll

-rw-r--r--    1 emby     root        261632 Sep 21 19:26 Emby.Drawing.dll

-rw-r--r--    1 emby     root        100864 Apr 28  2015 ImageMagickSharp.dll

-rw-r--r--    1 emby     root           296 Sep 30 09:09 ImageMagickSharp.dll.config

-rw-r--r--    1 emby     root           295 Mar 25  2015 ImageMagickSharp.dll.config.orig

-rw-r--r--    1 emby     root          5120 Apr 15  2015 Interfaces.IO.dll

-rw-r--r--    1 emby     root        780800 Sep 21 19:26 MediaBrowser.Api.dll

-rw-r--r--    1 emby     root        134144 Sep 21 19:26 MediaBrowser.Common.Implementations.dll

-rw-r--r--    1 emby     root         45056 Sep 21 19:26 MediaBrowser.Common.dll

-rw-r--r--    1 emby     root        475648 Sep 21 19:26 MediaBrowser.Controller.dll

-rw-r--r--    1 emby     root        621056 Sep 21 19:26 MediaBrowser.Dlna.dll

-rw-r--r--    1 emby     root         11776 Jan 12  2015 MediaBrowser.IsoMounting.Linux.dll

-rw-r--r--    1 emby     root         55808 Sep 21 19:26 MediaBrowser.LocalMetadata.dll

-rw-r--r--    1 emby     root        141824 Sep 21 19:26 MediaBrowser.MediaEncoding.dll

-rw-r--r--    1 emby     root         12800 Sep 21 19:26 MediaBrowser.MediaInfo.dll

-rw-r--r--    1 emby     root           180 Jan 12  2015 MediaBrowser.MediaInfo.dll.config

-rw-r--r--    1 emby     root        467456 Sep 21 19:26 MediaBrowser.Model.dll

-rw-r--r--    1 emby     root         55808 May 27  2015 MediaBrowser.Naming.dll

-rw-r--r--    1 emby     root        620032 Sep 21 19:26 MediaBrowser.Providers.dll

-rw-r--r--    1 emby     root       1713664 Sep 21 19:26 MediaBrowser.Server.Implementations.dll

-rw-r--r--    1 emby     root         19456 Sep 21 19:26 MediaBrowser.Server.Mono.exe

-rw-r--r--    1 emby     root           890 Jan 12  2015 MediaBrowser.Server.Mono.exe.config

-rw-r--r--    1 emby     root         90624 Sep 21 19:26 MediaBrowser.Server.Startup.Common.dll

-rw-r--r--    1 emby     root         46592 Sep 21 19:26 MediaBrowser.WebDashboard.dll

-rw-r--r--    1 emby     root         60416 Sep 21 19:26 MediaBrowser.XbmcMetadata.dll

drwxr-xr-x    3 emby     root          4096 Apr 15  2015 MediaInfo

-rw-r--r--    1 emby     root         47104 May  8  2015 Mono.Nat.dll

-rw-r--r--    1 emby     root        187392 Jan 12  2015 Mono.Posix.dll

-rw-r--r--    1 emby     root         64000 Jan 12  2015 MoreLinq.dll

-rw-r--r--    1 emby     root        420352 May  8  2015 NLog.dll

-rw-r--r--    1 emby     root        101888 Sep 21 19:26 OpenSubtitlesHandler.dll

-rw-r--r--    1 emby     root          5120 Feb 10  2015 Patterns.Logging.dll

-rw-r--r--    1 emby     root        649216 Jan 12  2015 ServiceStack.Api.Swagger.dll

-rw-r--r--    1 emby     root        137216 Jan 12  2015 ServiceStack.Client.dll

-rw-r--r--    1 emby     root        153088 Jan 12  2015 ServiceStack.Common.dll

-rw-r--r--    1 emby     root        117248 Jan 12  2015 ServiceStack.Interfaces.dll

-rw-r--r--    1 emby     root        286720 Jan 12  2015 ServiceStack.Text.dll

-rw-r--r--    1 emby     root       1396736 Jan 12  2015 ServiceStack.dll

-rw-r--r--    1 emby     root        420864 Jan 12  2015 SharpCompress.dll

-rw-r--r--    1 emby     root        311808 May  8  2015 SimpleInjector.dll

-rw-r--r--    1 emby     root        128512 Jun 15  2015 SocketHttpListener.dll

-rw-r--r--    1 emby     root        273920 Jan 12  2015 System.Data.SQLite.dll

-rw-r--r--    1 emby     root            94 Jan 12  2015 System.Data.SQLite.dll.config

-rw-r--r--    1 emby     root        164352 Jan 12  2015 UniversalDetector.dll

-rw-r--r--    1 emby     root        140800 Apr 14  2015 WebMarkupMin.Core.dll

drwxr-xr-x   13 emby     root          4096 Sep 21 19:26 dashboard-ui

-rw-r--r--    1 emby     root       2095140 Jan 12  2015 libsqlite3.0.dylib

-rw-r--r--    1 emby     root            18 Jan 12  2015 libsqlite3.dylib

drwxr-xr-x    5 emby     root          4096 Sep 21 19:26 swagger-ui

-rw-r--r--    1 emby     root        443392 Jan 12  2015 taglib-sharp.dll

DiskStation> 

Link to comment
Share on other sites

@@KRULL, what you need to do is look at the contents of the zip and find the corresponding directory in your installation, and then unzip there.

 

I apologize if that seems clunky. We are working on getting listed in the synology catalog. You can voice your opinion and help move that along here:

 

https://github.com/SynoCommunity/spksrc/pull/1673

 

Thanks.

Link to comment
Share on other sites

I have no clue what to type to unzip in SSH to extract the contents and not create a folder.

I have copied across the zip file, what do I tell it next?

 

DiskStation> cd /volume1/Media/Emby

DiskStation> cp EmbyMono.zip /volume1/@appstore/emby/share/emby

 

Edit: Got it

 

cd /volume1/Media/Emby

cp EmbyMono.zip /volume1/@appstore/emby/share/emby

unzip /volume1/@appstore/emby/share/emby/EmbyMono.zip 

 

Then select "A" to replace All.

 

Edit 2: that didn't work, it shows I am still on Version 3.0.5724.5

 

Edit 3:

 

Third time lucky, maybe it wasn't shut down completely last time.

 

cd /volume1/Media/Emby

mv Emby.Mono.zip /volume1/@appstore/emby/share/emby

unzip /volume1/@appstore/emby/share/emby/Emby.Mono.zip 

Then select "A" to replace All.

 
Version 3.0.5821.0
 
Now to figure out why it isn't working with Kodi properly, off to read those forums.
Edited by KRULL
Link to comment
Share on other sites

 

 

4. Copy the contents of the zip file into /volume1/@appstore/emby/share/emby (or wherever it has been installed, the contents of the zip should look like the contents of the folder you are copying into)

 

 

like i said on the github issue already, you may should change that to /usr/local/emby/share/emby as it is not save that @appstore is saved on volume1 all the time... anyways like i already written in my mail i've got a huge step closer to finally get all this merged in and published on the website :) currently im waiting for code review and hopefully when that's done i can finally push empy to the repo *yeah*

  • Like 3
Link to comment
Share on other sites

like i said on the github issue already, you may should change that to /usr/local/emby/share/emby as it is not save that @appstore is saved on volume1 all the time... anyways like i already written in my mail i've got a huge step closer to finally get all this merged in and published on the website :) currently im waiting for code review and hopefully when that's done i can finally push empy to the repo *yeah*

& a big thanks for all the hard work in getting that far!

Can't wait to see Emby as a one-click-package installer

  • Like 1
Link to comment
Share on other sites

 

 

like i said on the github issue already, you may should change that to /usr/local/emby/share/emby as it is not save that @appstore is saved on volume1 all the time... anyways like i already written in my mail i've got a huge step closer to finally get all this merged in and published on the website :) currently im waiting for code review and hopefully when that's done i can finally push empy to the repo *yeah*

Just discovered emby (last time i looked at live TV solutions was 9+mo ago) this looks awesome, testing with my HDHomeRun and windows version of server.  I assume the quote above means i should probably wait for this to appear on the offical synology package source rather than a community one?  (sorry for being gum, but its my first post ;-) )

Link to comment
Share on other sites

 

 

 

Just discovered emby (last time i looked at live TV solutions was 9+mo ago) this looks awesome, testing with my HDHomeRun and windows version of server.  I assume the quote above means i should probably wait for this to appear on the offical synology package source rather than a community one?  (sorry for being gum, but its my first post ;-) )

 

Not sure whether this will be 'an official' package from the synology repo. It may still be a one-click package from the community repo.

But a one-click package will resolve the multi-step current install method. Which will make the install/upgrade a much simpler process.

 

You can still install Emby as per the guide on page 1 of this thread. Full functionality from installing in this way.

Edited by RobsterUK
Link to comment
Share on other sites

 

 

Not sure whether this will be 'an official' package from the synology repo. It may still be a one-click package from the community repo.
But a one-click package will resolve the multi-step current install method. Which will make the install/upgrade a much simpler process.

 

You can still install Emby as per the guide on page 1 of this thread. Full functionality from installing in this way.

Thanks!  I will wait for the one click from community repro.  I bought a NAS so i didn't have to mess around too much (i had a disaster of a home made NAS - i do have some SAS adapters around if anyone wants them - hahahahah).

The Homerun DVR SW is about as close as i want to get to messing with my NAS via SSH.

Link to comment
Share on other sites

I have a friend who installed the Syno package, he is reporting that all his watch statuses are not saving and changes to metadata and posters are not saving as well.

 

What could be wrong? It would seem to me that the directory that the database and images are possibly incorrect or something....

 

Thanks for any input. 

Link to comment
Share on other sites

Can we please see a monaco version for the D216play? I'd really love to get this working.

 

  • DS216play - synology_monaco_216play

 

Thanks!

Link to comment
Share on other sites

well there are technically some flaws on low cpu models... when it comes to transcoding.. basically if it's done you'll should be able to install emby on any device which can run mono/ffmpeg/imagemagick but transcoding might not work for all devices

Link to comment
Share on other sites

Did anyone manage to install Emby on the DS716+? It has an x64 Celeron processor (N3150), but the x64 packages can't be installed. There are no specific packages yet for the braswell architecture.

Link to comment
Share on other sites

Ok, I added the braswell architecture to the x64 packages for ImageMagick, ffmpeg and emby. All packages installed ok and the initial setup of emby went through without hickups.

 

EDIT:

Update doesn't work. After copying the files from Emby.Mono the package won't start.

 

EDIT2:

While setting everything up emby server stops randomly. Also Mono is using almost 5 GB of memory (and growing). So I'd say emby is not yet ready for use on DS716+ ... except as a Docker container, which runs fine.

 

EDIT3:

And stopped running fine because of some permission error. :\

Edited by peroksid
Link to comment
Share on other sites

  • 2 weeks later...
Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...