Jump to content


Photo

Movies not displayed in Emdy for Kodi?

emdy kody display thunmbnails

  • This topic is locked This topic is locked
12 replies to this topic

#1 tired dad OFFLINE  

tired dad

    Advanced Member

  • Members
  • 149 posts
  • Local time: 11:10 AM

Posted 23 June 2015 - 08:00 PM

Hello,

 

I installed v 1.0 of Emby for Kodi (14.2) with no issues a few days ago. The first time sync took a while, but all the posters showed up and I could play a movie. I added other accounts, and they too showed up without a hitch.

 

Upon rebooting the machine, I cannot see any thumbnails... the Arctic Zehpyr skin shows it is loading, and I see the number of movies and episodes in the top left, plus the sync message in the top right as it goes through my collection.  However, there is nothing in "Videos", "Movies", or the Emby plugin folders (accessed via the "Programs" shortcut) when that's done.  The system knows how many movies I had, but each and every folder shows "0" items.  I also do not see any recent additions, episodes, et cetera.

 

Zip. Nada. Nothing.  Turning the machine off, rebooting, chanting to a diety with a frog tied around my waist didn't help either.

 

Anyone else experiencing this?


Edited by tired dad, 23 June 2015 - 08:00 PM.


#2 handsomepete OFFLINE  

handsomepete

    Newbie

  • Members
  • 3 posts
  • Local time: 11:10 AM

Posted 23 June 2015 - 10:25 PM

I am facing the same issue. I think its because of the master lock code being set. The master lock code in kodi is not enabling master mode automatically and therefore you have to go to the quit submenu after logging in to enable master mode before you can see any content



#3 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 12623 posts
  • Local time: 04:10 AM

Posted 23 June 2015 - 10:58 PM

Yeah, masterlock is not compatible because we don't create any sources.xml. You can however, as a workaround copy the sources.xml (%appdata\Roaming\Kodi\userdata\) into the profile you are using (same\Kodi\userdata\profiles\{user}\)

I think this will allow you to see the content. 

 

Kodi thread: http://forum.kodi.tv....php?tid=182440



#4 tired dad OFFLINE  

tired dad

    Advanced Member

  • Members
  • 149 posts
  • Local time: 11:10 AM

Posted 23 June 2015 - 11:18 PM

Yeah, masterlock is not compatible because we don't create any sources.xml. You can however, as a workaround copy the sources.xml (%appdata\Roaming\Kodi\userdata\) into the profile you are using (same\Kodi\userdata\profiles\{user}\)

I think this will allow you to see the content. 

 

Kodi thread: http://forum.kodi.tv....php?tid=182440

Thanks, I'll remove the masterlock to see if that works. If I don't use a masterlock, how can I prevent my kids from logging in to the other accounts?

 

I had a look in the Kodi folder under the Roaming folder and I have no "sources.xml" listed


Edited by tired dad, 23 June 2015 - 11:43 PM.


#5 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 12623 posts
  • Local time: 04:10 AM

Posted 23 June 2015 - 11:42 PM

Do the workaround? .... This way you can have masterlock working. :P


Edited by Angelblue05, 23 June 2015 - 11:42 PM.


#6 tired dad OFFLINE  

tired dad

    Advanced Member

  • Members
  • 149 posts
  • Local time: 11:10 AM

Posted 24 June 2015 - 01:04 AM

Do the workaround? .... This way you can have masterlock working. :P

It would appear I need the sources.xml file for that and I cannot locate any on the C: drive under the user profile settings.  I uninstalled it and will try again tomorrow.



#7 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 12623 posts
  • Local time: 04:10 AM

Posted 24 June 2015 - 01:47 AM

@tired dad

 

Take the sources.xml - from your master profile... like when you go in Kodi\userdata\sources.xml it should already be there.



#8 CBers OFFLINE  

CBers

    Advanced Member

  • Moderators
  • 15039 posts
  • Local time: 10:10 AM
  • LocationKent, England.

Posted 24 June 2015 - 04:05 AM

Take the sources.xml - from your master profile... like when you go in Kodi\userdata\sources.xml it should already be there.

I've just had a look in my Kodi userdata folder on my Fire TV and Nexus Player and there is no sources.xml file.

I don't use masterlock, but thought I'd check.

.

Edited by CBers, 24 June 2015 - 05:45 AM.


#9 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 12623 posts
  • Local time: 04:10 AM

Posted 24 June 2015 - 04:14 AM

Ok, well if it's not there, use the one I've attached to see if it works. It's blank.

Attached Files



#10 tired dad OFFLINE  

tired dad

    Advanced Member

  • Members
  • 149 posts
  • Local time: 11:10 AM

Posted 28 June 2015 - 11:23 PM

Well, it's been interesting.... adding the source.xml did nothing until I added a video source myself. Then, only the folder that I added showed up in the movies section when the master lock was enabled (makes sense in a way, I guess).  Adding all the other folders sometimes resulted in duplicate movie posters (not sure why) showing and they were evidently reading from a different source as the same movie showed it as being in the IMDB top 250 once, but not when clicking on the identical psoter next to it.

 

Once, when I redid the library, adding only one source folder allowed all the movies across the folders to be shown, but only until I restarted.  Another time after redoing them, I peeked into the movie folder and it showed 12 of 73 movies.  After Kodi finished its internal synching, it still only showed twelve, no matter how many restarts were done.

 

As for the master lock and movies not showing in general for Kodi on multiple profiles --  regardless of Emby -- I find it curious that peole don't see that as a major issue as that bug has been around for a year or so.  I want different profiles so my kids don't se some movies, and I want a password so they can't get into mine. 

 

I guess this feature isn't quite ready for prime time if one wants multiple password protected profiles.


Edited by tired dad, 28 June 2015 - 11:25 PM.

  • Angelblue05 likes this

#11 tired dad OFFLINE  

tired dad

    Advanced Member

  • Members
  • 149 posts
  • Local time: 11:10 AM

Posted 28 June 2015 - 11:46 PM

I just tried it again by adding two sources under two movie categories (new and viewed)... all the other movies (that were not in those two folders, like "Kids", "Classics", etc) also showed up with master lock enabled.  Exiting and restarting shows that the movies are still there.  Success!  Or so I thought...

 

I removed one source folder and I am back down to 11 movies after restarting.  Of course this is not meeting with the WAF (Wife Acceptance Factor) if it is really this inconsistent.

 

The next step is gonig to be to put the second source back in (it helps that I have all these copies of the sources.xml file around) to see if that works.  Not sure why, but it seems to have helped the last two times, but I see nothing in the XML coding that looks different between those sources.  I may be able to get the duplicates gone by telling Kodi that there is nothing to scrape in those sourced folders and if that works it will possibly affect the other minor issue of the movie count being double what I really have.

 

If all that works, I will try a second profile with no password.  I'm glad vacation starts in two days so I can test this :-)


  • Angelblue05 likes this

#12 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 12623 posts
  • Local time: 04:10 AM

Posted 28 June 2015 - 11:50 PM

Keep us updated on your progress. I know some users are interested in using Master lock code. Unfortunately it makes the content disappear. If you figure out a way, please share the steps! :)



#13 tired dad OFFLINE  

tired dad

    Advanced Member

  • Members
  • 149 posts
  • Local time: 11:10 AM

Posted 29 June 2015 - 07:22 PM

So far, I've found that having a sources file with two paths seems to work to show the movies under the actual "Movies" section of Kodi, and displays all movies properly.  This means that you see the posters, can acccess the files, and when moving a movie from one folder to another as a test and refreshing Emby, the changes are reflected in Kodi.  The paths can be dummy paths, they don't have to point to anything, but you need two or it won't work.  See below for an example

 

<sources>
    <programs>
        <default pathversion="1"></default>
    </programs>
    <video>
        <default pathversion="1"></default>
        <source>
            <name>dummy one</name>
            <path pathversion="1">smb://kore/dummy new/</path>
            <allowsharing>true</allowsharing>
        </source>
        <source>
            <name>dummy two</name>
            <path pathversion="1">smb://kore/dummy viewed/</path>
            <allowsharing>true</allowsharing>
        </source>
    </video>
    <music>
        <default pathversion="1"></default>
    </music>
    <pictures>
        <default pathversion="1"></default>
    </pictures>
    <files>
        <default pathversion="1"></default>
    </files>


Now for the bad part... if you do this and then add another profile without a password (in both Kodi and Emby), the Emby script fails.  Deleting the non-protected user, removing the master lock, and then adding the user again does not work. So, I'm going to uninstall and resinstall again.

 

PS - Can an admin change my typo from "Emdy" to "Emby" in the subject line and tags?  Thanks :)


Edited by tired dad, 29 June 2015 - 07:23 PM.






Also tagged with one or more of these keywords: emdy, kody, display, thunmbnails

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users