Jump to content

Server Crashes when updated and restarted


ibeamadeus

Recommended Posts

The trouble I am having is with MB Server, currently on Version 3.0.5070.20258 (but this has happened on at least the last 5 updates of the server and It just happened this morning while updating from 3.0.4936.24198)

        

 

When I "restart the server to apply the update" from the web interface it hangs the webpage and when I reload it throws the "cannot find page error" I am doing this from my laptop via firefox, but the same thing occurs when going to the configuration page and restarting from the configure mediabrowser server link...

 

I then go into the actual profile that runs the server and I see the following errors:

 

-These Happen before I get to the server to manually restart and clear popups-

"Unhandled Exception: Only One Usage of Socket Address (protocal/network address/port) is normally permitted" -This comes up in 4 separate boxes at each update and restart

"Error Attempting to Update Application FileNotFoundException could not find file: 'C:\Users\MediaCenter\AppData\Roaming\Mediabrowser-Server\system\ionic.zip.dll'

 

Then I clear those boxes, the splash creen comes up then disappears, and throws the following popup box

"There was an error launching Media Browser:Could not load type 'MediaBrowser.Controller.Drawing.IImageProcessor' from assembly 'MediaBrowser.Controller, Version=3.0.4936.24198, Culture=neutral, PublicKeyToken=null'."

at the same time it throws the popup:

"Unhandled exception:The calling thread cannot access this object because a different thread owns it."

 

-After this I hit ok, then it appears as though MB3 Server closes as the process is gone and the try icon disappears,

-I start the server from the start menu and it loads without an issue...

 

Link to related server logs : https://www.dropbox.com/sh/3k1jhuukh71yd0f/A2SwwFDqer

Images of error popups attached.

 

 

Other info that might be relevant:

4th Gen i7 4770k

AsRock z87Fatal1ty Professional Mobo

32GB Ram (Corsair VLP)

EVGA GeForce GTX 760-Ti SSC Edition

Samsung SSD (OS Drive)

4 WD Red 3TB Storage Drives)

 

I also Run Plex (to serve Roku Media until the Roku Channel is a bit more stable)

Serviio as well to hit a couple blu-ray players...

I use Media Center Master to parse my metadata

post-1143-0-94006700-1384960065_thumb.jpg

post-1143-0-51450000-1384960066_thumb.jpg

post-1143-0-98707500-1384960066_thumb.jpg

post-1143-0-42724000-1384960067_thumb.jpg

Link to post
Share on other sites

Will do on the logs, What is the current version?  Am I way behind on updates somehow?  I've had 5 or six updates in the last week, (silly me for not checking the version numbers) and after each it said up to date...  Did I get stuck in some weird anti-update loop?

Link to post
Share on other sites

4936 is really old. that's going back several months. a lot has changed since then, including our update routines, so i'm not surprised there's an issue. i would suggest an uninstall followed by a clean install.

Link to post
Share on other sites

also please attach logs here in the forum going forward. it allows us to read them in the browser without having to first download from dropbox

Link to post
Share on other sites
  • 1 year later...

Can anyone please help me. i have emby on my Linux server (ubuntu 15.04) i have noticed that when i apply update throught the emby server site address it installs the update and then when it restarts it crashes and wont restart. this happens even if i just do a restart and the only way to start emby back up is through comand line. 

Can someone please help me to fix this problem as i would like to be able to just restart server directly from emby.

 

Eagerly awaiting your reply

Steve

Link to post
Share on other sites

This topic is two years old.  I applaud your searching beforehand but whatever you are encountering is undoubtedly something other than what this topic was and it is in Linux so I would start a new thread in that forum and provide a log.  Thanks.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...