Jump to content


Photo

default to external subtitle

subtitle external default

  • Please log in to reply
4 replies to this topic

#1 DancingMan OFFLINE  

DancingMan

    Advanced Member

  • Members
  • 31 posts
  • Local time: 04:28 PM

Posted 02 June 2015 - 12:02 PM

Is it possible to set my external subtitles to be the default?  I see that I can set subtitles to always be on, and I can set a particular language as the default.  Most of my mp4 movies have graphic subtitles in them (dvdsub), and for lots of them I also have external subtitle files (srt, sub).  If I have an internal english subtitle and an external english subtitle file, it seems like Emby uses the internal as the default (the attachment is from the bottom of Emby's WebUI for one of my movies).

 

Is there any way to set a system wide default to say "if there are external & internal subtitles for the default language, use the external subtitle"?

 

 

Attached Files



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146793 posts
  • Local time: 04:28 PM

Posted 02 June 2015 - 12:05 PM

it will favor the external subtitles but since the internal ones are marked as default they are taking priority. you can also mark the external ones as default by adding .default to the file name. so movie.eng.default.srt


  • overClocked! likes this

#3 FrostByte OFFLINE  

FrostByte

    Advanced Member

  • ForumMod
  • 4551 posts
  • Local time: 04:28 PM
  • LocationThe UP

Posted 02 June 2015 - 12:15 PM

Another way is to use a tool like mkvmerge and mark the internal one as default = no.  Luke's method is quicker though


Edited by FrostByte, 02 June 2015 - 12:17 PM.


#4 DancingMan OFFLINE  

DancingMan

    Advanced Member

  • Members
  • 31 posts
  • Local time: 04:28 PM

Posted 02 June 2015 - 01:17 PM

That set the language to default for the external subtitle (see attachment).  Should it be movie.default.eng.srt?

Attached Files



#5 DancingMan OFFLINE  

DancingMan

    Advanced Member

  • Members
  • 31 posts
  • Local time: 04:28 PM

Posted 04 June 2015 - 10:25 AM

After more investigation, it seems like I made my mp4s and included the graphic subtitles in them (dvdsub) and did not set them as a default.  The programs I used (VidCoder, Handbrake, & ffmpeg) seem to have taken it upon themselves to mark my subtitle stream as default and add a second (text) subtitle that lists the current chapter.  I can't seem to get rid of the second stream - whether I try to completely transcode the file or just use ffmpeg to copy the video stream, audio stream, and only my graphic subtitle stream (without setting it as default); that second subtitle stream reappears and my subtitles are set to default.

 

Any ideas?  If there's some way in emby to tell it to ignore the default subtitle setting in the mp4, that would be fine (but unfortunately Luke says there isn't).  The next best option would be some sort of batch method - for example, I have a script that will go through a list of files and run ffmpeg on each one to copy streams to another container; I would just need to know what switch to include to make sure the second subtitle stream isn't made and my subtitle stream isn't set to default.

Attached Files







Also tagged with one or more of these keywords: subtitle, external, default

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users